Recent Video Drivers and PCIe cards on PowerMac 11,2.
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    matt3
    Posts: 658 from 2004/2/10
    I was wondering if anyone tried more of the recent cards with MorphOS and a PCIe PowerMac system.

    I was looking at picking another card and was looking for the best performing option that is functioning with the latest beta of the drivers.
  • »07.09.23 - 21:07
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    connor
    Posts: 570 from 2007/7/29
    I am also curious. Can the new cards that are supported be used with 4K screensize?
  • »07.09.23 - 21:24
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    matt3
    Posts: 658 from 2004/2/10
    Quote:

    connor wrote:
    I am also curious. Can the new cards that are supported be used with 4K screensize?


    I think it might work but the video card would need an HDMI or Displayport as DVI will not work.

    I have a 4k monitor as one of my displays (I use 2 with MorphOS), but my video card only has DVI out. MorphOS list the 4k resolutions in system preferences just fine, but for now I'm using 1600x1200 on it as 4k will display garbled (due to DVI is lmiting it).

    I'm using an Acer 27" 1080P monitor and a ViewSonic 27" VP2768a-4k. The viewsonic has a ton of inputs and I'm using and DVI to HDMI cable for it.

    That is why I want to try a different card with the Beta drivers.

    [ Edited by matt3 08.09.2023 - 08:44 ]
  • »08.09.23 - 13:41
    Profile
  • Moderator
    Kronos
    Posts: 2236 from 2003/2/24
    Quote:

    matt3 wrote:

    I have a 4k monitor as one of my displays (I use 2 with MorphOS), but my video card only has DVI out. MorphOS list the 4k resolutions in system preferences just fine, but for now I'm using 1600x1200 on it as 4k will display garbled (due to DVI is lmiting it).


    DualLink DVI can do 4k@30Hz, but..... there is a HW limit in these older cards that limits some function at around 3000 pixels width (can't remember the exact number) and as such MorphOS will limit the resolution to that number.
    Some of the newer PCIe cards (I only tested it with 9650-AGP and a PowerBook) might be able to go full 3840 and should also be able to do over DVI.

    [ Edited by Kronos 08.09.2023 - 16:19 ]
  • »08.09.23 - 15:17
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    connor
    Posts: 570 from 2007/7/29
    Quote:

    matt3 wrote:
    Quote:

    connor wrote:
    I am also curious. Can the new cards that are supported be used with 4K screensize?


    I think it might work but the video card would need an HDMI or Displayport


    this is usually present in the newer graphics cards, no problem. Can MorphOS handle 4K in 60 Hz?
  • »08.09.23 - 16:43
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    ernsteiswuerfel
    Posts: 545 from 2015/6/18
    From: Funeralopolis
    Quote:

    connor schrieb:
    Quote:

    matt3 wrote:
    Quote:

    connor wrote:
    I am also curious. Can the new cards that are supported be used with 4K screensize?

    I think it might work but the video card would need an HDMI or Displayport


    this is usually present in the newer graphics cards, no problem. Can MorphOS handle 4K in 60 Hz?


    Don't know about MorphOS itself but there is no current card supported by MorphOS which is able to do 4K-60Hz.

    You would at least need a Volcanic Islands card, which would be a Radeon R9 285. Latest MorphOS supported cards are of Northern Islands generation. See: https://www.x.org/wiki/RadeonFeature/#radeongraphicscomputehardware
    Talos II. [Gentoo Linux] | PMac G5 11,2. PMac G4 3,6. PBook G4 5,8. [MorphOS 3.18 / Gentoo Linux] | Vampire V4 SA [ApolloOS / Amiga OS 3.2.2]
  • »10.09.23 - 14:33
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    ernsteiswuerfel
    Posts: 545 from 2015/6/18
    From: Funeralopolis
    Also seems to be the perfect thread to provide @cyfm some info he asked about on working/non-working cards on the G5 11,2 here in another thead. ;-)

    I am starting with here with my current 3 single-slot cards fitting nicely in the G5 11,2 besides the original Nvidia one. Data gathered on Linux on the G5 via lspci.
    Talos II. [Gentoo Linux] | PMac G5 11,2. PMac G4 3,6. PBook G4 5,8. [MorphOS 3.18 / Gentoo Linux] | Vampire V4 SA [ApolloOS / Amiga OS 3.2.2]
  • »10.09.23 - 15:12
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    ernsteiswuerfel
    Posts: 545 from 2015/6/18
    From: Funeralopolis
    Dell Radeon X1300 Pro, 256 MiB, P/N: 102-A6762631, VGA/S-Video/DVI-I, Generation: R500 PCIe
    Works on MorphOS 3.18!

    Code:
     # lspci -vv -s 0001:06:00.0
    0001:06:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV516 [Radeon X1300/X1550 Series] (prog-if 00 [VGA controller])
    Subsystem: Dell RV516 [Radeon X1300/X1550 Series]
    Device tree node: /sys/firmware/devicetree/base/ht@0,f2000000/pci@3/pci1028,302@0
    Control: I/O- Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 65
    Region 0: Memory at 90000000 (64-bit, prefetchable) [disabled] [size=256M]
    Region 2: Memory at 80110000 (64-bit, non-prefetchable) [disabled] [size=64K]
    Region 4: I/O ports at <ignored> [disabled] [size=256]
    Expansion ROM at 80120000 [disabled] [size=128K]
    Capabilities: [50] Power Management version 2
    Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
    Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
    Capabilities: [58] Express (v1) Endpoint, MSI 00
    DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited
    ExtTag+ AttnBtn- AttnInd- PwrInd- RBE- FLReset- SlotPowerLimit 0W
    DevCtl: CorrErr- NonFatalErr- FatalErr- UnsupReq-
    RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
    MaxPayload 128 bytes, MaxReadReq 128 bytes
    DevSta: CorrErr- NonFatalErr- FatalErr- UnsupReq- AuxPwr- TransPend-
    LnkCap: Port #0, Speed 2.5GT/s, Width x16, ASPM L0s L1, Exit Latency L0s <64ns, L1 <1us
    ClockPM- Surprise- LLActRep- BwNot- ASPMOptComp-
    LnkCtl: ASPM Disabled; RCB 64 bytes, Disabled- CommClk-
    ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
    LnkSta: Speed 2.5GT/s, Width x8 (downgraded)
    TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
    Capabilities: [80] MSI: Enable- Count=1/1 Maskable- 64bit+
    Address: 0000000000000000 Data: 0000
    Kernel modules: radeon
    Talos II. [Gentoo Linux] | PMac G5 11,2. PMac G4 3,6. PBook G4 5,8. [MorphOS 3.18 / Gentoo Linux] | Vampire V4 SA [ApolloOS / Amiga OS 3.2.2]
  • »10.09.23 - 15:16
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    ernsteiswuerfel
    Posts: 545 from 2015/6/18
    From: Funeralopolis
    HIS HD 5550 Silence, 1024 MiB, P/N: H557HO1G, VGA/HDMI/DVI-I, Generation: Evergreen
    Does not work on MorphOS 3.18 (screen stays blank).

    Code:
     # lspci -vv -s 0001:06:00.0
    0001:06:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Redwood PRO [Radeon HD 5550/5570/5630/6510/6610/7570] (prog-if 00 [VGA controller])
    Subsystem: Hightech Information System Ltd. Redwood PRO [Radeon HD 5550/5570/5630/6510/6610/7570]
    Device tree node: /sys/firmware/devicetree/base/ht@0,f2000000/pci@3/pci1787,2009@0
    Control: I/O- Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 65
    Region 0: Memory at 90000000 (64-bit, prefetchable) [disabled] [size=256M]
    Region 2: Memory at 80140000 (64-bit, non-prefetchable) [disabled] [size=128K]
    Region 4: I/O ports at <ignored> [disabled] [size=256]
    Expansion ROM at 80120000 [disabled] [size=128K]
    Capabilities: [50] Power Management version 3
    Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
    Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
    Capabilities: [58] Express (v2) Legacy Endpoint, MSI 00
    DevCap: MaxPayload 256 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited
    ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
    DevCtl: CorrErr- NonFatalErr- FatalErr- UnsupReq-
    RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
    MaxPayload 128 bytes, MaxReadReq 512 bytes
    DevSta: CorrErr+ NonFatalErr- FatalErr- UnsupReq+ AuxPwr- TransPend-
    LnkCap: Port #0, Speed 2.5GT/s, Width x16, ASPM L0s L1, Exit Latency L0s <64ns, L1 <1us
    ClockPM- Surprise- LLActRep- BwNot- ASPMOptComp-
    LnkCtl: ASPM Disabled; RCB 64 bytes, Disabled- CommClk-
    ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
    LnkSta: Speed 2.5GT/s, Width x8 (downgraded)
    TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
    DevCap2: Completion Timeout: Range ABCD, TimeoutDis+ NROPrPrP- LTR-
    10BitTagComp- 10BitTagReq- OBFF Not Supported, ExtFmt- EETLPPrefix-
    EmergencyPowerReduction Not Supported, EmergencyPowerReductionInit-
    FRS-
    AtomicOpsCap: 32bit- 64bit- 128bitCAS-
    DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis- LTR- 10BitTagReq- OBFF Disabled,
    AtomicOpsCtl: ReqEn-
    LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-
    Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
    Compliance Preset/De-emphasis: -6dB de-emphasis, 0dB preshoot
    LnkSta2: Current De-emphasis Level: -6dB, EqualizationComplete- EqualizationPhase1-
    EqualizationPhase2- EqualizationPhase3- LinkEqualizationRequest-
    Retimer- 2Retimers- CrosslinkRes: unsupported
    Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
    Address: 0000000000000000 Data: 0000
    Kernel modules: radeon
    Talos II. [Gentoo Linux] | PMac G5 11,2. PMac G4 3,6. PBook G4 5,8. [MorphOS 3.18 / Gentoo Linux] | Vampire V4 SA [ApolloOS / Amiga OS 3.2.2]
  • »10.09.23 - 15:24
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    ernsteiswuerfel
    Posts: 545 from 2015/6/18
    From: Funeralopolis
    Sapphire HD 4550 HyperMemory, 512 MiB, SKU: 11141-06, VGA/HDMI/DVI-I, Generation: R700
    Works on MorphOS 3.18!

    Code:
     # lspci -vv -s 0001:06:00.0
    0001:06:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV710 [Radeon HD 4350/4550] (prog-if 00 [VGA controller])
    Subsystem: PC Partner Limited / Sapphire Technology RV710 [Radeon HD 4350/4550]
    Device tree node: /sys/firmware/devicetree/base/ht@0,f2000000/pci@3/pci174b,e106@0
    Control: I/O- Mem- BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 65
    Region 0: Memory at 90000000 (64-bit, prefetchable) [disabled] [size=256M]
    Region 2: Memory at 80110000 (64-bit, non-prefetchable) [disabled] [size=64K]
    Region 4: I/O ports at <ignored> [disabled] [size=256]
    Expansion ROM at 80120000 [disabled] [size=128K]
    Capabilities: [50] Power Management version 3
    Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
    Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
    Capabilities: [58] Express (v2) Legacy Endpoint, MSI 00
    DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited
    ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
    DevCtl: CorrErr- NonFatalErr- FatalErr- UnsupReq-
    RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
    MaxPayload 128 bytes, MaxReadReq 128 bytes
    DevSta: CorrErr- NonFatalErr- FatalErr- UnsupReq- AuxPwr- TransPend-
    LnkCap: Port #0, Speed 2.5GT/s, Width x16, ASPM L0s L1, Exit Latency L0s <64ns, L1 <1us
    ClockPM- Surprise- LLActRep- BwNot- ASPMOptComp-
    LnkCtl: ASPM Disabled; RCB 64 bytes, Disabled- CommClk-
    ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
    LnkSta: Speed 2.5GT/s, Width x8 (downgraded)
    TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
    DevCap2: Completion Timeout: Not Supported, TimeoutDis- NROPrPrP- LTR-
    10BitTagComp- 10BitTagReq- OBFF Not Supported, ExtFmt- EETLPPrefix-
    EmergencyPowerReduction Not Supported, EmergencyPowerReductionInit-
    FRS-
    AtomicOpsCap: 32bit- 64bit- 128bitCAS-
    DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis- LTR- 10BitTagReq- OBFF Disabled,
    AtomicOpsCtl: ReqEn-
    LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-
    Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
    Compliance Preset/De-emphasis: -6dB de-emphasis, 0dB preshoot
    LnkSta2: Current De-emphasis Level: -6dB, EqualizationComplete- EqualizationPhase1-
    EqualizationPhase2- EqualizationPhase3- LinkEqualizationRequest-
    Retimer- 2Retimers- CrosslinkRes: unsupported
    Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
    Address: 0000000000000000 Data: 0000
    Kernel modules: radeon
    Talos II. [Gentoo Linux] | PMac G5 11,2. PMac G4 3,6. PBook G4 5,8. [MorphOS 3.18 / Gentoo Linux] | Vampire V4 SA [ApolloOS / Amiga OS 3.2.2]
  • »10.09.23 - 15:25
    Profile
  • man
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    man
    Posts: 105 from 2019/11/11
    HIS HD 5550 Silence, 1024 MiB, P/N: H557HO1G, VGA/HDMI/DVI-I, Generation: Evergreen
    Does not work on MorphOS 3.18 (screen stays blank).

    i think up to 512 mib not work perhaps
  • »10.09.23 - 19:35
    Profile
  • man
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    man
    Posts: 105 from 2019/11/11
    HIS HD 5550 Silence, 1024 MiB, P/N: H557HO1G, VGA/HDMI/DVI-I, Generation: Evergreen
    Does not work on MorphOS 3.18 (screen stays blank).

    i think up to 512 mib not work perhaps
  • »10.09.23 - 19:37
    Profile
  • man
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    man
    Posts: 105 from 2019/11/11
    x1950 512 mib not work only 256 miB
  • »10.09.23 - 19:44
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    ernsteiswuerfel
    Posts: 545 from 2015/6/18
    From: Funeralopolis
    Quote:

    man schrieb:
    I think up to 512 mib not work perhaps

    My HD4550 got 512 M1B and it works.

    But maybe you got a point here! The other cards I tried all were 1024 MiB and they did not work. Probably a hint.
    Talos II. [Gentoo Linux] | PMac G5 11,2. PMac G4 3,6. PBook G4 5,8. [MorphOS 3.18 / Gentoo Linux] | Vampire V4 SA [ApolloOS / Amiga OS 3.2.2]
  • »16.09.23 - 16:02
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    ernsteiswuerfel
    Posts: 545 from 2015/6/18
    From: Funeralopolis
    HIS 6570 Silence, 1024 MiB, P/N: H657HO1G, VGA/HDMI/DVI-I, Generation: Northern Islands
    Does not work on MorphOS 3.18 (screen stays blank).

    Code:
     # lspci -vv -s 0001:06:00.0
    0001:06:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Turks PRO [Radeon HD 6570/7570/8550 / R5 230] (prog-if 00 [VGA controller])
    Subsystem: Hightech Information System Ltd. Turks PRO [Radeon HD 6570/7570/8550 / R5 230]
    Device tree node: /sys/firmware/devicetree/base/ht@0,f2000000/pci@3/pci1787,2012@0
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 65
    Region 0: Memory at 90000000 (64-bit, prefetchable) [size=256M]
    Region 2: Memory at 80140000 (64-bit, non-prefetchable) [size=128K]
    Region 4: I/O ports at 0000 [size=256]
    Expansion ROM at 80120000 [disabled] [size=128K]
    Capabilities: [50] Power Management version 3
    Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
    Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
    Capabilities: [58] Express (v2) Legacy Endpoint, MSI 00
    DevCap: MaxPayload 256 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited
    ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
    DevCtl: CorrErr- NonFatalErr- FatalErr- UnsupReq-
    RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
    MaxPayload 128 bytes, MaxReadReq 512 bytes
    DevSta: CorrErr+ NonFatalErr- FatalErr- UnsupReq+ AuxPwr- TransPend-
    LnkCap: Port #0, Speed 2.5GT/s, Width x16, ASPM L0s L1, Exit Latency L0s <64ns, L1 <1us
    ClockPM- Surprise- LLActRep- BwNot- ASPMOptComp-
    LnkCtl: ASPM Disabled; RCB 64 bytes, Disabled- CommClk-
    ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
    LnkSta: Speed 2.5GT/s, Width x8 (downgraded)
    TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
    DevCap2: Completion Timeout: Not Supported, TimeoutDis- NROPrPrP- LTR-
    10BitTagComp- 10BitTagReq- OBFF Not Supported, ExtFmt- EETLPPrefix-
    EmergencyPowerReduction Not Supported, EmergencyPowerReductionInit-
    FRS-
    AtomicOpsCap: 32bit- 64bit- 128bitCAS-
    DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis- LTR- 10BitTagReq- OBFF Disabled,
    AtomicOpsCtl: ReqEn-
    LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-
    Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
    Compliance Preset/De-emphasis: -6dB de-emphasis, 0dB preshoot
    LnkSta2: Current De-emphasis Level: -6dB, EqualizationComplete- EqualizationPhase1-
    EqualizationPhase2- EqualizationPhase3- LinkEqualizationRequest-
    Retimer- 2Retimers- CrosslinkRes: unsupported
    Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
    Address: 0000000000000000 Data: 0000
    Kernel driver in use: radeon
    Kernel modules: radeon
    Talos II. [Gentoo Linux] | PMac G5 11,2. PMac G4 3,6. PBook G4 5,8. [MorphOS 3.18 / Gentoo Linux] | Vampire V4 SA [ApolloOS / Amiga OS 3.2.2]
  • »16.09.23 - 16:05
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    ernsteiswuerfel
    Posts: 545 from 2015/6/18
    From: Funeralopolis
    Sapphire HD 5450 Low Profile, 1024 MiB, SKU: 11166-02, VGA/HDMI/DVI-I, Generation: Evergreen
    Does not work on MorphOS 3.18 (screen stays blank).

    Code:
    # lspci -vv -s 0001:06:00.0
    0001:06:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Park [Mobility Radeon HD 5430] (prog-if 00 [VGA controller])
    Subsystem: PC Partner Limited / Sapphire Technology Caicos [Radeon HD 5450]
    Device tree node: /sys/firmware/devicetree/base/ht@0,f2000000/pci@3/pci174b,6000@0
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0, Cache Line Size: 64 bytes
    Interrupt: pin A routed to IRQ 65
    Region 0: Memory at 90000000 (64-bit, prefetchable) [size=256M]
    Region 2: Memory at 80140000 (64-bit, non-prefetchable) [size=128K]
    Region 4: I/O ports at 0000 [size=256]
    Expansion ROM at 80120000 [disabled] [size=128K]
    Capabilities: [50] Power Management version 3
    Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
    Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
    Capabilities: [58] Express (v2) Legacy Endpoint, MSI 00
    DevCap: MaxPayload 256 bytes, PhantFunc 0, Latency L0s <4us, L1 unlimited
    ExtTag+ AttnBtn- AttnInd- PwrInd- RBE+ FLReset-
    DevCtl: CorrErr- NonFatalErr- FatalErr- UnsupReq-
    RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop+
    MaxPayload 128 bytes, MaxReadReq 512 bytes
    DevSta: CorrErr+ NonFatalErr- FatalErr- UnsupReq+ AuxPwr- TransPend-
    LnkCap: Port #0, Speed 2.5GT/s, Width x16, ASPM L0s L1, Exit Latency L0s <64ns, L1 <1us
    ClockPM- Surprise- LLActRep- BwNot- ASPMOptComp-
    LnkCtl: ASPM Disabled; RCB 64 bytes, Disabled- CommClk-
    ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
    LnkSta: Speed 2.5GT/s, Width x8 (downgraded)
    TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
    DevCap2: Completion Timeout: Range ABCD, TimeoutDis+ NROPrPrP- LTR-
    10BitTagComp- 10BitTagReq- OBFF Not Supported, ExtFmt- EETLPPrefix-
    EmergencyPowerReduction Not Supported, EmergencyPowerReductionInit-
    FRS-
    AtomicOpsCap: 32bit- 64bit- 128bitCAS-
    DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis- LTR- 10BitTagReq- OBFF Disabled,
    AtomicOpsCtl: ReqEn-
    LnkCtl2: Target Link Speed: 2.5GT/s, EnterCompliance- SpeedDis-
    Transmit Margin: Normal Operating Range, EnterModifiedCompliance- ComplianceSOS-
    Compliance Preset/De-emphasis: -6dB de-emphasis, 0dB preshoot
    LnkSta2: Current De-emphasis Level: -6dB, EqualizationComplete- EqualizationPhase1-
    EqualizationPhase2- EqualizationPhase3- LinkEqualizationRequest-
    Retimer- 2Retimers- CrosslinkRes: unsupported
    Capabilities: [a0] MSI: Enable- Count=1/1 Maskable- 64bit+
    Address: 0000000000000000 Data: 0000
    Kernel driver in use: radeon
    Kernel modules: radeon
    Talos II. [Gentoo Linux] | PMac G5 11,2. PMac G4 3,6. PBook G4 5,8. [MorphOS 3.18 / Gentoo Linux] | Vampire V4 SA [ApolloOS / Amiga OS 3.2.2]
  • »16.09.23 - 16:07
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    ernsteiswuerfel
    Posts: 545 from 2015/6/18
    From: Funeralopolis
    Ok, so far I tried 4 cards which would be suitable for bigfoots r600 driver.

    Of the 4 cards the only one which works on my G5 11,2 is the Radeon HD4550, 512 MiB, Generation R700.

    The other 3 cards which did not work on MorphOS were of Evergreen and Northern Islands generation and all got 1024 MiB RAM.
    Talos II. [Gentoo Linux] | PMac G5 11,2. PMac G4 3,6. PBook G4 5,8. [MorphOS 3.18 / Gentoo Linux] | Vampire V4 SA [ApolloOS / Amiga OS 3.2.2]
  • »16.09.23 - 16:10
    Profile
  • man
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    man
    Posts: 105 from 2019/11/11
    ok
    so what s the best card for powermac g5
  • »16.09.23 - 20:01
    Profile
  • MorphOS Developer
    zukow
    Posts: 642 from 2005/2/9
    From: Poland
    still R500, X1950XT
  • »16.09.23 - 21:49
    Profile Visit Website
  • man
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    man
    Posts: 105 from 2019/11/11
    ok thanks for answers
  • »17.09.23 - 10:49
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    matt3
    Posts: 658 from 2004/2/10
    Wanted to share that I got high resolutions screens working in MorphOS on my 4k monitor.

    Right now I running in Ambient in 2560 x 1440 24bit and it works perfect so far, real nice to have serious real estate to use. I probably can get 3840 x 2160 working with more playing around but this resolution is really as high as I want to go on 27" So who would have thought that 4k was available in MorphOS.

    I also had to tweak one of the screenmodes in Monitors to get them working, just copied a working lower resolution one and used that as a basis.

    I'm using my same X1900 PPC Bios PCIe video card and I'm using a cheap DVI to DP converter. Please make sure you get the powered version of the converter or it will NOT work.
  • »21.09.23 - 17:21
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    matt3
    Posts: 658 from 2004/2/10
    Quote:

    Andreas_Wolf wrote:
    > who would have thought that 4k was available in MorphOS.

    Everyone who reads MorphOS release news items or release notes ;-)

    "MorphOS 3.8 also adds the ability to use state-of-the-art 4K displays in their native resolution."
    https://morph.zone/modules/news/article_storyid_2215.html

    "Allow up to 3840 pixel wide screens on R400 GPUs and above to support 4K display resolutions"
    https://www.morphos-team.net/releasenotes/3.8


    Thanks for keeping me honest Andreas!

    :)
  • »21.09.23 - 19:27
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    matt3
    Posts: 658 from 2004/2/10
    I did find one issue thus far with Mplayer in that it refuses to play anything at this resolutions. If I back down to 1920 x 1200, no problem everything plays (although it does seem a bit slower in playback then when I was using 1600x1200).

    Mplayer is getting really long in the tooth and could really use an update, is anyone maintaining it these days?

    I also might pick up a 1950XT since that seems to work fine in PM's and should give a boost or maybe I will holdout to see where bigfoot's drivers yield good results.



    [ Edited by matt3 21.09.2023 - 14:33 ]
  • »21.09.23 - 19:32
    Profile