New Modern Webkit-based Browser In Development
  • MorphOS Developer
    jacadcaps
    Posts: 2759 from 2003/3/5
    From: Canada
    Sneak peak of Dark Mode in the upcoming Wayfarer 2.0 release

    Youtube
  • »17.06.21 - 12:30
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    MoerBoer
    Posts: 189 from 2019/10/15
    Very cool!
  • »17.06.21 - 13:06
    Profile
  • Caterpillar
    Caterpillar
    Puni
    Posts: 33 from 2020/7/21
    From: Norway
    Nice! :-)
    Member of Void - An Amiga demo group (website)
  • »17.06.21 - 16:41
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    ernsteiswuerfel
    Posts: 491 from 2015/6/18
    From: Funeralopolis
    Ah, how very nice! (The Return of Darkness and Evil)
    Talos II. [Gentoo Linux] | PMac G5 11,2. PMac G4 3,6. PBook G4 5,8. [MorphOS 3.17 / Void Linux / Gentoo Linux] | Vampire V4 SA [ApolloOS / Amiga OS 3.2.1]
  • »17.06.21 - 19:25
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    vulture
    Posts: 182 from 2008/2/4
    From: Greece
    Ah! That's more like it! :)
  • »18.06.21 - 20:31
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Cool_amigaN
    Posts: 713 from 2011/11/30
    Eager to try the new version but I am getting the following error: Wayfarer requires ICU files in MOSSYS:Data/ICU/icudt67b :/
    Amiga gaming Tribute: Watch, rate, comment :)
  • »19.06.21 - 22:43
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Posts: 2759 from 2003/3/5
    From: Canada
    Wayfarer 2.0 is now available for download. Please note that you MUST move the included ICU files (in MOSSYS/Data/ICU to the respective MOSSYS path).

    - Rebased to latest stable WebKitGTK (2.32.1)
    - Implemented Dark Mode
    - Fixed a crash in HLS video playback
    - Worked around an issue preventing sites from loading, etc after quit confirmation requester got cancelled
    - Fixed webkit message log functionality that crashed if the resulting message contained formatting sequences
    - Changed rendering of elements like checkmarks that were missing on some websites
    - Out-of-RAM crashes no longer bring up the Send Bugreport messagebox

    While the 'Rebased to latest stable WebKitGTK (2.32.1)' entry may seem insignificant, it was actually quite a bit of work to get this to run smoothly. There were several endianness regressions (bugs) in JavaScriptCore that I've tracked down and fixed together with Daniel Kolesa (Void Linux). Many, many interfaces in WebCore have changed and those changes had to be reflected in my code (even if they were simple type/enum changes 70% of the time). Still, a working rebase proves that there's future for Wayfarer and 1.x wasn't just a one-off.

    [ Edited by jacadcaps 20.06.2021 - 02:10 ]
  • »19.06.21 - 22:51
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    tolkien
    Posts: 473 from 2013/5/29
    Awesome!
    Cant wait to try it.
    Thanks so much Jacadcaps! Bravo!
    MorphOS: PowerMac G5 - PowerBook G4 - MacMini.
    Classic: Amiga 1200/060 - A500 PiStorm
  • »19.06.21 - 23:17
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    analogkid
    Posts: 628 from 2004/11/3
    From: near myself
    Thanks for this awesome release! Very stable and fast. One question, I'm still not able to download archives from Bandcamp. On-site playing works very well, but downloading archives with the Mp3 or FLAC files still gives me an "There was an error preparing your download." error. Is there some special magic to get this working?
  • »20.06.21 - 18:26
    Profile
  • jPV
  • Paladin of the Pegasos
    Paladin of the Pegasos
    jPV
    Posts: 1929 from 2003/2/24
    From: po-RNO
    Quote:

    analogkid wrote:
    One question, I'm still not able to download archives from Bandcamp. On-site playing works very well, but downloading archives with the Mp3 or FLAC files still gives me an "There was an error preparing your download." error. Is there some special magic to get this working?

    Are you trying to download them immediately after a purchase or later when you have logged into Bandcamp? I've had difficulties to download after a purchase for some time now (it used to work long time ago), but when I now logged into my account and tried to download from my collection, it seems to work. I changed between formats few times.. and once it gave me the error with FLAC, but then it instructed to reload the page and then I was able to prepare it in many formats including the FLAC... so.. it seems to work quite ok now... I haven't tried to buy anything with the latest Wayfarer, but if there's a problem then you probably can work-around it by downloading the purchases from your collection.
  • »20.06.21 - 19:40
    Profile Visit Website
  • Paladin of the Pegasos
    Paladin of the Pegasos
    NewSense
    Posts: 1318 from 2012/11/10
    From: Manchester, UK/GB
    Wayfarer v2.0 seems fairly stable for me, but videos on the Formula1 website still seem to stall/timer stops at 0:08s, often at which point the audio ends, even though sometimes the video plays to the end of the clip 0:49s, though when it gets to the end of the clip I sometimes get "Could not download the video, Error Code: PLAYER_ERR_TIMEOUT, Session ID: 2021-06-20:50e7eb4d5164135796015c4e Player Element ID: 1703091379004867301" or "Could not download the video, Error Code: PLAYER_ERR_TIMEOUT, Session ID: 2021-06-21:65695e30fdd6ec64303c89e1 Player Element ID: 1703103602357171155" - just 2 examples.

    I never got that error message in any of the earlier 1.xx versions of Wayfarer, though it could obviously just be a co-incidence to get these messages now.

    Also, I've noticed that when using the mouse middle-wheel to scroll through text that I'm writing into a text entry field of a web-page, and also when I'm trying to scroll though a message, or message list, within my webmail or any other pre-written text entry field where the text extends with scrollbars then the middle-wheel scrolls the page itself, but fails to scroll within the text field on that webpage.

    An example of this behaviour would be as on MorphOS Storage - FlipClock_1.1.lha where there is a ReadMe section that extends further down the page, out of view, but you have to use the right hand scroll gadget to scroll the text with v2.0, whereas with v1.21 it does what it should and scrolls with the middle-mouse wheel when the cursor is hovered over the ReadMe text field, so that needs fixing.

    This failure to scroll behaviour was apparent with writing this text on M-Zone as the text I wrote generated scrollbars but I had to use the scrollbars to move to the top of the text, unless I used the cursor, or Ctrl+Home/End, to move within the field up/down to an area that was above what was in view.

    Also, when you access the MorphOS-Storage page to access the data held on FlipClock_1.1.lha it fails to load the details into the URL field of "https://www.morphos-storage.net/?id=1647969", as the "/?id=1647969" part is missing from the entry, and probably this is the case for many websites or other inputs into the URL field
    MacMini 1.5GHz,64MB VRAM, PowerBooks A1138/9 (Model 5,8/9),PowerMac G5 2.3GHz(DP), iMac A1145 2.1GHz 20", all with MorphOS v3.17,Airport,Bluetooth,A1016 Keyboard,T-RB22 Mouse,DVD-RW-DL,MiniMax,Firewire/USB2 & MacOSX 10.4/5.
  • »21.06.21 - 01:48
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    analogkid
    Posts: 628 from 2004/11/3
    From: near myself
    Quote:

    jPV wrote:
    Are you trying to download them immediately after a purchase or later when you have logged into Bandcamp? I've had difficulties to download after a purchase for some time now (it used to work long time ago), but when I now logged into my account and tried to download from my collection, it seems to work. I changed between formats few times.. and once it gave me the error with FLAC, but then it instructed to reload the page and then I was able to prepare it in many formats including the FLAC... so.. it seems to work quite ok now... I haven't tried to buy anything with the latest Wayfarer, but if there's a problem then you probably can work-around it by downloading the purchases from your collection.


    Both doesn't work, neither downloading from my collection nor immediately after purchasing. I'm getting the same error message. It used to work in an very early version of Wayfarer, in the first one or two public releases.
  • »21.06.21 - 03:56
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Templario
    Posts: 482 from 2012/4/28
    Well, also there is the problem when your system hasn't the name MOSSYS and how in my case I have the name System, Wayfarer neither works although you have copied the ICU Data in System:Data/ICU
  • »21.06.21 - 10:35
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    tolkien
    Posts: 473 from 2013/5/29
    Mossys: is "system:morphos/" so you must copy to "system:morphos/data/icu".

    Mossys: is where the OS install oficial libs, devs, C, etc etc....
    System is where user install user libs, c commands etc etc.
    MorphOS: PowerMac G5 - PowerBook G4 - MacMini.
    Classic: Amiga 1200/060 - A500 PiStorm
  • »21.06.21 - 11:27
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Templario
    Posts: 482 from 2012/4/28
    Quote:

    tolkien escribió:
    Mossys: is "system:morphos/" so you must copy to "system:morphos/data/icu".

    Mossys: is where the OS install oficial libs, devs, C, etc etc....
    System is where user install user libs, c commands etc etc.

    Thank you for your help, now Wayfarer works, I though in the other drawer Data instead of this MorphOS/Data
  • »21.06.21 - 19:23
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2759 from 2003/3/5
    From: Canada
    Wayfarer 2.1 is now out.

    - ICU files will now be loaded from PROGDIR if missing in MOSSYS
    - Updated EasyList adblocker data
    - Fixed wheel scrolling in subframes
    - Fixed a race condition in HLS player
    - Fixed a widely reported crash in H264 decoding
    - Fixed a potential crash in bookmarks code

    Just a reminder: update Wayfarer by copying all of the files included in the LHA onto your current installation, overwriting existing files.
  • »22.06.21 - 20:14
    Profile Visit Website
  • Paladin of the Pegasos
    Paladin of the Pegasos
    NewSense
    Posts: 1318 from 2012/11/10
    From: Manchester, UK/GB
    I downloaded v2.1 and installed it as suggested with all the new files in the download placed in my system with all the unarchived folders/files. :-)

    However, I have had a couple of crashes when trying to view videos on Formula 1's website - without HLS active, though videos only seemed to play for 0:08s anyway with video/audio, and after 0:08s only with video. Initially, on that use/video, it just crashed out, and I got a Crash Reporter which I completed/sent.

    The second time I loaded a video from Formula 1's website the video played (no audio/sound) and I got an error message from the website - this time with HLS active, stating "Could not download the video, Error Code: PLAYER_ERR_TIMEOUT, Session ID: 2021-06-23:aa5d671bb15b070e9a0d1da2 Player Element ID: 1703352181737740921, but after that error message was clicked on "OK" it then continued to play the video - though still none of the audio worked during the video playing, but then it crashed out stating that "Wayferer seems to have ran out of RAM :-(" or words to that effect - but no Crash Reporter to complete.

    The sub-menu mouse middle-wheel scrolling does seem to be working as it was in earlier versions, so that's definitely an improvement from v2.0. 8-)

    @ jacadcaps - I'd really like to see the "Save As" download option implemented as soon as you can, as this is a real "pain-in-the-butt" only being able to save a file with the name supplied from wherever it is download from, and only to the path that is "set in stone" in the Settings. I really would appreciate this option being part of Wayfarer's Settings as it really is a nuisance not having this dynamic user choice.
    MacMini 1.5GHz,64MB VRAM, PowerBooks A1138/9 (Model 5,8/9),PowerMac G5 2.3GHz(DP), iMac A1145 2.1GHz 20", all with MorphOS v3.17,Airport,Bluetooth,A1016 Keyboard,T-RB22 Mouse,DVD-RW-DL,MiniMax,Firewire/USB2 & MacOSX 10.4/5.
  • »23.06.21 - 16:48
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2759 from 2003/3/5
    From: Canada
    I am aware of the Formula1 issue, happens on YT too if you change quality (same thing as F1 changes quality for you). Not sure when I'll find the time to look into this. I suggest you use 1.21 for that website for the time being.
  • »23.06.21 - 17:14
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Posts: 2759 from 2003/3/5
    From: Canada
    2.2 is now out.

    - Fixed duration handling in the Media Source player
    - Disabled focus frame on some elements since it wasn't always redrawn correctly
    - Fixed a low-memory related crash in the PNG decoder
    - Tweaked ICU data checks to try and detect broken installations
    - Added a workaround for Wayfarer not shutting down (may still be up to 30s)
    - Fixed setting media playback variables after prefs were reset

    @NewSense: formula1 should now be more or less OK :)

    [ Edited by jacadcaps 27.06.2021 - 02:37 ]
  • »27.06.21 - 00:35
    Profile Visit Website
  • Paladin of the Pegasos
    Paladin of the Pegasos
    NewSense
    Posts: 1318 from 2012/11/10
    From: Manchester, UK/GB
    Quote:

    jacadcaps wrote: 2.2 is now out.

    That's great, but I've already had a few crashes - 1 no Crash Reporter, 2nd & 3rd - Crash Reports sent - after at least a couple of the crashes the WkWebView Acinerella Video Decoder had gone "Frozen" so I had to fully warm reboot to be able to use the Formula 1's website to test the functionality as I obviously couldn't use the video capabilities with Acinerella "Frozen".
    Quote:

    jacadcaps wrote:
    - Fixed duration handling in the Media Source player

    sadly I've not found that to be working with Formula 1's website - videos can play, but then after about 16 seconds they loop/repeat whether the video is on SD or HD or Auto
    Quote:

    jacadcaps wrote:
    - Disabled focus frame on some elements since it wasn't always redrawn correctly
    - Fixed a low-memory related crash in the PNG decoder
    - Tweaked ICU data checks to try and detect broken installations
    - Added a workaround for Wayfarer not shutting down (may still be up to 30s)
    - Fixed setting media playback variables after prefs were reset

    I trust they all work - as I've not had direct occasion to test these fixes. 8-)
    Quote:

    jacadcaps wrote: @NewSense: formula1 should now be more or less OK :-)

    If only that were true, but there are still issues.

    The best I got on Formula 1's website to view videos with v2.2 was using Wayfarer - as Wayfarer (no User Agent),
    and with these options active (ticked)
    Media Playback
    Media Source Playback
    HVC Codec Support
    Decode Video

    Then a video started with audio and video - in sync, but only usually played for about 16 seconds then it stalled (video) and then looped the audio first, then restarted the video all by itself sometmes and looped over and over again those same 16 seconds of video/audio, with many, same 8-16 second sections, stalled in between, though clicking on the video twice (pause || play >) often restarted the video/audio but only back to about 8 seconds from the start and then only played until about 16 seconds and then looped again. Sometimes the video played for about 1 minute and 30+ seconds, then looped back on itself and repeated what it had played before not wholly but most of it, then it eventually moved forward a bit, onto 2+ minutes then dropped back to the 1 minute section and played that all over again.

    The video cache seems to cope with the video data, but video data downloading stalls while the video does its backwards/forwards/backwards movements, but gradually shuffles forward bit-by-bit and begins downloading when it gets past the point the website will offer more data. I should also mention that as the cache is filling it is holding more and more data in RAM and so for the 7 minute video as it gets to about 2/3rds of the loaded video it has "swallowed" about 400-500MB of RAM, so I got close to "bottoming-out" of RAM and of Wayfarer crashing again.

    Surely a webpage of a 7 minute video playing at SD quality shouldn't be holding 400-500MB of RAM captive?

    So as the video moved on a bit further and then repeated what it had just played before, like a video echo. Don't forget the video I refer to is supposed to be 7 minutes and 3 seconds of playtime, but I'm only seeing about 20+ seconds of that video at a time, before it first "peats" then "re-peats" and I'm getting "tortured" during that time span of 16+ seconds - it's like being in a déja vu video nightmare! :-/
    MacMini 1.5GHz,64MB VRAM, PowerBooks A1138/9 (Model 5,8/9),PowerMac G5 2.3GHz(DP), iMac A1145 2.1GHz 20", all with MorphOS v3.17,Airport,Bluetooth,A1016 Keyboard,T-RB22 Mouse,DVD-RW-DL,MiniMax,Firewire/USB2 & MacOSX 10.4/5.
  • »27.06.21 - 02:55
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    analogkid
    Posts: 628 from 2004/11/3
    From: near myself
    Quote:

    analogkid wrote:
    Thanks for this awesome release! Very stable and fast. One question, I'm still not able to download archives from Bandcamp. On-site playing works very well, but downloading archives with the Mp3 or FLAC files still gives me an "There was an error preparing your download." error. Is there some special magic to get this working?


    Any ideas regarding this issue? Downloading archives from Bandcamp still doesn't work in 2.2, no matter which format I choose. Nevertheless, great work! Version 2.x is rock stable here.

    [ Edited by analogkid 27.06.2021 - 09:14 ]
  • »27.06.21 - 07:13
    Profile
  • Butterfly
    Butterfly
    Mozzerfan
    Posts: 95 from 2016/10/5
    Quote:

    jacadcaps wrote:
    2.2 is now out.

    - Fixed duration handling in the Media Source player
    - Disabled focus frame on some elements since it wasn't always redrawn correctly
    - Fixed a low-memory related crash in the PNG decoder
    - Tweaked ICU data checks to try and detect broken installations
    - Added a workaround for Wayfarer not shutting down (may still be up to 30s)
    - Fixed setting media playback variables after prefs were reset

    @NewSense: formula1 should now be more or less OK :)


    The shutdown problems with all my 3 systems are gone with this release.

    Thanks Jaca.
  • »27.06.21 - 10:10
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11762 from 2003/5/22
    From: Germany
    > using Wayfarer - as Wayfarer (no User Agent)

    Wayfarer does emit a default user agent string. Technically, it is possible to have the browser emit an empty string (i.e. no user agent), but I'm not sure how websites will react to that.
  • »27.06.21 - 12:02
    Profile