OGG player bug ?!
  • Order of the Butterfly
    Order of the Butterfly
    beworld
    Posts: 237 from 2010/2/10
    From: FRANCE
    hi all !

    I have a problem....
    Somes files OGG (not all) doesnt work with my MOS 3.9

    Here an example : http://www.warmup-asso.fr/users_private/beworld/Blast_Sound_0.ogg

    When i compile an game, some sounds doesnt work and i dont know why, only oslution is to convert to wav... not a cool solution :(

    In game, i have this error message :
    Coulnd not load sound file : Error writing datastream


    I test with an external audio player (VAMP for example) it's working....

    Any ideas ?

    Thanks
    PowerMac 2.7ghz MOS 3.10
    PowerBook 1.5Ghz MOS 3.10
    My MOS ports
  • »12.03.18 - 19:54
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    beworld
    Posts: 237 from 2010/2/10
    From: FRANCE
    Noone can confirm that this OGG not reading ?
    PowerMac 2.7ghz MOS 3.10
    PowerBook 1.5Ghz MOS 3.10
    My MOS ports
  • »13.03.18 - 13:13
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    mobydick
    Posts: 178 from 2004/2/26
    From: Mordor, capita...
    I can confirm this. The internal player and MPlayer can not playback this OGG. MorphOS 3.9, Pegasos II, onboard sound.
    Pegasos II/G4@1GHz, 1 GB RAM, MorphOS 3.9
    Efika MX Smartbook, Ubuntu 12.04
    peguser.narod.ru
  • »13.03.18 - 18:56
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    beworld
    Posts: 237 from 2010/2/10
    From: FRANCE
    thanks

    i send report bug to morphosteam via MorphOS.
    PowerMac 2.7ghz MOS 3.10
    PowerBook 1.5Ghz MOS 3.10
    My MOS ports
  • »13.03.18 - 19:10
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    igracki
    Posts: 305 from 2003/2/25
    From: Berlin
    OWB can play this sound!
  • »14.03.18 - 18:58
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    polluks
    Posts: 395 from 2007/10/23
    From: Gelsenkirchen,...
    Just guessing:

    vorbisfile.library 5.1 (03.04.12)
    for MorphOS by DET Nicolas and Sigbjørn Skjæret, using libogg 1.3.0 and libvorbis 1.3.2 - Copyright (c) 2002-2012 Xiph.Org Foundation
    20101101 (Schaufenugget)

    Blast_Sound_0.ogg
    20140122 (Turpakäräjiin)

    encoded four years later, maybe time to update the library.
    BTW OWB does not use this library.
    However vorbis-tools.lha has also problems...

    [ Editiert durch polluks 15.03.2018 - 02:20 ]
    Pegasos II G4: MorphOS 3.9, Zalman M220W
    Power Mac G3: OSX 10.3 · PowerBook 5,8: OSX 10.5, MorphOS 3.11
  • »15.03.18 - 01:41
    Profile
  • MorphOS Developer
    CISC
    Posts: 616 from 2005/8/27
    From: the land with ...
    Quote:

    polluks wrote:
    Just guessing:

    vorbisfile.library 5.1 (03.04.12)
    for MorphOS by DET Nicolas and Sigbjørn Skjæret, using libogg 1.3.0 and libvorbis 1.3.2 - Copyright (c) 2002-2012 Xiph.Org Foundation
    20101101 (Schaufenugget)

    Blast_Sound_0.ogg
    20140122 (Turpakäräjiin)

    encoded four years later, maybe time to update the library.


    Maybe, but the changelogs for both libraries does not mention anything that should cause incompatibility, so it might be that the latest (still very old, they haven't been changed since 2015) versions are just more fault tolerant and that there really is something wrong with these files.


    - CISC
  • »15.03.18 - 12:16
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    beworld
    Posts: 237 from 2010/2/10
    From: FRANCE
    I have this bug for somes games ports that use OGG files.

    All (or 90% maybe ) of files smaller than 10kb.

    I need to convert it to WAV.

    BeWorld
    PowerMac 2.7ghz MOS 3.10
    PowerBook 1.5Ghz MOS 3.10
    My MOS ports
  • »15.03.18 - 13:49
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    beworld
    Posts: 237 from 2010/2/10
    From: FRANCE
    hi

    any progress on tiny OGG files ?
    I have same problem with somes games ports (i use last gcc and last morphos sdk)
    PowerMac 2.7ghz MOS 3.10
    PowerBook 1.5Ghz MOS 3.10
    My MOS ports
  • »20.10.18 - 16:50
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    KennyR
    Posts: 384 from 2003/3/4
    From: #AmigaZeux, Gu...
    Quote:

    Here an example : http://www.warmup-asso.fr/users_private/beworld/Blast_Sound_0.ogg


    There's something odd about this ogg file. It looks like an ogg in a binary editor but when I just tried to load it unto Windows Media Player it told me that the extension (.ogg) does not match the fileformat. Yet it still plays.
  • »20.10.18 - 17:20
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Templario
    Posts: 246 from 2012/4/28
    Quote:

    beworld escribió:
    hi all !

    I have a problem....
    Somes files OGG (not all) doesnt work with my MOS 3.9

    Here an example : http://www.warmup-asso.fr/users_private/beworld/Blast_Sound_0.ogg

    When i compile an game, some sounds doesnt work and i dont know why, only oslution is to convert to wav... not a cool solution :(

    In game, i have this error message :
    Coulnd not load sound file : Error writing datastream


    I test with an external audio player (VAMP for example) it's working....

    Any ideas ?

    Thanks


    Thank you for use VAMP, I made the program to test files for programation like this case.
    Amiga 500 with ROMs 1.3-2.05 and M-Tec AT 500 with hard disk and 4MB Ram.
    WinUAE + original OS 3.5&3.9
    Sam440ep 800 MHZ + OS 4.1 F.E.
    Sam460ex 1 GHz + OS 4.1 + Update 6.
    MacMini 1.5 GHz + MorphOS 3.11
    PowerBook G4 1.65 + MorphOS 3.11
  • »21.10.18 - 14:12
    Profile Visit Website