Earth 2140
  • Butterfly
    Butterfly
    Charvel
    Posts: 97 from 2007/2/15
    Hi I cant get Earth 2140 to run on my Pegasos 1.
    It complains about "sound initialization error. Channels in use?"
    Anyone got this game to run under MorphOS?
  • »03.04.08 - 12:53
    Profile
  • MorphOS Developer
    zukow
    Posts: 516 from 2005/2/9
    From: Poland
    Have you http://aminet.net/driver/audio/eaudio.device.lha installed ?
  • »03.04.08 - 13:15
    Profile Visit Website
  • Butterfly
    Butterfly
    Charvel
    Posts: 97 from 2007/2/15
    Thanks! That solved the soundpart =)

    Now it is complaining about screenmode.
    "Unable to open a usable 640x480x64 screenmode."
    "the availible 640x480x16 screenmode are not in bigendian RGB16 pixelformat".

    Anyone have a clue?
  • »03.04.08 - 13:46
    Profile
  • Butterfly
    Butterfly
    Charvel
    Posts: 97 from 2007/2/15
    Aha, thanks!
    i will try that.
  • »03.04.08 - 16:43
    Profile
  • Butterfly
    Butterfly
    Charvel
    Posts: 97 from 2007/2/15
    I give up......
    i belive I have searched through the whole web for the patch.
    it doesnt exist on pagans homepage anymore.

    If anyone got it....pleeease email it to me =)
    Charvel@home.se

    //Peter
  • »04.04.08 - 05:32
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 10648 from 2003/5/22
    From: Germany
    > it was available by requesting it with e-mail from authors.

    Sure? I think it was (is?) available by requesting it via email from the publisher (epic, now RuneSoft).

    https://morph.zone/modules/newbb_plus/viewtopic.php?topic_id=998&forum=3#7111
    https://morph.zone/modules/newbb_plus/viewtopic.php?topic_id=1048&forum=10#7465
  • »04.04.08 - 22:57
    Profile
  • Butterfly
    Butterfly
    Charvel
    Posts: 97 from 2007/2/15
    Got it!
    Now it runs :)
  • »05.04.08 - 10:26
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Cego
    Posts: 587 from 2006/5/28
    From: Germany
    Earth 2140 crashes on my PowerBook G4. That happened also a few years ago on my old machine. The strange thing is, it happens when i'm moving water units.
    Powerbook G4@1,67GHz, 2GB DDR2 Ram, Radeon 9700, 60GB SSD, MorphOS 3.7
    PowerMac Dual G5 @2.3GHz, 4GB DDR Ram, Radeon 9600XT, 2x250GB HD, MorphOS 3.7, MacOS X Leopard 10.5.8
  • »30.03.15 - 18:28
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    eliot
    Posts: 501 from 2004/4/15
    Quote:

    Charvel wrote:
    Aha, thanks!
    i will try that.



    Where do get it from?
    I am also interested in running Earth on MorphOs.
    regards
    eliot
  • »31.03.15 - 06:09
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Cool_amigaN
    Posts: 518 from 2011/11/30
    Cego, which army's side are you playing with and in which level does the crash occur?
    I 've installed it and tried only some of the first few stages which are fine on a PMAC G$ with 9800Pro.
    Amiga gaming Tribute: Watch, rate, comment :)
  • »31.03.15 - 17:10
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Cego
    Posts: 587 from 2006/5/28
    From: Germany
    it happend at mission 7 with the brown army. i also remember that it also happened with the blue side in mission 6 or 7 a few years back.
    Powerbook G4@1,67GHz, 2GB DDR2 Ram, Radeon 9700, 60GB SSD, MorphOS 3.7
    PowerMac Dual G5 @2.3GHz, 4GB DDR Ram, Radeon 9600XT, 2x250GB HD, MorphOS 3.7, MacOS X Leopard 10.5.8
  • »31.03.15 - 17:29
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Cego
    Posts: 587 from 2006/5/28
    From: Germany
    okay, it seems that this error only occurs with the 68k version of earth. i've been playing the ppc version and there were no crashes at all.
    Powerbook G4@1,67GHz, 2GB DDR2 Ram, Radeon 9700, 60GB SSD, MorphOS 3.7
    PowerMac Dual G5 @2.3GHz, 4GB DDR Ram, Radeon 9600XT, 2x250GB HD, MorphOS 3.7, MacOS X Leopard 10.5.8
  • »01.04.15 - 19:01
    Profile