New Modern Webkit-based Browser In Development
  • Order of the Butterfly
    Order of the Butterfly
    tolkien
    Posts: 420 from 2013/5/29
    I have used Amazon Fire Stick user agent. It feels it react much better to time video changes and, dont know if was my mind, but seems to load faster.

    I tried it in the powerbook. Will try it in the powermac today.
    MorphOS: PowerMac G5 - PowerBook G4 - MacMini.
    Classic: Amiga 1200/060 - A500 PiStorm
  • »04.05.22 - 05:42
    Profile
  • Butterfly
    Butterfly
    Primax
    Posts: 73 from 2021/7/2
    Little review (Wayfarer 3.6, AmigaOne X5000, Radeon X1650 Pro):

    1) Videos that are integrated into websites (embedded videos) do not run. No matter which 'user agent' I set for 'spoofing'. Even the new 'Amazon Fire Stick' agent brings does not change anything. Example:
    https://blog.oshpark.com/2022/04/22/the-2022-open-hardware-summit-is-live/
    (by the way: works pefectly with OWB)

    I had found only one page so far where it worked:
    https://www.heise.de/news/heise-spielt-Amiga-500-live-ab-12-Uhr-Neue-alte-Retro-Freundin-6659366.html

    Unfortunately, it doesn't work now either....

    2) YouTube videos basically work (Wayfarer and Safari agent). But:
    - with the Safari agent I can't rewind because the button can't be caught. In full-screen mode, the timeline has completely disappeared.
    - with the Wayfarer agent it works, but at the new point the video first hooks and jerks and then breaks off completely.

    And unfortunately, it just crashed (crash report sent).

    [ Editiert durch Primax 08.05.2022 - 09:53 ]
    AmigaOne X5000 @ 2GHz / 4GB RAM / Radeon X1650 / AmigaOS 4.1 Final Edition / MorphOS 3.17
    Amiga1200 / Blizzard 1230 IV / 128 MB RAM / AmigaOS 3.9
  • »08.05.22 - 08:45
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    Posts: 155 from 2019/4/6
    What is the exact string of the user-agent of:
    Amazon Fire Stick user agent?

    Thanks
  • »08.05.22 - 13:37
    Profile
  • Paladin of the Pegasos
    Paladin of the Pegasos
    NewSense
    Posts: 1230 from 2012/11/10
    From: Manchester, UK/GB
    Quote:

    white wrote: What is the exact string of the user-agent of: Amazon Fire Stick user agent? Thanks

    I hope this is what you wanted, it seems from the settings information that the Amazon Fire Stick User Agent is: Dalvik/2.1.0 (Linux; U; Android 5.1; AFTM Build/LMY47O)
    MacMini 1.5GHz,10,2,64MB VRAM,1GB,Airport, Bluetooth,A1016 Keyboard,T-RB22 Mouse,DVD-RW-DL+CD-RW,Iomega MiniMax,Belkin 6 port 3 x Firewire/3 x, USB2, MorphOS 3.12, Mac OSX 10.4/10.5, A1138+A1139 PwrBk MOS v3.12,Model 5,8/5,9, & PowerMac G5 2.3GHz(DP)
  • »08.05.22 - 22:24
    Profile
  • Butterfly
    Butterfly
    Primax
    Posts: 73 from 2021/7/2
    Quote:

    Primax schrieb:
    Little review (Wayfarer 3.6, AmigaOne X5000, Radeon X1650 Pro):


    Can anybody confirm my experiences? Or report different ones with the websites I listed?
    I thought, using concrete websites it is good to compare.
    AmigaOne X5000 @ 2GHz / 4GB RAM / Radeon X1650 / AmigaOS 4.1 Final Edition / MorphOS 3.17
    Amiga1200 / Blizzard 1230 IV / 128 MB RAM / AmigaOS 3.9
  • »09.05.22 - 10:21
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    tolkien
    Posts: 420 from 2013/5/29
    @Primax
    I have visited those websites as Wayfarer user agent and the integrated videos are shown correctly.
    I have activated all codecs, multimedia etc etc. so dont know. Perhaps you should flush de cache.
    MorphOS: PowerMac G5 - PowerBook G4 - MacMini.
    Classic: Amiga 1200/060 - A500 PiStorm
  • »09.05.22 - 18:52
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2629 from 2003/3/5
    From: Canada
    Quote:

    Primax wrote:
    - with the Safari agent I can't rewind because the button can't be caught


    This is not going to work and does not work in Safari/macOS when spoofing as iOS either - that's because it depends on input events that only an iOS device would generate. You can use the Media menu / hotkeys to seek despite this limitation.
  • »09.05.22 - 19:21
    Profile Visit Website
  • Butterfly
    Butterfly
    Primax
    Posts: 73 from 2021/7/2
    Quote:

    tolkien schrieb:
    @Primax
    I have visited those websites as Wayfarer user agent and the integrated videos are shown correctly.
    I have activated all codecs, multimedia etc etc. so dont know. Perhaps you should flush de cache.



    Enabled all options - although it is not necessary because the red flag tells you what is required - flushed the cache (deleted all folders in cache/1: result is the same. Video is not played.
    I would say it is due my poor (??) X1650 but at least the first video OWB plays fine. So, this cannot be the reason.

    What then?

    Do I have to remove the cgxvideo.library from Libs which was previously required?

    Thanks!
    AmigaOne X5000 @ 2GHz / 4GB RAM / Radeon X1650 / AmigaOS 4.1 Final Edition / MorphOS 3.17
    Amiga1200 / Blizzard 1230 IV / 128 MB RAM / AmigaOS 3.9
  • »13.05.22 - 16:08
    Profile Visit Website
  • Butterfly
    Butterfly
    Primax
    Posts: 73 from 2021/7/2
    Again thought about the problem:
    I am not an expert so it is quite likely that I do something wrong.

    On the other hand: the embedded video of the heise website worked for me with a previous version. And I changed nothing except installing the latest Wayfarer version. So, could it be an issue of Wayfarer and X5000 or something like that?
    AmigaOne X5000 @ 2GHz / 4GB RAM / Radeon X1650 / AmigaOS 4.1 Final Edition / MorphOS 3.17
    Amiga1200 / Blizzard 1230 IV / 128 MB RAM / AmigaOS 3.9
  • »14.05.22 - 12:31
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Posts: 2629 from 2003/3/5
    From: Canada
    @Primax

    Check the system logs with LogTool for lines like
    Code:

    [VD]setOverlayWindowCoords: failed creating vlayer for size ...
  • »16.05.22 - 17:52
    Profile Visit Website