MorphOS 3.11 - Massive WiFi problems on G4 PB
  • Just looking around
    Reth
    Posts: 12 from 2006/8/27
    Hi everybody,

    unfortunately since MOS 3.11 (IMO I did not experience this problem before) I have a lot of severe WiFi problems! Wifi either doesn't get connected at all or if connected I cannot even ping the internal address of my router!

    If both might be working by chance data transmission is horribly slow, contains lots of package losses (according to parallel ping) and so on.

    When I boot into MacOS instead everything is fine: WiFi is working great and transmission is stable and fast.

    Does anybody know what the problem might be on MOS side? Even more since Wifi and transmission worked much more stable in earlier versions?

    Thank you for your help and

    Kind Regards
  • »12.08.19 - 00:22
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Templario
    Posts: 277 from 2012/4/28
    Also I have problems as you, the wifi drivers of MorphOS 3.11 has snyome problems, slow connection and disconnects
    Amiga 500 with ROMs 1.3-2.05 and M-Tec AT 500 with hard disk and 4MB Ram.
    WinUAE + original OS 3.5&3.9
    Sam440ep 800 MHZ + OS 4.1 F.E.
    Sam460ex 1 GHz + OS 4.1 F.E.
    MacMini 1.5 GHz + MorphOS 3.11
    PowerBook G4 1.65 + MorphOS 3.11
  • »12.08.19 - 08:47
    Profile Visit Website
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    Jeckel
    Posts: 133 from 2007/3/11
    It is funny because I have the exact opposite problem: under MorphOS 3.11 WIFI works reliable, strong signal, good bandwidth; under MacOS X, WIFI had a very low signal, sometimes doesn't connect or loose connection, and the bandwidth is very bad unless I move the computer very close to the router.

    I guess WIFI is a bit weird. :)
  • »12.08.19 - 10:12
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 1787 from 2003/3/5
    From: Poland
    It could be down to the firmware that's being uploaded to the chip by the respective OS.
  • »12.08.19 - 10:44
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    KennyR
    Posts: 657 from 2003/3/4
    From: #AmigaZeux, Gu...
    Have you got an Android tablet or phone? It would be helpful to use Wifi Analyzer to make sure that you suddenly didn't get a neighbouring source which is now interfering with your signal. (Wifi analogue video senders are the worst, though thankfully nobody really uses them any more.)

    I know you said it works fine on MacOS but that could still be auto-channel negotiation, with that driver picking a nice clear channel and maybe MorphOS failing to.
  • »12.08.19 - 10:45
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 1787 from 2003/3/5
    From: Poland
    My ASUS router has some settings for "legacy receivers". Turning that on was key to making WiFi work somewhat OK.

    [ Edited by jacadcaps 12.08.2019 - 11:47 ]
  • »12.08.19 - 10:46
    Profile Visit Website
  • jPV
  • Paladin of the Pegasos
    Paladin of the Pegasos
    jPV
    Posts: 1517 from 2003/2/24
    From: po-RNO
    Wifi can be horrible slow with lots of packet loss on my PB too, but after configuring my router to use channel 1 it's been fine. When I had that in "auto" mode, it was pure luck when it worked fine and when not. So I think it's a bit sensitive about the channel and I'd try to use channels 1 or 6 which are the best wifi channels in theory. 11 could be too, but it's been said that at least for certain age Apple hardware you shouldn't use channels over 10 or so.. so I'd try 1 or 6 when testing if it's about this.
  • »12.08.19 - 15:12
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    KennyR
    Posts: 657 from 2003/3/4
    From: #AmigaZeux, Gu...
    2.4G wifi routers switched to dual band 802.11n in the mid 00s. Unfortunately this means they use channel 6, plus another channel (usually 3 or 9). Most people rarely switch this off in their routers and a lot of ISP routers leave it configured by default, even if they also support 5G.

    What this means is that channel 6 gets really crowded, and adapters which support single band only usually end up with really crappy performance because they can't connect to that second band channel.

    So trying to turn off 802.11n and making sure A and G compatibility is on, and setting single band, and using a low channel like 1 may indeed work for solving these kind of problems.

    I personally used channel 13 when I lived in a flat with around 20 other 2.4G networks crowding the airwaves, and that worked really well - with the problem that many drivers (especially those meant for the US market) don't actually support channel 13.
  • »12.08.19 - 18:37
    Profile
  • Just looking around
    Reth
    Posts: 12 from 2006/8/27
    But wouldn't that mean all our other devices running on 802.11n won't work any longer or slow down massivly when using A?
  • »13.08.19 - 20:35
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    KennyR
    Posts: 657 from 2003/3/4
    From: #AmigaZeux, Gu...
    Quote:

    Reth wrote:
    But wouldn't that mean all our other devices running on 802.11n won't work any longer or slow down massivly when using A?


    Yes. Even if you're just using a single channel, try to leave N enabled if possible. It does theoretical max 150 MB/s on single channel, and G does 54 MB/s.

    But if you're struggling to find clear channels, it's already being hit pretty hard so it may actually not make as much difference.

    That's of course if noise is indeed the problem. For all I know your airwaves could be totally clear and it's 100% a MorphOS issue.
  • »13.08.19 - 20:42
    Profile
  • Just looking around
    Reth
    Posts: 12 from 2006/8/27
    For me at least it seems so since within previous MOS versions everything worked fine and reliably.

    Does anybody know about the expert settings within network? Maybe I can tweak those a little?
  • »13.08.19 - 20:48
    Profile