Folio
  • Caterpillar
    Caterpillar
    sergius
    Posts: 31 from 2005/12/6
    Hi guys, I'm having a little trouble using Folio in french.
    In French we use a lot the ' caracter and when I save a text with this character, Folio inserts automatically a \ before the ' .

    as you can see, this piece of text was saved 3 times

    Original text : C'était l'année de ses seize ans
    after saving 1 time : C\'était l\'année de ses seize ans
    after saving 2 times : C\\'était l\\'année de ses seize ans
    after saving 3 times : C\\\'était l\\\'année de ses seize ans

    Do you have this issue to?
    An idea to solve it?

    Thks
  • »24.07.18 - 16:19
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    NewSense
    Posts: 666 from 2012/11/10
    From: Manchester, UK...
    @ Sergius

    I have tried this on my GB/UK setup Apple A1016 Bluetooth keyboard, and basically I get the same results as you do , sadly. :-(

    If I save the file as either .folio, .htm, or .mht, then when it is reloaded I get the same results as you.

    If I try to load it as a .rtf file, that is still not supported . . . . BUT . . . . what is more surprising is that if I saved it as a .txt file then that generates a JavaScript error requester stating . . . . .

    "The file could not be opened because it is in the wrong format.

    This version of Folio supports loading Folio, HTML, MHT, and TXT documents."

    A saved PDF from Odyssey (OWB) v1.25 of the file reads correctly, and copies to Scribble & Ed as it looks/reads originally on screen.

    However, the .txt file that I saved from your original input is read in Scribble and Ed as:

    C'était l'année de ses seize ans

    However, it looks/reads OK in Multiview - no sign of the "©" and if I save it out from Multiview (Copy) and then paste it into Ed it has been "sanitised"/overlooked from within the file and the "©" has not been seen/displayed, and is now gone from the file in any case by doing that copy/paste.

    It seems the accents are not being interpreted correctly as yet, but then Folio is still in Beta stage, so I'd certainly mention this to André, for him to look into the issue(s) that are causing it to happen.

    The .txt issue I will bring to his attention, if he hasn't viewed this forum thread over the next few days, but I feel sure he will be checking over this issue once he comes across this thread "Folio", seeing as it's his "baby". 8-)
    Mac Mini 1.5GHz, Model 10.2, 64MB VRam, 250GB HDD, 1GB RAM, Airport, Bluetooth, Wireless Keyboard & Mouse, DVD-RW-DL+CD-RW, Iomega MiniMax, Belkin 6 port 3 x Firewire/3 x USB2, MorphOS 3.9, Mac OS X 10.4 & 10.5 & A1138 Powerbook MOS v3.9, Model 5,8 (Also
  • »25.07.18 - 02:56
    Profile
  • ASiegel
    Posts: 1041 from 2003/2/15
    From: Central Europe
    I had already replied to an inquiry from sergius via PM before this discussion thread popped up...
  • »25.07.18 - 11:55
    Profile
  • Leo
  • Order of the Butterfly
    Order of the Butterfly
    Leo
    Posts: 412 from 2003/8/18
    @ASiegel: better post it here, it could help someone else having the same problem.
    Nothing hurts a project more than developers not taking the time to let their community know what is going on.
  • »25.07.18 - 14:37
    Profile Visit Website
  • ASiegel
    Posts: 1041 from 2003/2/15
    From: Central Europe
    @ Leo

    The solution is an updated application... I just meant to confirm that I have been made aware of the problem.
  • »25.07.18 - 14:39
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    NewSense
    Posts: 666 from 2012/11/10
    From: Manchester, UK...
    @ ASiegel:

    Does that include the .txt file issue, that Folio creates, and then cannot load back in?

    Also, if there is an updated application, is it due for release imminently, or does it need more testing prior to its release?

    [EDIT] I'd be happy to offer a further donation if there are more improvements to Folio.
    Mac Mini 1.5GHz, Model 10.2, 64MB VRam, 250GB HDD, 1GB RAM, Airport, Bluetooth, Wireless Keyboard & Mouse, DVD-RW-DL+CD-RW, Iomega MiniMax, Belkin 6 port 3 x Firewire/3 x USB2, MorphOS 3.9, Mac OS X 10.4 & 10.5 & A1138 Powerbook MOS v3.9, Model 5,8 (Also
  • »25.07.18 - 17:50
    Profile
  • ASiegel
    Posts: 1041 from 2003/2/15
    From: Central Europe
    @ NewSense

    I just lost an Intel SSD last week with quite a bit of MorphOS data on it. Unbeknownst to me when I bought the expensive-ish 480GB drive, Intel used one of the infamous Sandforce controllers for it that have been known to spontaneously stop working.

    To top things off, an Intel support staff member named Iolanda just informed me I am not eligible for a warranty replacement after making several suggestions that made it clear she had failed to read my initial error description.

    While I had to unexpectedly buy a replacement SSD and have my main workstation back up and running right now, I am afraid a new Folio version is not 'imminent' for the moment.
  • »25.07.18 - 18:16
    Profile
  • Caterpillar
    Caterpillar
    sergius
    Posts: 31 from 2005/12/6
    Oh! sad for the ssd broken.

    My workaround for the \' issue:
    I write my text, then a do some "find and replace"

    I replace \' by '
    I replace \\' by '
    I replace \\\' by '

    That's all.
  • »25.07.18 - 20:27
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    KennyR
    Posts: 317 from 2003/3/4
    From: #AmigaZeux, Gu...
    @Asiegel

    Don't even go through Intel's support. If it's still in warranty, just ask for an RMA number and a replacement. Accept no refusal, as it's illegal for them to refuse.

    If it's still in warranty...
  • »25.07.18 - 21:37
    Profile
  • ASiegel
    Posts: 1041 from 2003/2/15
    From: Central Europe
    @ KennyR

    Well, there is the legally mandated warranty, which is guaranteed by the reseller, and then there is Intel's voluntary 5-year extended manufacturer warranty...
  • »25.07.18 - 21:46
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    takemehomegrandma
    Posts: 2508 from 2003/2/24
    Quote:

    and then there is Intel's voluntary 5-year extended manufacturer warranty...


    Yes, try turning directly to Intel if the reseller warranty is expired.
    MorphOS is Amiga done right! :-)
    MorphOS NG will be AROS done right! :-)
  • »26.07.18 - 01:42
    Profile
  • ASiegel
    Posts: 1041 from 2003/2/15
    From: Central Europe
    Quote:

    takemehomegrandma wrote:

    Yes, try turning directly to Intel if the reseller warranty is expired.

    Well, I already did and discussed the result above.
  • »26.07.18 - 06:02
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    NewSense
    Posts: 666 from 2012/11/10
    From: Manchester, UK...
    @ ASiegel,

    Sorry to hear about your SSD issues, that really is likely to be a great deal of trouble, but as others have said, I'd persist with any valid warranty you have for the SSD drive, as that should be honoured by either the retailer or Intel if the extended warranty is still valid.

    I can understand about the delay of an updated Folio, which is a shame, but understandable, and I hope you get some satisfaction by obtaining a warranted replacement unit, and are able to get back on track with your MorphOS passion, for which many of us, well me at least as I can't speak for everyone I suppose, are ever so grateful for. 8-D

    I'm not a major fan of SSD drives, but I do own a few, though I rarely use them, as they are kept disconnected for most of the time, with the software updated when necessary, yet still available as a backup should I need them. I trust them even less now I have heard of your trouble with one.
    Mac Mini 1.5GHz, Model 10.2, 64MB VRam, 250GB HDD, 1GB RAM, Airport, Bluetooth, Wireless Keyboard & Mouse, DVD-RW-DL+CD-RW, Iomega MiniMax, Belkin 6 port 3 x Firewire/3 x USB2, MorphOS 3.9, Mac OS X 10.4 & 10.5 & A1138 Powerbook MOS v3.9, Model 5,8 (Also
  • »27.07.18 - 02:28
    Profile
  • ASiegel
    Posts: 1041 from 2003/2/15
    From: Central Europe
    Quote:

    NewSense wrote:
    I'm not a major fan of SSD drives, but I do own a few, though I rarely use them, as they are kept disconnected for most of the time, with the software updated when necessary, yet still available as a backup should I need them. I trust them even less now I have heard of your trouble with one.

    Actually, leaving SSDs disconnected from power for extended periods of time can lead to loss of data. You should keep them connected if possible as they are not suitable for long-term data storage but do offer high speeds during active and continued use. (Source)

    My bad experiences were solely limited to drives with Sandforce controllers, which are no longer being manufactured.
  • »04.08.18 - 16:15
    Profile
  • Paladin of the Pegasos
    Paladin of the Pegasos
    Intuition
    Posts: 1007 from 2013/5/24
    From: Englistan
    Quote:

    ASiegel wrote:
    @ KennyR

    Well, there is the legally mandated warranty, which is guaranteed by the reseller, and then there is Intel's voluntary 5-year extended manufacturer warranty...


    Two years from date of purchase in the EU isn't it?
    1.67GHz 15" PowerBook G4, 1GB RAM, 128MB Radeon 9700M Pro, 64GB SSD, MorphOS 3.9

    2.7GHz DP G5, 4GB RAM, 512MB Radeon X1950 Pro, OSX 10.5.8, 500GB SSHD, MorphOS 3.9
  • »04.08.18 - 19:13
    Profile