SmbFS & Umlauts
  • Order of the Butterfly
    Order of the Butterfly
    ernsteiswuerfel
    Posts: 373 from 2015/6/18
    From: Funeralopolis
    Yesterday I finally set up Samba (4.6.11) on my Linux-Server being annoyed by USB fiieswapping I did before for MorphOS. ;-) Setup was surprisingly painless and smbfs is working well.

    However I noticed the umlauts are missing in files and directories, like Bäume is shown as Bume or Österreich is shown as sterreich. Is there something which can be done about that?

    Also I need these options in my /etc/samba/smb.conf
    Code:
       server min protocol = NT1
    ntlm auth = ntlmv1-permitted

    to get the share mounted in MorphOS. I guess SMB2/SMB3 is not supported yet?
    Talos II. [Gentoo Linux] | PMac G5 11,2. PMac G4 3,6. PBook G4 5,8. [MorphOS 3.13 / Void Linux / Gentoo Linux] | A1200. ACA-1233, Indivision AGA Mk2. [Amiga OS 3.2]
  • »02.05.20 - 17:08
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    ernsteiswuerfel
    Posts: 373 from 2015/6/18
    From: Funeralopolis
    I've read through that posts but there is no hint what options are set in the smb.conf of these NAS boxes... Would be interesting to know! I guess at this point of time it could even have been samba 3.x which did things quite a bit differently.
    Talos II. [Gentoo Linux] | PMac G5 11,2. PMac G4 3,6. PBook G4 5,8. [MorphOS 3.13 / Void Linux / Gentoo Linux] | A1200. ACA-1233, Indivision AGA Mk2. [Amiga OS 3.2]
  • »02.05.20 - 18:18
    Profile
  • MorphOS Developer
    cyfm
    Posts: 404 from 2003/4/11
    From: Germany
    You most likely need to specify a TRANSLATE file for the MSDOS/Windows character set if you run into umlaut issues like that. It basically is a 256 byte mapping table for msdos -> latin1 charset and vice versa.
  • »03.05.20 - 12:27
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    ernsteiswuerfel
    Posts: 373 from 2015/6/18
    From: Funeralopolis
    Thanks for the suggestion! But character set on the host is de_DE.UTF-8 on an ext4 filesystem. Is there a translation file for that and where would I get it?
    Talos II. [Gentoo Linux] | PMac G5 11,2. PMac G4 3,6. PBook G4 5,8. [MorphOS 3.13 / Void Linux / Gentoo Linux] | A1200. ACA-1233, Indivision AGA Mk2. [Amiga OS 3.2]
  • »03.05.20 - 12:51
    Profile
  • MorphOS Developer
    cyfm
    Posts: 404 from 2003/4/11
    From: Germany
    The filesystem character set doesn't necessarily match what smbfs uses/receives in the end. I would try a win1252<->latin1 file first.
  • »03.05.20 - 19:35
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    KennyR
    Posts: 750 from 2003/3/4
    From: #AmigaZeux, Gu...
    I have a 2008-era QNap NAS that has never had any problem with umlauts or indeed any non-Latin characters, including Korean and Cyrillic. Peering into smb.conf all I can see of relevance is

    dos charset = ASCII
    display charset = UTF8

    But it is an old Samba. Very, very old. Easily 2.x.
  • »04.05.20 - 22:16
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    ernsteiswuerfel
    Posts: 373 from 2015/6/18
    From: Funeralopolis
    @KennyR:
    Thanks for your hint which lead me to the place I should have checked first anyhow, the samba manpage on my Gentoo Linux box via man smb.conf. :-D

    Solution for me was to add dos charset = ISO-8859-15 to /etc/samba/smb.conf on the server side. On the MorphOS side no changes were required.

    Ja, sehr gut! Nun kann ich ändlich orrdentlich teutsch mit meinem Sambaservierer sprächen.
    Talos II. [Gentoo Linux] | PMac G5 11,2. PMac G4 3,6. PBook G4 5,8. [MorphOS 3.13 / Void Linux / Gentoo Linux] | A1200. ACA-1233, Indivision AGA Mk2. [Amiga OS 3.2]
  • »04.05.20 - 23:04
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    ernsteiswuerfel
    Posts: 373 from 2015/6/18
    From: Funeralopolis
    I'll share my now working smb.conf, perhaps it is helpful to someone:

    Code:
    [global]

    # workgroup = NT-Domain-Name or Workgroup-Name, eg: MIDEARTH
    workgroup = HALI

    # server string is the equivalent of the NT Description field
    server string = Samba Server
    server min protocol = NT1

    # Re-enable SMB1 support
    ntlm auth = ntlmv1-permitted

    # iso8859-15 for non-UTF8-clients
    dos charset = ISO-8859-15

    hosts allow = 192.168.2. 192.168.3. 127.
    interfaces = 192.168.2.2/24 192.168.3.2/24

    [homes]
    comment = Home Directories
    browseable = yes
    writable = yes

    The rest of the options is left at default settings.

    On MorphOS I mount my Linux home directory via S/user-network-startup:
    Code:
    run >NIL: SmbFS USER=linuxuser DOMAIN=HALI SERVICE=//serverhostname/linuxuser password=xxx VOLUME=distanthome CASESENSITIVE OMITHIDDEN

    Where linuxuser would be the same username you use on Linux, serverhostname an IP address set in MorphOS hosts file and xxx the password for your user on the server you set via smbpasswd (on the server).

    So my Linux Home directory appears on Ambient as distanthome, does not show the Linux 'hidden' point files and is case sensitive (which is default on Linux).
    Talos II. [Gentoo Linux] | PMac G5 11,2. PMac G4 3,6. PBook G4 5,8. [MorphOS 3.13 / Void Linux / Gentoo Linux] | A1200. ACA-1233, Indivision AGA Mk2. [Amiga OS 3.2]
  • »04.05.20 - 23:23
    Profile