Software : : Wayarer 8.0
Posted By: jacadcaps. on 2024/5/4 2:01:26


Wayfarer 8.0 is now available for download.

This version once again updates the WebKit core to the latest stable WebKitGTK branch.

wayfarer.icu
 
  • Paladin of the Pegasos
    Paladin of the Pegasos
    NewSense
    Joined: 2012/11/10
    Posts: 1497
    From: Manchester, UK/GB
    @ jacadcaps - Though v8.2 of Wayfarer seems to be stable and working OK, it is unable to upload photos to the ebay servers for any problems with an ebay purchased item, or any other reason for wanting to upload an image/photo, it seems. I used to be able to upload these images as PNG files, though JP(E)Gs were not accepted, but now neither file type is accepted, and generates a server error at ebay that rejects the upload. :-(

    The same image(s) are accepted via Windows systems. I don't know what is the cause, but probably the fact that we are using a basically unsupported mainstream web browser cannot be helping our situation, but if there is anything you can do to fix this issue then I'd appreciate it.

    I know Wayfarer is well supported by you and Piru, but Cloudflare and others out there just don't care about that! ;-)
    MacMini 1.5GHz,64MB VRAM, PowerBooks A1138/9 (Model 5,8/9),PowerMac G5 2.3GHz(DP), iMac A1145 2.1GHz 20", all with MorphOS v3.18+,Airport,Bluetooth,A1016 Keyboard,T-RB22 Mouse,DVD-RW-DL,MiniMax,Firewire/USB2 & MacOSX 10.4/5
  • »2024/5/14 4:27
    Profile
  • MDW
  • Order of the Butterfly
    Order of the Butterfly
    MDW
    Joined: 2003/7/26
    Posts: 460
    From: Wroclaw/Poland
    After update the Wayfarer to version 8.3 I observe CPU usage 100% on various websites (ppa.pl, exec.pl, Google Translator). MorphZone works normally.
    It occurs during the second visit on a website using this version of the Wayfarer. Maybe it is a problem with cache…
    Can I download Wayfarer 8.2 or should I recover it from last daily backup?

    [ Edited by MDW On 2024/5/18 14:27 ]
  • »2024/5/18 13:14
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Joined: 2003/3/5
    Posts: 3027
    From: Canada
    wayfarer.icu history page has links to old versions. Please see if disabling http/2 in Wayfarer's network settings helps first though.
  • »2024/5/18 16:32
    Profile Visit Website
  • MDW
  • Order of the Butterfly
    Order of the Butterfly
    MDW
    Joined: 2003/7/26
    Posts: 460
    From: Wroclaw/Poland
    Quote:

    Please see if disabling http/2 in Wayfarer's network settings helps first though.

    Yes, it helped me. If I disable HTTP/2 Support, the problem doesn't occur and Wayfarer works well with these websites.
    Thank you for help!
  • »2024/5/19 1:09
    Profile Visit Website
  • MDW
  • Order of the Butterfly
    Order of the Butterfly
    MDW
    Joined: 2003/7/26
    Posts: 460
    From: Wroclaw/Poland
    Wayfarer 8.4 works well. However I will keep set the HTTP/2 to “Disabled” because in case of "Enabled" or "Except POST" after several requests I have message "Error loading morph.zone 7: Couldn't connect to server".

    [ Edited by MDW On 2024/5/19 12:44 ]
  • »2024/5/19 11:36
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Joined: 2003/3/5
    Posts: 3027
    From: Canada
    8.5 out now, should fix the network-related problems of 8.3/4.
  • »2024/5/20 19:18
    Profile Visit Website
  • MDW
  • Order of the Butterfly
    Order of the Butterfly
    MDW
    Joined: 2003/7/26
    Posts: 460
    From: Wroclaw/Poland
    Unfortunately on Wayfarer 8.5 I still sometimes have errors like this:

    "Error loading morph.zone
    7: Couldn't connect to server"


    or

    "Error loading ppa.pl
    7: Couldn't connect to server"


    Someone in comments on ppa.pl also reported this problem.
  • »2024/5/21 14:54
    Profile Visit Website
  • MDW
  • Order of the Butterfly
    Order of the Butterfly
    MDW
    Joined: 2003/7/26
    Posts: 460
    From: Wroclaw/Poland
    After update Wayfarer to version 8.6 the problem doesn't occur. So... version 8.6 rulez! :)
    Thank you Jaca.
  • »2024/5/22 14:00
    Profile Visit Website
  • Paladin of the Pegasos
    Paladin of the Pegasos
    NewSense
    Joined: 2012/11/10
    Posts: 1497
    From: Manchester, UK/GB
    Very recently, last few day(s), eBay (UK) now have a red banner headline that basically reads as "if you want to continue to buy or sell on ebay then you need to upgrade your browser", which as I am running v8.6 of Wayfarer there is no option to upgrade it for MorphOS, and with being unable to edit the User Agent field (even though I am supposed to be able to do so) then I cannot imitate a browser that is supported fully by eBay it seems. :-(

    Also, my system (of recent) seems to fail to allow mouse dragging highlighting of text, in that I position my text cursor prior or after where I want to drag the cursor position to the left or the right, or even up or down, but then the text does not get highlighted, which is really weird, and the first time this has ever happened with MorphOS. Also the Copy option does not get shown in the drop-down menu, UNLESS I have highlighted the text using the keyboard option!

    So, do I need to change some setting or has some part of MorphOS got corrupted in some way? :-?

    However, I can highlight text using the keyboard - is there a way I can correct this or is this some sort of corruption in Ambient or MUI that needs to be addressed? :-?

    Maybe this text editing issue is also affecting the situation that I cannot amend the supposed to be editable field for customising any User Agent option? :-?
    MacMini 1.5GHz,64MB VRAM, PowerBooks A1138/9 (Model 5,8/9),PowerMac G5 2.3GHz(DP), iMac A1145 2.1GHz 20", all with MorphOS v3.18+,Airport,Bluetooth,A1016 Keyboard,T-RB22 Mouse,DVD-RW-DL,MiniMax,Firewire/USB2 & MacOSX 10.4/5
  • »2024/6/5 1:48
    Profile