Software : : Wayfarer 2.5
Posted By: jacadcaps. on 2021/8/25 13:31:50
Wayfarer 2.5 is now available from wayfarer.icu. The new version fixes two severe JavaScript memory leaks, which in some cases would leak more than 10MB per page load.

Full changelist:
  • Fixed a severe memory leak in JavaScriptCore, up to 5MB+ were being leaked per one page load in case of websites using SQL/IDB
  • Fixed to terminate Audio Worklet threads (which has also leaked a JavaScript VM) on pages using WebAudio
  • Implemented a warning (yellow shield icon) for mixed HTTPS/HTTP website content
  • Updated OpenSSL to 1.1.1l
  • Fixed a bug in Curl backend / networking that caused WebSockets to fail
  • Removed MorphOS 3.14 threading workarounds
  • Lowered WebAudio audio thread priority
  • Fixed Download Image As... to popup a requester
  • Disabled Download As window's menu
  • Fixed double-clicking on downloaded items in Downloads view where Download As was used
  •  
    • Just looking around
      Reth
      Joined: 2006/8/27
      Posts: 17
      From:
      Hi there,

      just downloaded and installed latest Version of your browser on latest MOS on PowerMacG4.

      So far I was really excited by your browser since it worked very smooth even with all those newer bloated web sites.
      But now with the latest version wayfarer often consumes 100% of CPU and maybe other ressources while not reacting at all. This lasts from a few seconds upto almost a minute some time.
      Do not know what the problem is but did not experience this problem with earlier versions.
      For example when using GMX web portal and web mail account page this now regularly freezes for long periods when using it. Was not the case in previous versions.

      Is there any way I can download and install any previous version until this problem might be solved?

      Thank you in advance for a short reply!

      CU

      [ Editiert durch Reth Ein 2021/8/26 23:44 ]
    • »2021/8/26 20:10
      Profile
    • MorphOS Developer
      jacadcaps
      Joined: 2003/3/5
      Posts: 2539
      From: Canada
      Impossible to say what's going on without further details and I don't think it's likely anything introduced in 2.5. Try a clean install. If you really think it's 2.5, the older versions can be downloaded from https://wayfarer.icu/history
    • »2021/8/26 20:52
      Profile Visit Website
    • Just looking around
      Reth
      Joined: 2006/8/27
      Posts: 17
      From:
      Thank you. Will try.

      With latest version I can see this behaviour best when using GMX web portal and GMX online mail account. This site "freezes" wayfarer regularly for longer periods before it reacts. This was not the case in previous versions.
      Anything I might be able to provide here (logs or similar)?
    • »2021/8/26 21:46
      Profile
    • MorphOS Developer
      jacadcaps
      Joined: 2003/3/5
      Posts: 2539
      From: Canada
      Websites change, not just Wayfarer. It's likely the website itself.

      By the way, your email server rejects my emails.
    • »2021/8/27 12:32
      Profile Visit Website
    • Just looking around
      Reth
      Joined: 2006/8/27
      Posts: 17
      From:
      Yeah, this behaviour I unfortunately have with several other sites and fora too. They do not work with GMX nor with Freenet unfortunately. :(

      Their Site did not really change as far as I can estimate this.

      [ Editiert durch Reth Ein 2021/9/7 15:04 ]
    • »2021/9/2 17:07
      Profile
    • Just looking around
      Reth
      Joined: 2006/8/27
      Posts: 17
      From:
      OK. Did a complete clean install of Wayfarer 2.5 - unfortunately the same problem.
      CPU usage raises to permanent 100% and Wayfarer does not react anymore. Other programs are still running but of course very slow.

      Could this topic be related to the rendering engine since GMX portal runs fine on other devices using different browsers (Firefox, Safari, Edge, ...)?

      I managed to get GMX portal loading and working somewhat smoothely on latest OWB - with one big problem: When clicking on mails they will not open and show in the read area. Also other icons related to them (deleting etc.) will not work.

      Within Wayfarer GMX portal is not even loading anymore (as described above). Changing any settings (browser identity etc.) did not help.

      Are there any kind or detail information I can somehow provide to get this topic more clear (logs, debug infos, system specs, etc.)?

      [ Editiert durch Reth Ein 2021/9/7 15:07 ]

      [ Editiert durch Reth Ein 2021/9/7 16:43 ]
    • »2021/9/7 13:06
      Profile
    • MorphOS Developer
      jacadcaps
      Joined: 2003/3/5
      Posts: 2539
      From: Canada
      As mentioned in the Wayfarer forum thread: the website is simply too heavy in terms of JavaScript it is running. It works, but needs minutes to run all of the scripts.
    • »2021/9/7 17:44
      Profile Visit Website