Software : : Wayfarer 1.9 with audio playback
Posted By: jacadcaps. on 2020/12/30 17:58:21
Wayfarer 1.9 with audio playback

Wayfarer 1.9 is now out with audio playback support and minor bug fixes.</div>
The media player supports similar codecs as Odyssey, but also the Opus audio codec and MPEG-TS demuxing. HLS support allows listening to many modern radio streams. Media playback can be enabled or disabled per host.

Please see the FAQ for answers on many audio related questions.
 
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Stevo
    Joined: 2004/1/24
    Posts: 849
    From: #AmigaZeux
    That's very nice, thank you. I also like how it's now possible to listen to the audio from YouTube shows. Video support next? ;)

    Happy new year!
    ---
    http://www.iki.fi/sintonen/logs/its_only_football.txt
  • »2020/12/30 18:32
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    vulture
    Joined: 2008/2/4
    Posts: 172
    From: Greece
    Brilliant!
  • »2020/12/30 18:34
    Profile
  • Butterfly
    Butterfly
    Spihunter
    Joined: 2003/7/10
    Posts: 81
    From: Durham, NC USA
    Woo hoo! Bandcamp and Soundcloud work.
    17" Powerbook. MorphOS registered
    Hear my music here: Gordon Gallant
    And here: Kattalax
  • »2020/12/30 18:36
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Zetec-s
    Joined: 2008/7/10
    Posts: 156
    From: Cheshire, UK
    Thanks so much for this.

    Listening to BBC Radio streaming online right now and its using around 3% of the CPU on my G5 Quad.

    Really good implementation. Can't wait for the media playback.

    [ Edited by Zetec-s On 2020/12/30 18:06 ]
  • »2020/12/30 18:57
    Profile
  • MorphOS Developer
    jacadcaps
    Joined: 2003/3/5
    Posts: 2513
    From: Canada
    A 1.10 release with a minor AHI crash fix will be out within several minutes.
  • »2020/12/30 19:12
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    analogkid
    Joined: 2004/11/3
    Posts: 619
    From: near myself
    @jacadcaps

    Thanks for this update! What do you think about adding an option in the media "Load, Download or Ignore" requester to copy the source URL to clipboard?
  • »2020/12/30 20:16
    Profile
  • IKE
  • Butterfly
    Butterfly
    IKE
    Joined: 2009/11/7
    Posts: 87
    From: Southern CA
    I've tried a few streaming audio sites:

    https://player.siriusxm.com -- does not load, likely propriety audio codecs, etc. like Spotify
    ________

    https://www.iheart.com -- very slow and not all areas are functional. Was not able to login. Works while spoofing as Safari.
    Couldn't get it to start spoofing as others or it was slow/timed out...Not sure. Playback is 32bit audio. Once it starts streaming, sounds great.

    Seems to work best when going directly to a station's url, i.e.
    for example:

    https://www.iheart.com/live/955-klos-5340/
    ________

    https://www.nugs.net/ -- works well; spoofed as Chrome
    ________

    archive.org Live Music Archive -- works well; spoofed as Chrome; turn on "Allow Media Playback" for uninterupted live
    concert stream playback:

    https://archive.org/browse.php?collection=etree&field=creator
    _______

    Soundcloud -- works well as others said; spoofed as Chrome
    IKE

    MacMini G4 1.5Ghz/PowerBook G4 1.67Ghz/PowerMac G5 2.0Ghz DP 7,2 Radeon 9650/256MB
  • »2020/12/30 23:59
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Joined: 2003/3/5
    Posts: 2513
    From: Canada
    https://player.siriusxm.com seems to be using encrypted streams.
  • »2020/12/31 0:05
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    eliot
    Joined: 2004/4/15
    Posts: 554
    From:
    Nice, NDR2 livestream is also working!
    Great work!
    regards
    eliot
  • »2020/12/31 7:18
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    beworld
    Joined: 2010/2/10
    Posts: 449
    From: FRANCE
    Online!
    Thanks to add "Select all" ! (and all other stuff)

    And Happy New Year
  • »2020/12/31 7:20
    Profile Visit Website
  • Paladin of the Pegasos
    Paladin of the Pegasos
    NewSense
    Joined: 2012/11/10
    Posts: 1166
    From: Manchester, UK/GB
    @ jacadcaps - all seemed to be working nicely, no crashes so far, and the audio does work on BBC, though its very delayed in getting triggered, and the CPU runs quite wild for a while as it accesses the data, then it asks to Load/Download/Cancel the audio file it is trying to play, which I take it is as you intended - with require user gesture with media playback, or use the other alternative settings to make it go ahead automatically by default?

    I'll try it without "user gesture" and see how much CPU activity there is then when it handles it all by itself.

    Well it alll seemed to go OK earlier, but now it's as slow as a slug, and hasn't played any file/a single audio file, just spooling, and asking to download the audio file, or if I put it with no "user gesture" then I don't get the requester, which sometimes pops up/then closes all on its own, even when the "user Gesture" is active or not active. I'll reboot and see if something has been affected, but no process is shown "frozen"

    [UPDATE] I am getting no further at the moment. I get the CPU fan racing away, the CPU monitor goes to 100%, the audio "Play" ">" button just remains spooling on the BBC Sound page, and there's no sound. I see a spruiously/randomly numbered mp3 file in the download area but it doesn't play. I can play it with MorphOS 'Play' but it is a short musical piece only, no speech or singing or anything like it should sound like as media. Sometimes after I have actually closed/quit Wayfarer, the CPU fan continues to 'race' and only if I run "avail flush" does it soon, afterwards, about 5-10 seconds later start to suddenly drop back to normal speed and the CPU monitor drop back fairly quickly back to normal speed.

    Additional to that, I get a lot more graphic break-up, pages remain in blocks or sections look like links but the links are graphics that haven't re-drawn some few centimetres sometimes further up/down/side of where the link seems to be, but isn't. Also, sometimes the 1st or 3rd tab when it's closed it disappears (just the tab) but the page stays visible, and the additional tabs to the side don't fill in the space that's been left by it being closed, even though the page is displayed as it hasn't actually closed. If I click in the far right or another window a couple of tabs away then the windows shuffle back together and the page I tried to close then does actually visibly close and things go back to normal for the time being. Sometimes the middle mouse button click on the Quick-Link button seems to have no effect, but then after clicking on a few other buttons, about a few seconds later they all load in one almost instantaneous block of tabs. There seems to be something a bit weird with this v1.10, well that's what I'm finding at the moment.

    I'll try to do some more testing later today, but I've got other matters to attend to at the moment, so my further testing will have to wait for the time being, sadly.

    [ Edited by NewSense On 2020/12/31 10:21 ]
    MacMini 1.5GHz,10,2,64MB VRAM,1GB,Airport, Bluetooth,A1016 Keyboard,T-RB22 Mouse,DVD-RW-DL+CD-RW,Iomega MiniMax,Belkin 6 port 3 x Firewire/3 x, USB2, MorphOS 3.12, Mac OSX 10.4/10.5, A1138+A1139 PwrBk MOS v3.12,Model 5,8/5,9, & PowerMac G5 2.3GHz(DP)
  • »2020/12/31 9:12
    Profile
  • MorphOS Developer
    jacadcaps
    Joined: 2003/3/5
    Posts: 2513
    From: Canada
    Wow, newsense, you've a knack for problematic sites :) You can tweak playback settings to avoid the popup. The CPU usage is unlikely to be related to the player itself - must be JS on that site.

    Unfortunately it looks like I've broken my wrist yesterday, so any updates will be delayed.
  • »2020/12/31 15:59
    Profile Visit Website
  • Paladin of the Pegasos
    Paladin of the Pegasos
    NewSense
    Joined: 2012/11/10
    Posts: 1166
    From: Manchester, UK/GB
    Ouch !! :-/ That is bad news for you, and I hope you are not in too much pain/discomfort by now - is a plaster cast required? :-?

    The BBC obviously don't care about how much JS they use, they just want to keep the content they allow off their site to be accountable to them, as you have to login to gain access to the "Sounds" section of their website.

    Frankly I'm not that likely to listen to the music on there, as I'd much prefer to use WebRadio, or my own extensive music collection, as that works without any real issues, and plays what I want without any intervention. It's the video content from the BBC that might be handy to be able to access so sound then would be a factor, along with the video flow/throughput, but I can always use my Windows systems if I really, really need to if only to watch the content if it's important to me at the time and there's some urgency to do so. I'd much prefer to use MorphOS, but I have to be realistic about the CPU, and, probably unnecessary, over-use of JS, that will create other system overheads to be incurred with such media handling. :-(

    [ Edited by NewSense On 2021/1/1 8:04 ]
    MacMini 1.5GHz,10,2,64MB VRAM,1GB,Airport, Bluetooth,A1016 Keyboard,T-RB22 Mouse,DVD-RW-DL+CD-RW,Iomega MiniMax,Belkin 6 port 3 x Firewire/3 x, USB2, MorphOS 3.12, Mac OSX 10.4/10.5, A1138+A1139 PwrBk MOS v3.12,Model 5,8/5,9, & PowerMac G5 2.3GHz(DP)
  • »2021/1/1 8:05
    Profile