Software : : Poseidon V4.2 for MorphOS 1.4.5 PowerUP (Amiga Classic)
Posted By: platon42. on 2008/9/1 17:37:09
Something wonderful has happened! 2.5 years after the last update of Poseidon for MorphOS 1.4.x, the latest version V4.2 is now available for MorphOS 1.4.5 PowerUP Amigas. This version is not meant for Pegasos or Efika, nor for MorphOS 2.x installations. Please consider buying MorphOS 2.x for the latest Poseidon V4.x release.

The Poseidon V4.2 update can be downloaded using Trident online update (if V3.x is installed) or from my website http://www.platon42.de

If you want to support me, please consider donating an item from my Amazon wishlist (URL below). Thanks!

Amazon Wishlist: http://www.amazon.de/gp/registry/wishlist/1123KBN787GJQ
 
  • Paladin of the Pegasos
    Paladin of the Pegasos
    jcmarcos
    Joined: 2003/3/13
    Posts: 1178
    From: Pinto, Madrid ...
    Let's hope the MorphOS 2.0 Poseidon update comes next...
  • »2008/9/2 8:09
    Profile
  • Andreas_Wolf
    Joined: 2003/5/22
    Posts: 11000
    From: Germany
    > Let's hope the MorphOS 2.0 Poseidon update comes next...

    Let's rather hope MorphOS 2.1 with integrated and bugfixed Poseidon V4.2 comes next. A standalone Poseidon update would require even heavier MorphOS patching than with MorphOS 1.4.
  • »2008/9/2 9:49
    Profile
  • Paladin of the Pegasos
    Paladin of the Pegasos
    jcmarcos
    Joined: 2003/3/13
    Posts: 1178
    From: Pinto, Madrid ...
    Quote:

    A standalone Poseidon update would require MorphOS patching


    Really? And I was tempted about replacing my MorphOS 2.0 "massstorage.class" with this new one...

    I'm one of those shocked by a pendrive that doesn't work at all in 2.0, but worked perfectly in 1.4.5.
  • »2008/9/2 12:49
    Profile
  • Ex-Member
    Joined: 2004/6/15
    Posts: 74
    From:
    Quote:


    Really? And I was tempted about replacing my MorphOS 2.0 "massstorage.class" with this new one...

    I'm one of those shocked by a pendrive that doesn't work at all in 2.0, but worked perfectly in 1.4.5.


    And what would that help? The problems were mostly related to pciusb.device and obviously that is not part of MorphOS for PowerUP. And this specially compiled version of massstorage.class for MorphOS 1.4.5 doesn't use the mount.library of MorphOS 2.0. And that's just one difference.

    When I said you shouldn't use this version for 2.0, I had a reason.
    Bye...
    Chris Hodges
  • »2008/9/2 13:11
    Profile
  • Paladin of the Pegasos
    Paladin of the Pegasos
    jcmarcos
    Joined: 2003/3/13
    Posts: 1178
    From: Pinto, Madrid ...
    Quote:

    When I said you shouldn't use this version for 2.0, I had a reason


    Being a programmer like you, I like having detailed information about the reason for a "don't do it". I also suspected about something different in the operating system, rather than Poseidon.

    Thank you very much for the information, Chris! Great job!
  • »2008/9/3 10:27
    Profile