Software : : YAM 2.5 for MorphOS
Posted By: Targhan. on 2003/8/3 6:38:05
There has been a compile of YAM 2.5 (beta) for MorphOS. You can find it from this LINK.

*Note: It looks like you need to have previously installed YAM to use the MorphOS version.