Sound on Powerbook3,2 (G4)
  • Just looking around
    Posts: 1 from 2014/4/22
    Hi all,

    I'm new here and had the luck to come across a very nice Powerbook G4 (3,2), 867Mhz model with a still working battery.

    So, I immediately installed the latest MorphOS 3.5 after seeing that everything was working fine under MacOS X and loving my MorphOS experience on my Powermac G4.

    Installation went fine but somehow I cannot get audio from the system. Did I miss anything? On my Powermac G4 the sound is not working either and the volume icon is always on low. On the Powerbook the volume seems to be okay, but I can't get any audio playing (simply playing an audio CD)

    I'm assuming I can't get audio to one of the emulators which I'm planning to use (Like E-UAE and perhaps some more).

    Looking forward to your replies.
  • »22.04.14 - 23:47
    Profile Visit Website
  • MorphOS Developer
    cyfm
    Posts: 370 from 2003/4/11
    From: Germany
    If you are refering to a Titanium PowerBook >3,5<, you are probably right. It has been inofficially enabled for MorphOS since release 3.4 but I couldn't get the sound to work properly. It basically acts like it does output the sound but it is muted.
  • »23.04.14 - 11:13
    Profile Visit Website
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    KimmoK
    Posts: 102 from 2003/5/19
    I bought powerbook G4 3.5:
    http://www.everymac.com/systems/apple/powerbook_g4/specs/powerbook_g4_1.0.html

    Otherwise seems ok and speedy with MorphOS, but no sound. (worked ok in OSX)

    (perhaps a list of supported HW needs some mention that audio does not work on powerbook 3.4...3.5 models???)
    "On this page, you find a list of hardware that is directly supported by MorphOS 3.x."
    "Computers"
    "Apple PowerBook G4**"
    "* * - Only models with a Radeon graphics chip are supported."


    Any info if work is done to enable audio on those low end PowerBooks? (essential component of any "Amiga")

    (I imagine it might be minor issue in i2s implementation, if someone needs tester for i2s fix for 3.5 powerbook, send me pm)

    UPDATE:
    Some things that I've learned: these old powerbooks use ADB interface for touchpad and keyboard connection, because of that, the touchpad is not detected properly and keyboard does not work that nicely (ctrl+apple+apple does not do reboot). Also battery info might not show up correctly.
    (anyway, I bought this for eur50 with 1G RAM and new DVD drive + spare battery and so far I have enjoyed it greatly, I will register OS for this and hope to see fixes for audio and ADB stuff one day)

    [ Edited by KimmoK 29.05.2014 - 11:35 ]
    :-x :-P 8-)
  • »16.05.14 - 14:04
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    pegasos-sigi2
    Posts: 256 from 2006/8/31
    At Kimmok:

    "It has been inofficially enabled for MorphOS since release 3.4"
    That mean: First the other things than this sound problem

    [ Edited by pegasos-sigi2 16.05.2014 - 15:28 ]
    Spreedy - The spreedsheet editor of MorphOS
    Calimero - Do you know about the new DTP Program for MorphOS ?
  • »16.05.14 - 14:25
    Profile
  • Just looking around
    Posts: 12 from 2017/8/9
    This laptop (PowerBook 3,5) still works with 3.10 and audio still does not work, as described above.

    Also, the boot splash screen shows my system as 667 MHz but actually it's an 867 model. I remember reading something about why this happens but I can't find it anymore.

    This is one of my favorite models because it can natively boot Mac OS 9.2.2 through OS X 10.5.8 *and* MorphOS!
  • »05.06.18 - 02:25
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    polluks
    Posts: 369 from 2007/10/23
    From: Gelsenkirchen,...
    Quote:

    uchar schrieb:
    Also, the boot splash screen shows my system as 667 MHz but actually it's an 867 model. I remember reading something about why this happens but I can't find it anymore.


    So you didn't make a bug report?
    Pegasos II G4: MorphOS 3.9, Zalman M220W
    Power Mac G3: OSX 10.3 · PowerBook 5,8: OSX 10.5, MorphOS 3.10
  • »05.06.18 - 04:21
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    NewSense
    Posts: 637 from 2012/11/10
    From: Manchester, UK...
    Quote:

    uchar wrote: This laptop (PowerBook 3,5) still works with 3.10 and audio still does not work, as described above.

    I feel I should mention the recently implemented Isochronous audio option so you may be able to get sound output for this model, via USB audio, possibly using one of the two Behringer (UCA 222 and UCA 202) models already tested by "Tcheko" in the Development Team, or try one of the other working devices that have been tested by other users.

    You may be in the fortunate situation where you can save the AHI prefs for such a device as being the only audio device to use, as it seems there is no other available/working for your PowerBook model, so you can keep the USB device plugged in for each reboot/switch on, and actually get sound output to work consistently for your hardware.

    I tried the Griffin iMic, and a C-Media USB audio device on my MacMini, but once de-activated they both, individually, froze my system, requiring a switch off / reboot, so I don't want to have to suffer that inconvenience, of unnecessary reboots, but you may get better mileage with your limited options, just thought I'd mention it to you, but as far as I am aware there is no System Volume Control that works with this audio option - apart from using Jukebox, where you can use the internal volume control of that program to control volume level. Maybe you can control its volume with any other program you use that has some form of internal volume control.

    I just hope this information is of some use to you. ;-)
    Mac Mini 1.5GHz, Model 10.2, 64MB VRam, 250GB HDD, 1GB RAM, Airport, Bluetooth, Wireless Keyboard & Mouse, DVD-RW-DL+CD-RW, Iomega MiniMax, Belkin 6 port 3 x Firewire/3 x USB2, MorphOS 3.9, Mac OS X 10.4 & 10.5 & A1138 Powerbook MOS v3.9, Model 5,8 (Also
  • »05.06.18 - 05:21
    Profile