Napalm on MorphOS
  • Order of the Butterfly
    Order of the Butterfly
    kriz
    Posts: 252 from 2005/10/18
    From: No(R)way
    cool, this i must try !!
    -- Amiga 1200/4000 - Pegasos2 - MacMiniG4 / PowerBookG4 -- Horrordelic Records - Darkpsy Psychedelic Label - Based in Norway (Hell) --
  • »02.12.11 - 02:32
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    XDelusion
    Posts: 602 from 2010/10/27
    As much as I LOVE MorphOS,, the fact that I can not get ImageFX to work right, and the fact that so many PPC RTG games do not work right, really irritates me to no end.

    I am the only guy who can not get sound to work in game when playing Shogo. The menus are fine, but once I start the game the sound vanishes. Likewise, I seem to be the only guy who can't get ImageFX to work either. Strange...

    On the other hand I did get WipeOut to work, and though it does have issues upon startup, it work, so I'm good, but it would be really nice if more than one RTG game worked on here. There are so many titles that I'd love to be enjoying but can not because I can't afford the hardware to run OS 4 on (assuming it does not have compatibility issues as well), or a PPC card at a good price for my classic Amiga(s).

    TOTAL BUMMER!

    So yes, I for one agree, it would be grand to get this game running right under MorphOS. I wonder what's holding it back? If only the sources had been released....
    "I hope life isn't a big joke, because I don't get it." - Jack Handey

    Registered MorphOS user, Amiga user, and Atari 8-bit user.
  • »02.12.11 - 05:06
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11575 from 2003/5/22
    From: Germany
    > I am the only guy who can not get sound to work in game when playing Shogo.

    This is not true, and you know it.

    https://morph.zone/modules/newbb_plus/viewtopic.php?topic_id=7754&forum=10&start=11
    https://morph.zone/modules/newbb_plus/viewtopic.php?topic_id=5995&forum=16&start=1

    > it would be really nice if more than one RTG game worked on here.

    I'm sure it's more than one.

    > I can't afford the hardware to run OS 4 on (assuming it does not have
    > compatibility issues as well)

    OS4 has worse compatibility to those games than MorphOS.

    > it would be grand to get this game running right under MorphOS.
    > I wonder what's holding it back?

    Nothing. Missed my posting above?
  • »02.12.11 - 11:30
    Profile
  • jPV
  • Paladin of the Pegasos
    Paladin of the Pegasos
    jPV
    Posts: 1885 from 2003/2/24
    From: po-RNO
    Quote:

    It has been accomplished:

    http://os4depot.net/?function=showfile&file=game/strategy/napalm.lha


    Ooooh! \o/ Wow...aaaah... finally! :) Seems to work o//

    But...but... network is disabled :( It is pretty essential thing to fully enjoy the game. Wake me up again when it's done too ;) /me continues to wait... but probably takes little single player game meanwhile :P
  • »02.12.11 - 17:45
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11575 from 2003/5/22
    From: Germany
    > network is disabled :( [...] Wake me up again when it's done too ;)

    New version from today (same link) has written "Included experimental serial network driver (not tested)" in its changelog.
  • »06.12.11 - 13:48
    Profile
  • Moderator
    Miky060
    Posts: 694 from 2003/2/24
    From: ITALY
    Here it does not works. Looking Snoopium it seems it looks for picasso.library..

    In every case I get a window that says "ERROR #0010: Unable to open library!"


    [ Edited by Miky060 06.12.2011 - 14:38 ]

    PegasosII "Elite" Machine --> PowerMac MDD "popular" Machine --> MacMini 1.5 "still more popular" Machine
  • »06.12.11 - 14:35
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11575 from 2003/5/22
    From: Germany
    > I get a window that says "ERROR #0010: Unable to open library!"

    Maybe you missed the "OS4Emu" part in posting #8?
  • »06.12.11 - 14:42
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11575 from 2003/5/22
    From: Germany
    > OS4emu is only needed for CD audio. I didn't use that cdplayer.library at all.

    I don't use CD audio either but here patched Napalm refuses to start and complains that it can't load the lib if OS4Emu is not running.

    > do you have rtgmaster installed?

    Is that really needed with the patched version? The patch author said he removed the RTGMaster dependencies:

    http://www.amigans.net/modules/xforum/viewtopic.php?post_id=63637#forumpost63637
    http://www.amigans.net/modules/xforum/viewtopic.php?post_id=67008#forumpost67008
  • »06.12.11 - 14:59
    Profile
  • Moderator
    Miky060
    Posts: 694 from 2003/2/24
    From: ITALY
    I have the morphos native rtgmaster.library in my sys:Libs/
    Tryed also to launch PatchLoadSegOS4 before launching Napalm, but nothing changes..

    PegasosII "Elite" Machine --> PowerMac MDD "popular" Machine --> MacMini 1.5 "still more popular" Machine
  • »06.12.11 - 15:09
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11575 from 2003/5/22
    From: Germany
    > Tryed also to launch PatchLoadSegOS4 before launching Napalm,
    > but nothing changes..

    Then I'm puzzled, sorry.
  • »06.12.11 - 15:15
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    defender
    Posts: 245 from 2011/4/24
    Hey there, I have installed Napalm and direct after that I installed the 1.4 Patch from the AmigaFuture Page (just copy all files from the lha into the Napalm dirctory). On my Morphos 2.7 there is no RTG Master installed. After that I installed the Napalm OS4 Installer (delete the word "abort" command in row 16, and change the info to use the standart programm Morphos:c/installer). Well that's it. Ok for the sound you have to edit the NAPALM.PREFS file with ED so that row 29 (Audio_Driver) shows NAPALM_E:Audio.ahi. Additional you have to set Vertical sync inside the game (ESC while playing and then into the game_control menue). Until now I've played the first mission and that was quit impressive against
    my original A1200 with all its addons.

    greets defender
    PowerMac 3.6 - Radeon 9000_64Mb - 1,5Gb Ram - SB Live - MorphOS 3.9
    CD32 - PowerBook 1,67GHz 1GB/100GB - MorphOS 3 reg. 1455
  • »06.12.11 - 17:52
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11575 from 2003/5/22
    From: Germany
    > On my Morphos 2.7 there is no RTG Master installed.

    Thanks for confirming that RTGMaster isn't required any longer.
  • »06.12.11 - 18:23
    Profile
  • Moderator
    Miky060
    Posts: 694 from 2003/2/24
    From: ITALY
    Andreas are you sure you are not useing the rtgmaster.library that is in Napalm/Libs directory? If you delete it the game still works?

    PegasosII "Elite" Machine --> PowerMac MDD "popular" Machine --> MacMini 1.5 "still more popular" Machine
  • »06.12.11 - 20:57
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11575 from 2003/5/22
    From: Germany
    > Andreas are you sure you are not useing the rtgmaster.library that is in
    > Napalm/Libs directory? If you delete it the game still works?

    Yes, I have no rtgmaster.library there. However, I have one located in libs: but I'm not in reach of my MorphOS machine right now so cannot test what happens if I delete it from there. Have a look above where defender just said in this thread that he doesn't have rtgmaster.library installed and yet Napalm runs.
  • »06.12.11 - 21:03
    Profile
  • Just looking around
    nujack
    Posts: 8 from 2006/9/8
    From: Leipzig
    Miky060,
    Quote:

    "ERROR #0010: Unable to open library!"


    I receive the same Error-message on my MacMini with MOS2.6. Strange. Which library is needed?
    Snoopium tells something about Picasso96API and rtg.library.
    Any hints are welcome.
  • »08.12.11 - 15:43
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    defender
    Posts: 245 from 2011/4/24
    The Problem belongs to your rtgmaster.library and you really have to install OS4 emulation. On your system
    there should be !no! RTGmaster installed, because it will be generated every time you start the game and if it works
    there will be !no! screen requester the game just simply starts. And you have to update to napalm 1.4 before installing
    the OS4 Napalm patch. By the way the game crashes quiet often, its no fun to play it ~ at
    least on my machine (Powermac3,6 /1,5Gb/Radeon9250-128Mb) good luck and good night!
    PowerMac 3.6 - Radeon 9000_64Mb - 1,5Gb Ram - SB Live - MorphOS 3.9
    CD32 - PowerBook 1,67GHz 1GB/100GB - MorphOS 3 reg. 1455
  • »08.12.11 - 21:58
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11575 from 2003/5/22
    From: Germany
    > Andreas are you sure you are not useing the rtgmaster.library that is in
    > Napalm/Libs directory? If you delete it the game still works?

    I'm now back on my MorphOS machine and this is what I've found. There's a severe difference between the recent patch version from December 6th and the initial version that was released before:

    * old version: works on MorphOS; needs v1.4 executable as patch base, needs OS4Emu (if OS4 version of cdplayer.library is used), doesn't need rtgmaster.library
    * new version: doesn't work on MorphOS ("ERROR #0010: Unable to open library!"), needs original Napalm CD executable as patch base, OS4Emu on/off makes no difference, rtgmaster.library installed/removed makes no difference

    So I only tried the recent patch version just now and so far I've not managed to make it run on MorphOS. The previous version still runs fine of course with the parameters set as mentioned above. I apologize for the confusion I may have caused.
  • »09.12.11 - 01:52
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11575 from 2003/5/22
    From: Germany
    > The Problem belongs to your rtgmaster.library and you really have to install
    > OS4 emulation. On your system there should be !no! RTGmaster installed

    With the new patch version released on December 6th removing rtgmaster.library and switching on/off OS4Emu makes no difference here. Napalm refuses to start, complaining with the mentioned error message.

    > you have to update to napalm 1.4 before installing the OS4 Napalm patch.

    That is required for the old version of the patch. The recent version cannot use the v1.4 executable as patch base but absolutely needs the original Napalm CD executable. Do you really run the most recent executable (132,108 bytes) on MorphOS, not the previous one (131,900 bytes)?
  • »09.12.11 - 02:05
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    defender
    Posts: 245 from 2011/4/24
    I appologize, after your post I took the newest version (from Monday) and it shows the same errors.
    It seems to be a change in the crimsoncrisses file - so we have to take the previous version to run the game.
    Has any of you had the same stability problem when getting into the secound level ?

    sorry for spreading confusion
    defender
    PowerMac 3.6 - Radeon 9000_64Mb - 1,5Gb Ram - SB Live - MorphOS 3.9
    CD32 - PowerBook 1,67GHz 1GB/100GB - MorphOS 3 reg. 1455
  • »09.12.11 - 15:40
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11575 from 2003/5/22
    From: Germany
    > after your post I took the newest version (from Monday) and it shows the same errors.

    Thanks for clarification.

    > we have to take the previous version to run the game.

    Yes. Let's hope there'll be future versions that will work on MorphOS again.
  • »09.12.11 - 16:16
    Profile
  • Moderator
    Miky060
    Posts: 694 from 2003/2/24
    From: ITALY
    Ok, so now can someone give a link to have the old version of the napalm patch? It's no more available online..

    PegasosII "Elite" Machine --> PowerMac MDD "popular" Machine --> MacMini 1.5 "still more popular" Machine
  • »09.12.11 - 17:36
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    defender
    Posts: 245 from 2011/4/24
    I have send it to your e-mail adress.
    Hope you'll get it from your provider.

    greets
    defender
    PowerMac 3.6 - Radeon 9000_64Mb - 1,5Gb Ram - SB Live - MorphOS 3.9
    CD32 - PowerBook 1,67GHz 1GB/100GB - MorphOS 3 reg. 1455
  • »09.12.11 - 19:21
    Profile Visit Website