amirss ssl version
  • Butterfly
    Butterfly
    alfie
    Posts: 96 from 2005/3/25
    From: Italy
    analogkid wrote in another thread:
    Quote:

    Sorry for being offtopic.. it would be great if you consider updating AmRSS with SSL support.


    This is a very quick "add ssl and try a couple of times", you test it :P

    https://alfie.altervista.org/downloads/amrssl.lha




    [ Edited by alfie 24.06.2024 - 23:33 ]
  • »24.06.24 - 22:21
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    analogkid
    Posts: 664 from 2004/11/3
    From: near myself
    Thanks! I've been literally waiting years for it. I'm testing it now.
  • »25.06.24 - 12:12
    Profile
  • Paladin of the Pegasos
    Paladin of the Pegasos
    NewSense
    Posts: 1497 from 2012/11/10
    From: Manchester, UK/GB
    @ alfie - if I try to add the MorphOS Storage RSS Feed then AmRSS(L) - this latest version cannot access the feed, even though I know it's working, as you will see if you click on the inline weblink, so maybe that needs some understanding why AmRSS(L) doesn't access it, as it reads "can't connect to host" - well it would if it was spelled correctly - which is a very minor point. 8-)

    I spotted there are a few minor spelling errors in the English text of the program, and wondered if you wanted a corrected file for the program, to improve its readability ... for English readers!? :-?

    There are some old sites that don't have correct data for them, which includes Morph-Zone as it doesn't have a RSS feed, but by editing the updated correct web address it makes it easier to double-click and load the website via AmRSS(L). ;-)

    The BBC News and weather website pages still have RSS feeds that get updated, so they work OK currently.

    BBC NEWS RSS (xml) feed
    BBC Weather for Manchester UK

    Other weather forecasts are of course available. 8-D
    MacMini 1.5GHz,64MB VRAM, PowerBooks A1138/9 (Model 5,8/9),PowerMac G5 2.3GHz(DP), iMac A1145 2.1GHz 20", all with MorphOS v3.18+,Airport,Bluetooth,A1016 Keyboard,T-RB22 Mouse,DVD-RW-DL,MiniMax,Firewire/USB2 & MacOSX 10.4/5
  • »29.06.24 - 12:46
    Profile
  • Butterfly
    Butterfly
    alfie
    Posts: 96 from 2005/3/25
    From: Italy
    the version I posted is broken in multiple ways, sorry :(

    first of all, it is compiled with LITTLE_AMRSS set, amrss had a lot of compilation flags to produce a very minimal classic version, a nlist version, a mos version and a full mos version

    also, many things are broken, because of reason (1)

    the actual version I am working on is much better and ... let's test that site...


    (1) I am lazy when it's so hot, so so hot


    [ Edited by alfie 29.06.2024 - 21:24 ]
  • »29.06.24 - 13:23
    Profile Visit Website
  • Butterfly
    Butterfly
    alfie
    Posts: 96 from 2005/3/25
    From: Italy
    This is the error I get
    Code:

    Work318:devs/tmp> tls www.morphos-storage.net
    Error attempting to connect
    1739D100:error:0A000438:SSL routines:ssl3_read_bytes:tlsv1 alert internal error::0:SSL alert number 80


    I don't know what to say/do... Mos OpenSSL pros are needed.
  • »29.06.24 - 18:24
    Profile Visit Website
  • Paladin of the Pegasos
    Paladin of the Pegasos
    NewSense
    Posts: 1497 from 2012/11/10
    From: Manchester, UK/GB
    @ alfie - probably others in the MorphOS Development Team, such as Piru will know what to say/do (not that I am saying he, or they, will, but he/they will probably know what is required) to fix this issue, and maybe it can be fixed by changing some server settings on the MorphOS-Storage website, maybe Papiosaur or beworld will know if they can fix the problem directly on their website, or maybe there are other members who will understand the problem, and know how to fix it . . . hopefully! ;-)

    That's if they consider it to be worth their valuable time to look into/address the problem. 8-)

    I added the AmigaFuture's RSS feed to AmRSS(L) and that works without any issues, so surely it can be fixed without too much effort, and probably without the need to drag the MOS Dev. Team into the problem. 8-D
    MacMini 1.5GHz,64MB VRAM, PowerBooks A1138/9 (Model 5,8/9),PowerMac G5 2.3GHz(DP), iMac A1145 2.1GHz 20", all with MorphOS v3.18+,Airport,Bluetooth,A1016 Keyboard,T-RB22 Mouse,DVD-RW-DL,MiniMax,Firewire/USB2 & MacOSX 10.4/5
  • »30.06.24 - 06:26
    Profile
  • Butterfly
    Butterfly
    alfie
    Posts: 96 from 2005/3/25
    From: Italy
    NewSense, yesterday, after the Italy debacle :P I needed to think to something else, so I spent a lot of time trying to understand what's wrong with that site. I chatted with Piru in irc and he doesn't really know. Different versions of curl on different system report the same problem as in amirc, while other versions work.

    The consensus is that something is wrong on the server side and I can't understand what exactly. Also, I tried to set all the ssl options curl set internally and nothing worked.

    The curl command in MorphOS 3.18 fails; if you can make it work, probably it will work in amrss too (amrss doesn't use curl library, but I am positive that it will work).

    Sorry, don't know what to do.
  • »30.06.24 - 08:53
    Profile Visit Website
  • MorphOS Developer
    Piru
    Posts: 582 from 2003/2/24
    From: finland, the l...
    This issue also occurs with Debian stable (OpenSSL 3.0.13 30 Jan 2024) and Debian unstable (OpenSSL 3.2.2 4 Jun 2024), so it clearly is some generic configuration issue.
  • »30.06.24 - 12:40
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Papiosaur
    Posts: 2073 from 2003/4/10
    From: France
    Quote:

    NewSense a écrit :
    @ alfie - probably others in the MorphOS Development Team, such as Piru will know what to say/do (not that I am saying he, or they, will, but he/they will probably know what is required) to fix this issue, and maybe it can be fixed by changing some server settings on the MorphOS-Storage website, maybe Papiosaur or beworld will know if they can fix the problem directly on their website, or maybe there are other members who will understand the problem, and know how to fix it . . . hopefully! ;-)

    That's if they consider it to be worth their valuable time to look into/address the problem. 8-)

    I added the AmigaFuture's RSS feed to AmRSS(L) and that works without any issues, so surely it can be fixed without too much effort, and probably without the need to drag the MOS Dev. Team into the problem. 8-D

    Personnaly, i don't know the origin of the problem, i have send a message to BeWorld about that. I hope he could find a solution. As NewSense said, if somebody has ideas, i could try to resolve it too if i can.
  • »01.07.24 - 10:35
    Profile Visit Website
  • Butterfly
    Butterfly
    alfie
    Posts: 96 from 2005/3/25
    From: Italy
    I finally found that adding
    SSL_set_tlsext_host_name(ssl,hostName);
    f.e.
    SSL_set_tlsext_host_name(ssl,"www.morphos-storage.net");

    makes it work, without even setting a cb

    why this is the only one site I found to need that, I don't know.

    [ Edited by alfie 01.07.2024 - 19:13 ]
  • »01.07.24 - 18:13
    Profile Visit Website
  • MorphOS Developer
    Piru
    Posts: 582 from 2003/2/24
    From: finland, the l...
    Quote:

    alfie wrote:
    I finally found that adding
    SSL_set_tlsext_host_name(ssl,hostName);
    f.e.
    SSL_set_tlsext_host_name(ssl,"www.morphos-storage.net");

    makes it work, without even setting a cb

    why this is the only one site I found to need that, I don't know.


    This is due to Server Name Indication" (SNI): https://www.cloudflare.com/en-gb/learning/ssl/what-is-sni/

    Basically many servers only host a single HTTPS enabled site. In order to allow multiple sites to be hosted on a single IP/port SNI was created. If the SNI needed and is not specified the server doesn't know which site you want to talk to -> error. IP/port that only host a single site work without specifying the hostname extension (SNI).

    This particular server is a bit unusual since it errors out during the TLS connection phase already. Typically the server will rather just host their "default" site (which will then result in TLS certificate validation error due to mismatched host certificate) rather than error out like that (this threw me off and I didn't think that missing SNI could have been the issue).

    SNI is definitely needed in modern web and should always be specified.

    [ Edited by Piru 01.07.2024 - 21:22 ]
  • »01.07.24 - 19:04
    Profile
  • Butterfly
    Butterfly
    alfie
    Posts: 96 from 2005/3/25
    From: Italy
    Yes, Piru, you are right.

    Very content, it works:
    RAG5F

    P.S. One day, I will ruin your day on IRC to switch from codesets.library to charsets. I wrote codesets.library just for amrss, but it doesn't seem to be capable of doing what I want. But I don't know how to use charsets.library in expat unknown codeset hook.



    [ Edited by alfie 01.07.2024 - 22:38 ]
  • »01.07.24 - 21:31
    Profile Visit Website
  • Paladin of the Pegasos
    Paladin of the Pegasos
    NewSense
    Posts: 1497 from 2012/11/10
    From: Manchester, UK/GB
    @ alfie - great that you continued to figure out the issue, and resolve it, 8-)

    . . . so when will the newer functional executable archive be released? :-?

    As usual Piru - you're extensive knowledge of networking is awe inspiring ! :-o

    Is this trouble due to the dreaded "Cloudflare" that we can well do without? :-?
    MacMini 1.5GHz,64MB VRAM, PowerBooks A1138/9 (Model 5,8/9),PowerMac G5 2.3GHz(DP), iMac A1145 2.1GHz 20", all with MorphOS v3.18+,Airport,Bluetooth,A1016 Keyboard,T-RB22 Mouse,DVD-RW-DL,MiniMax,Firewire/USB2 & MacOSX 10.4/5
  • »02.07.24 - 07:14
    Profile