Heretic II port new version?
  • Just looking around
    PPCenby
    Posts: 15 from 2022/12/4
    Hi! Does anyone know if the new version of Heretic II will work on MorphOS?
    https://www.amiga-shop.net/en/Amiga-Software/Amiga-Games/Heretic-II-for-AmigaOS-4::1354.html
  • »22.03.24 - 21:33
    Profile
  • MorphOS Developer
    zukow
    Posts: 642 from 2005/2/9
    From: Poland
    68k version should work
  • »22.03.24 - 21:51
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 12073 from 2003/5/22
    From: Germany
    > Does anyone know if the new version of Heretic II will work on MorphOS?

    How can it? It's an OS4 version.
  • »22.03.24 - 23:12
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 12073 from 2003/5/22
    From: Germany
    > 68k version should work

    That's not released yet, isn't it? And it will surely run slower on MorphOS than the old PPC version for OS3/WarpUP.
  • »22.03.24 - 23:13
    Profile
  • Just looking around
    PPCenby
    Posts: 15 from 2022/12/4
    Quote:

    Andreas_Wolf wrote:
    > 68k version should work

    That's not released yet, isn't it? And it will surely run slower on MorphOS than the old PPC version for OS3/WarpUP.


    Yes, but unfortunately under current versions of MorphOS the old PPC version of Heretic II crashes after the tutorial when the first level loads.

    [ Edited by PPCenby 22.03.2024 - 18:25 ]
  • »23.03.24 - 00:16
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    KennyR
    Posts: 872 from 2003/3/4
    From: #AmigaZeux, Gu...
    Quote:

    PPCenby wrote:
    Quote:

    Andreas_Wolf wrote:
    > 68k version should work

    That's not released yet, isn't it? And it will surely run slower on MorphOS than the old PPC version for OS3/WarpUP.


    Yes, but unfortunately under current versions of MorphOS the old PPC version of Heretic II crashes after the tutorial when the first level loads.


    The game plays a video immediately before starting play in the main campaign. That's probably where it's crashing. Maybe try disabling the videos?

    You got the tutorial working, so you've conquered the hardest challenge - actually getting Warp3D to work. As far as my now very dim memory recalls, the Warp3D wrapper used Rave and this was dropped for Radeons after the 9xxx series.

    [ Edited by KennyR 24.03.2024 - 19:34 ]
  • »24.03.24 - 20:28
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Cego
    Posts: 707 from 2006/5/28
    From: Germany
    Quote:

    PPCenby wrote:
    Quote:

    Andreas_Wolf wrote:
    > 68k version should work

    That's not released yet, isn't it? And it will surely run slower on MorphOS than the old PPC version for OS3/WarpUP.


    Yes, but unfortunately under current versions of MorphOS the old PPC version of Heretic II crashes after the tutorial when the first level loads.


    works here nicely
    Pegasos II G4 @1.0GHz, 1GB DDR Ram, Radeon 9200Pro, 240GB SSD+160GB HD, MorphOS 3.18, AmigaOS4.1 FE, Debian 8
  • »24.03.24 - 21:37
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 12073 from 2003/5/22
    From: Germany
    > Rave […] was dropped for Radeons after the 9xxx series.

    With R300, so after Radeon 9250. TinyRave to the rescue!
  • »24.03.24 - 23:31
    Profile
  • Just looking around
    PPCenby
    Posts: 15 from 2022/12/4
    Quote:

    KennyR wrote:
    [The game plays a video immediately before starting play in the main campaign. That's probably where it's crashing. Maybe try disabling the videos?

    You got the tutorial working, so you've conquered the hardest challenge - actually getting Warp3D to work. As far as my now very dim memory recalls, the Warp3D wrapper used Rave and this was dropped for Radeons after the 9xxx series.


    How do I disable videos? Is there a console command? There doesn't seem to be an option in the menu as far as I could see.

    I'm running on the "silent upgrade" Mac Mini with the 64MB Radeon 9200.
  • »25.03.24 - 19:23
    Profile
  • man
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    man
    Posts: 104 from 2019/11/11
    rename or delete the videos
  • »25.03.24 - 22:20
    Profile
  • Just looking around
    PPCenby
    Posts: 15 from 2022/12/4
    Quote:

    man wrote:
    rename or delete the videos


    I can't find the videos in the Heretic II drawer.
  • »07.04.24 - 18:33
    Profile
  • man
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    man
    Posts: 104 from 2019/11/11
    have you search base/videos
  • »08.04.24 - 07:19
    Profile
  • man
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    man
    Posts: 104 from 2019/11/11
    shows alls drawers
  • »08.04.24 - 07:19
    Profile
  • Just looking around
    PPCenby
    Posts: 15 from 2022/12/4
    Quote:

    man wrote:
    have you search base/videos


    The drawer's empty...
  • »09.04.24 - 20:28
    Profile
  • man
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    man
    Posts: 104 from 2019/11/11
    you can try by the system 'search'
    with the drawer of heretic 2 use mouse with search and make choice type 'video'
    but i m not sure this applicatio of morphos work perfectly
  • »10.04.24 - 07:55
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    KennyR
    Posts: 872 from 2003/3/4
    From: #AmigaZeux, Gu...
    Quote:

    PPCenby wrote:
    Quote:

    man wrote:
    have you search base/videos


    The drawer's empty...


    Possibly why the game is crashing then - looking for videos and not being able to find them, rather than finding them and crashing when trying to play.

    There should be three videos in base/VIDEO - Bumper, Intro and Outro. I don't have access to my old install of the game on MorphOS any more, but the PC originals are .smk (smacker), while Hyperion had to change that to something else for legal reasons.
  • »12.04.24 - 08:49
    Profile
  • Just looking around
    PPCenby
    Posts: 15 from 2022/12/4
    Thanks for the information, everyone! I copied the .smk files from the VIDEO drawer in disc B to the one on the hard drive. That solved the crashing issue, and I can get into the game now! However, when the video plays, there's just a black screen with audio only.
  • »12.04.24 - 17:30
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    KennyR
    Posts: 872 from 2003/3/4
    From: #AmigaZeux, Gu...
    Quote:

    PPCenby wrote:
    Thanks for the information, everyone! I copied the .smk files from the VIDEO drawer in disc B to the one on the hard drive. That solved the crashing issue, and I can get into the game now! However, when the video plays, there's just a black screen with audio only.


    I think that may always have been the case on MorphOS.
  • »12.04.24 - 22:15
    Profile
  • man
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    man
    Posts: 104 from 2019/11/11
    i have not find wizard.library mos so i use wizard.library 45.1 68k (to see if the last on 0s3.2.2 if better)and rtgmaster.library 42.2 mos for the old heretic 2 perhaps the new heretic 2 needs too
  • »14.04.24 - 15:04
    Profile
  • man
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    man
    Posts: 104 from 2019/11/11
    a part of my config of this game but i have no music for moment

    set compass "1"
    set r_detail "3"
    set cl_yawspeed "70"
    set dm_no_bodies "0"
    set ami_soundcache "1500000"
    set con_alpha "0.7"
    set advancedstaff "1"
    set allow_download_sounds "1"
    set allow_download_models "1"
    set allow_download_players "1"
    set allow_download_maps "1"
    set allow_download "1"
    set gl_skinmip "0"
    set gl_fog_enddist "1024.0"
    set gl_notileclear "0"
    set gl_polyoffset "0"
    set gl_dither "1"
    set gl_fontfix1 "256"
    set gl_fontfix2 "1024"
    set gl_mintriarea "1.0"
    set gl_texturecache "26214400"
    set gl_closeworkbench "0"
    set gl_sync "1"
    set gl_buffers "3"
    set gl_forcedepth "32"
    set hostname "Parthoris"
    set sv_jumpcinematic "0"
    set sv_reconnect_limit "3"
    set vid_ref "gl"
    set vid_xpos "0"
    set vid_ypos "0"
    set vid_brightness "0.562500"
    set win_noalttab "0"
    set gl_driver "MiniGL/Warp3D"
    set gl_ext_palettedtexture "1"
    set viewsize "100"
    set s_volume "0.900000"
    set s_sounddir "sound"
    set s_khz "44"
    set s_mixahead "0.2"
    set cd_nocd "1"
    set adr0 ""
    set adr1 ""
    set adr2 ""
    set adr3 ""
    set adr4 ""
    set adr5 ""
    set adr6 ""
    set adr7 ""
    set adr8 ""
    set cl_stereo_separation "0.4"
    set lookspring "1"
    set lookstrafe "0"
    set mouse_sensitivity_x "4"
    set mouse_sensitivity_y "4"
    set doubletap_speed "100"
    set m_pitch "0.022"
    set cl_camera_dampfactor "0.2"
    set name "Corvus"
    set skin "Corvus"
    set skindir "skins"
    set rate "2800"
    set msg "1"
    set fov "75.0"
    set in_mouse "1"
    set in_joystick "1"
    set file_gamemsg "gamemsg.txt"
    set file_levelmsg "levelmsg.txt"
    set gl_particle_min_size "2"
    set gl_particle_max_size "40"
    set gl_particle_size "40"
    set gl_particle_att_a "0.01"
    set gl_particle_att_c "0.01"
    set gl_picmip "0"
    set gl_ext_swapinterval "1"
    set gl_ext_gamma "1"
    set gl_ext_pointparameters "1"
    set gl_swapinterval "1"
    set cl_doautoaim "1"
    set gl_lockmode "MANUAL"
    set s_modeid "196610"
    set vid_mode "9"
    set vid_gamma "0.625000"
    set vid_contrast "0.837500"
    set snd_dll "ahisnd.dll"
    set shownames "1"
    set sc_framerate "20.0"
    set s_loadas8bit "0"
    set no_middle_text "0"
    set gl_texturemode "gl_linear_mipmap_linear"
    set gl_sortmulti "5"
    set gl_shadows "1"
    set gl_particle_att_b "0.0"
    set gl_modulate "1"
    set gl_ext_multitexture "5"
    set gl_driver0 "3DfxGL_Ht2dll"
    set freelook "1"
    set crosshair "4"
    set cl_run "0"
    set cl_camera_fpheight "0.0"
    set blood_level "2"
    set autoweapon "1"
    set pakfirst "0"
    set vid_fullscreen "1"
  • »14.04.24 - 15:35
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    KennyR
    Posts: 872 from 2003/3/4
    From: #AmigaZeux, Gu...
    It's nothing to do with your config. The old cdplayer.library does nothing on MorphOS. You need the MorphOS replacement to play CD audio.

    https://aminet.net/package/util/libs/cdplayer_lib_ahi
  • »15.04.24 - 23:06
    Profile