AmigaOne X5K & MorphOS & Dual Boot... Oh My!
  • Caterpillar
    Caterpillar
    Posts: 25 from 2023/12/1
    Lions & Tigers & Bears... Oh My!

    I mean...

    AmigaOne X5K & MorphOS & Dual Boot... Oh My!

    This is stage 1 of my efforts to make my AmigaOne X5K boot both the Amiga OS 4.1 and MorphOS 3.18.

    This is the 1st video about my plans, my system, some peaks inside, and 1st boot (from MorphOS Installer USB Stick) after installing a 2nd Video Card in my X5000.

    Long video but hope some find it fun!

    https://youtu.be/ZpwUkdsYGpU

    adding a 2nd video showing the final product of it all working.

    https://youtu.be/xli0F-cIa6k

    [ Edited by amigasociety 13.01.2024 - 14:40 ]
  • »12.01.24 - 17:35
    Profile Visit Website
  • esc
  • Order of the Butterfly
    Order of the Butterfly
    esc
    Posts: 154 from 2013/5/28
    Love it!

    Can you share the cable and 90 degree mount that you used? I’m going to do the same with my X5000.
  • »13.01.24 - 02:21
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    matt3
    Posts: 671 from 2004/2/10
    Quote:

    amigasociety wrote:
    Lions & Tigers & Bears... Oh My!

    I mean...

    AmigaOne X5K & MorphOS & Dual Boot... Oh My!

    This is stage 1 of my efforts to make my AmigaOne X5K boot both the Amiga OS 4.1 and MorphOS 3.18.

    This is the 1st video about my plans, my system, some peaks inside, and 1st boot (from MorphOS Installer USB Stick) after installing a 2nd Video Card in my X5000.

    Long video but hope some find it fun!

    https://youtu.be/ZpwUkdsYGpU




    I would most likely reference the kids story with the rabbit hole and not the animals, as I bet in under a year you find room on your desk and buy a PowerMac 2.5 PCIe or 2.7 PCIX :)

    That is my prediction anyways!

    Don't forget to connect a second display to the other display port on the X1950, dual monitor is very good with MorphOS these days. Try out Iris, Pagestream, and PolyOrganizer as well, since you mentioned trying some productive tasks with it. They are a great app set. More than a few MorphOS users use it as their daily driver and can do work with it.

    Since you haven't used in 8 versions or so, a lot has gotten better. So check out the native apps, they work very well. You will need to upgrade both wayfarer and iris to the latest versions and they will begin to auto update afterwards.

    Nice video apu, always enjoy watching your content.
  • »13.01.24 - 15:33
    Profile
  • Caterpillar
    Caterpillar
    Posts: 25 from 2023/12/1
    Quote:

    esc wrote:
    Love it!

    Can you share the cable and 90 degree mount that you used? I’m going to do the same with my X5000.


    I purchased it on eBay. Unsure if links are allowed here but here it is.

    https://www.ebay.com/itm/374929149484?

    They sell all sorts of versions so look at the pictures and model #s so you order the right one and length for you.

    For me it was the R23SF-TL 25cm

    Double check the pictures to make sure the orientation of both sides works for you. I did a vertical mount of the video card so needed the x16 to point up and the screws be on the side.

    Hope this helps.

    TJ

    * the landing sot on the link above will not probably show the exact cable I purchased so study then all to see what one works best for you. The one it lands on for me is not the same as mine.

    [ Edited by amigasociety 13.01.2024 - 08:09 ]
  • »13.01.24 - 17:08
    Profile Visit Website
  • Caterpillar
    Caterpillar
    Posts: 25 from 2023/12/1
    I know all too well about Rabbit Holes. hahahaha

    For now I think I am good but did own a PM G5 2ghz model back in the day. Owned for 5 years until it pooped out. Sold it cheap. Should have tried to fix it.

    Cool about the dual monitor on MorphOS. Is it extended monitor like on a Mac OS system? That would be nice. My 2 displays are close enough I could probably try that. Just need a 2nd DVI to HDMI cable is all.

    btw, what video player is used these days? Still MPlayer on MorphOS?

    Last night I used SMB and connected my X5K via MorphOS to my NAS and grabbed (very slowly) a 300MB mp4 video to then play on my system. What app do you all use to play videos? Did not appear to know how to handle the mp4 I had.

    Thanks

    TJ

    *note, that 300mb fiel grabbed from my NAS took 7+ minutes to get copied over. It is an older NAS, slower ethernet port on it but on my linux system a 300mb file takes a fraction of that time if memory serves. Will have to test that more.


    Quote:

    matt3 wrote:
    Quote:

    amigasociety wrote:
    Lions & Tigers & Bears... Oh My!

    I mean...

    AmigaOne X5K & MorphOS & Dual Boot... Oh My!

    This is stage 1 of my efforts to make my AmigaOne X5K boot both the Amiga OS 4.1 and MorphOS 3.18.

    This is the 1st video about my plans, my system, some peaks inside, and 1st boot (from MorphOS Installer USB Stick) after installing a 2nd Video Card in my X5000.

    Long video but hope some find it fun!

    https://youtu.be/ZpwUkdsYGpU




    I would most likely reference the kids story with the rabbit hole and not the animals, as I bet in under a year you find room on your desk and buy a PowerMac 2.5 PCIe or 2.7 PCIX :)

    That is my prediction anyways!

    Don't forget to connect a second display to the other display port on the X1950, dual monitor is very good with MorphOS these days. Try out Iris, Pagestream, and PolyOrganizer as well, since you mentioned trying some productive tasks with it. They are a great app set. More than a few MorphOS users use it as their daily driver and can do work with it.

    Since you haven't used in 8 versions or so, a lot has gotten better. So check out the native apps, they work very well. You will need to upgrade both wayfarer and iris to the latest versions and they will begin to auto update afterwards.

    Nice video apu, always enjoy watching your content.




    [ Edited by amigasociety 13.01.2024 - 08:25 ]
  • »13.01.24 - 17:22
    Profile Visit Website
  • Moderator
    Kronos
    Posts: 2267 from 2003/2/24
    Dual monitor allows to have 2 separate screens on 2 monitor.

    Stretching one screen over 2 monitors would not work with how the screenbuffer is expected to be layed out in memory so one would need some sort of virtual monitor driver and a lower layer that constantly copies the data to the actual screenbuffers.

    Might be possible with some GPU compute but noone has shown any interest in putting in all the work for the rather limited benefit.
  • »13.01.24 - 17:48
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    matt3
    Posts: 671 from 2004/2/10
    My rabbit hole journey got me knee deep in PowerMac and PowerBook. They are real nice to switch to if you itch for more performance. Going for 2.5/2.7 Ghz with the Altivec and you will be at ludicrous speed. :)

    As Kronos mentioned it still treats them as 2 separate displays... However:
    1. The OS will automatically setup the 2nd display that is ready to go.
    2. Screen savers automatically work with both screens.
    3. Go to Ambient MUI and Windows and add the screen jump button. All MorphOS programs will instantly go to the opposite display if you press it. Works well.
    4. Using 2 monitors for productivity in MorphOS works rather well. I run PolyOrga/Turbocalc/Dopus on my 2nd display at 1080p. My main ambient screen is between 4k and 1080p for my old eyes. There is a native Dopus out there for MorphOS as well. Iris, Wayfarer, PolyOrga, Pagestream, as well as the OS have all had constant and major updates over years at this point and are a joy to use. Wayfarer being on the latest webkit is a huge/monumental task, version 7 is very good and keeps getting better, hard to believe 1.x was over 4 years ago now. For productivity, you are in a happy place. Hope you enjoy it as much as I have...

    You also can access containers/dockers on your NAS via wayfarer if you want to use libreoffice or something else...

    I use MPlayer for watching videos. MPlayer

    There is an old VLC floating around that works OK, but MPlayer is much better.

    No idea why your Network is slow? I did a quick copy of a file and MorphOS claimed it was 35mbs. I copied a 600mb file in under 20 seconds from my nas to the powermac. I easily stream 15 gig 1080p files and small 4k off my NAS with solid playback. You should experience decent results there. Sadly I don't have an X5000 to test with, but I'm sure others will be able to give input there. The same holds true for video, there are other faster cards that people have reported as working, but you will have to research that if you want to swap out the 1950Pro down the road.


    Quote:

    amigasociety wrote:
    I know all too well about Rabbit Holes. hahahaha

    For now I think I am good but did own a PM G5 2ghz model back in the day. Owned for 5 years until it pooped out. Sold it cheap. Should have tried to fix it.

    Cool about the dual monitor on MorphOS. Is it extended monitor like on a Mac OS system? That would be nice. My 2 displays are close enough I could probably try that. Just need a 2nd DVI to HDMI cable is all.

    btw, what video player is used these days? Still MPlayer on MorphOS?

    Last night I used SMB and connected my X5K via MorphOS to my NAS and grabbed (very slowly) a 300MB mp4 video to then play on my system. What app do you all use to play videos? Did not appear to know how to handle the mp4 I had.

    Thanks

    TJ

    *note, that 300mb fiel grabbed from my NAS took 7+ minutes to get copied over. It is an older NAS, slower ethernet port on it but on my linux system a 300mb file takes a fraction of that time if memory serves. Will have to test that more.


    Quote:

    matt3 wrote:
    Quote:

    amigasociety wrote:
    Lions & Tigers & Bears... Oh My!

    I mean...

    AmigaOne X5K & MorphOS & Dual Boot... Oh My!

    This is stage 1 of my efforts to make my AmigaOne X5K boot both the Amiga OS 4.1 and MorphOS 3.18.

    This is the 1st video about my plans, my system, some peaks inside, and 1st boot (from MorphOS Installer USB Stick) after installing a 2nd Video Card in my X5000.

    Long video but hope some find it fun!

    https://youtu.be/ZpwUkdsYGpU




    I would most likely reference the kids story with the rabbit hole and not the animals, as I bet in under a year you find room on your desk and buy a PowerMac 2.5 PCIe or 2.7 PCIX :)

    That is my prediction anyways!

    Don't forget to connect a second display to the other display port on the X1950, dual monitor is very good with MorphOS these days. Try out Iris, Pagestream, and PolyOrganizer as well, since you mentioned trying some productive tasks with it. They are a great app set. More than a few MorphOS users use it as their daily driver and can do work with it.

    Since you haven't used in 8 versions or so, a lot has gotten better. So check out the native apps, they work very well. You will need to upgrade both wayfarer and iris to the latest versions and they will begin to auto update afterwards.

    Nice video apu, always enjoy watching your content.







    [ Edited by matt3 13.01.2024 - 13:17 ]
  • »13.01.24 - 19:02
    Profile
  • Caterpillar
    Caterpillar
    Posts: 25 from 2023/12/1
    Quote:

    matt3 wrote:


    Thanks!

    Yeh, maybe someone else here using X5K can offer feedback on copying a 300mb file off a NAS and time. I have my NAS (older 2 day Zyxel) to my Router, and this X5K connects directly to the same router as well.

    For whatever reason, the copy took ages to come over.

    I will try mPlayer when I get a chance.

    I take it with my card 720p max? or less?

    TJ
  • »13.01.24 - 20:18
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    matt3
    Posts: 671 from 2004/2/10
    The cpu is going to drive playback way more than the video card.

    I'm playing small 4k files with a slightly slower video card than the one you just installed for MorphOS. On my other 2.7 system using the same card you just put in, it crushes 20 gig 1080p files across the NAS like butter. I'm sure it has to do with 2.7 GHz, the nature of MorphOS and maybe the Altivec helps out.

    I would fully expect MorphOS to play the same video files with the same level of performance as on OS4 with the better video card. Let me know.



    Quote:

    amigasociety wrote:
    Quote:

    matt3 wrote:


    Thanks!

    Yeh, maybe someone else here using X5K can offer feedback on copying a 300mb file off a NAS and time. I have my NAS (older 2 day Zyxel) to my Router, and this X5K connects directly to the same router as well.

    For whatever reason, the copy took ages to come over.

    I will try mPlayer when I get a chance.

    I take it with my card 720p max? or less?

    TJ


  • »13.01.24 - 22:49
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 12113 from 2003/5/22
    From: Germany
    > I would fully expect MorphOS to play the same video files with the
    > same level of performance as on OS4 with the better video card.

    Doubtful. With A-Eon's drivers, which every X5000 owner should have, OS4 can delegate the video decoding to the GPU via VA-API, causing virtually no load to the CPU. This was added about 3 years ago. Of course, the player software must support this as well, which are currently Emotion and DvPlayer.
  • »13.01.24 - 23:02
    Profile
  • Caterpillar
    Caterpillar
    Posts: 25 from 2023/12/1
    @Andreas_Wolf

    Yes, and moving from an older Radeon HD7750 that I used for the last 7 years to an RX580, updating to thew newer drivers via Enhancer, I went from only able to plat 480p, sometimes 720p, to 1080p to 4k range fine in Emotion.

    RX580 on the Amiga OS 4.1 via updated software is quite nice!

    Here is my recent video (before and after) that I made moving from the HD7750 to RX580.

    https://youtu.be/U3h_fSUTEl4

    TJ
  • »13.01.24 - 23:25
    Profile Visit Website
  • Caterpillar
    Caterpillar
    Posts: 25 from 2023/12/1
    The Finish (or is it really the Starting) Line of my AmigaOne X5000 Dual Boot Computer, booting Amiga OS 4.1 and MorphOS 3.18 for the (kind of) First Time.
    My guess this is really just the Starting Line for me as MorphOS looks quite nice!

    Adding a 2nd video rather than start a 2nd thread.

    Dual Boot now up and running from internal drives and I chat about the process.

    Hope you enjoy!

    https://youtu.be/xli0F-cIa6k

    tj

    [ Edited by amigasociety 13.01.2024 - 14:39 ]
  • »13.01.24 - 23:38
    Profile Visit Website
  • MorphOS Developer
    zukow
    Posts: 644 from 2005/2/9
    From: Poland
    Regarding NAS. I don't remember if MorphOS supports internal X5000 lan port but using Realtek 1GB Pcie card it copies ~20MB/s using SMB2 on PowerMac G5 PCIe, so it should be the same in X5000.
  • »14.01.24 - 00:22
    Profile Visit Website
  • Caterpillar
    Caterpillar
    Posts: 25 from 2023/12/1
    I am only connected via the X5Ks motherboard ethernet port so that is what mine is on.

    I do own a small pci ethernet card that I pulled the day the on-board port driver was in place but could switch to a nic if I had to.

    Just googled it, the X5K ethernet supposed to be 1x Gigabit Ethernet

    When I did my copy from Nas to my MOS hdd, I did it by dragging and dropping from NAS window to MOS hdd window I had opened.

    Are there different speeds that drag and drop produce via network copy? Maybe that is why mine was so slow?

    TJ

    Quote:

    zukow wrote:
    Regarding NAS. I don't remember if MorphOS supports internal X5000 lan port but using Realtek 1GB Pcie card it copies ~20MB/s using SMB2 on PowerMac G5 PCIe, so it should be the same in X5000.




    [ Edited by amigasociety 13.01.2024 - 15:29 ]
  • »14.01.24 - 00:26
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    matt3
    Posts: 671 from 2004/2/10
    Hey TJ,

    Great video you just posted!

    Yes, I just dragged my files off my NAS to a local drive and it gave the speeds I posted below.

    I am still interested in seeing, how well the X5000 plays video. I didn't realize they baked an API in the cake, I do wonder how close they will be?

    As far as Wayfarer, you are way off speeds right now that I'm seeing. I can't believe it's just the G5 at this point, so here is what I might suggest:
    1. Install the latest wayfarer and it will auto update whenever a new release comes out. Jacek really has all that stuff dialed in. I would bet version 7.2 is faster than the 6.x with a base 3.18 install.
    2. Change the in memory cache to 'balanced' under settings in wayfarer and also crank up the memory for it.
    3. Turn on Caching, especially since your using spinny disks. That is done under System with the super dude icon.
    4. Try different settings in wayfarer to spoof as other browsers.
    5. Jacek posted that using a proxy definitely improves performance. I haven't done this yet, however.
    6. You may even want to increase buffers on the partition, not sure if that will gain much though...

    Again, my setup is MUCH faster than what you are showing thus far. So you have speed to find at this point, keep looking. Youtube comes right up pretty much and I can click and play videos with no issues.

    This system is using an X1900 PCIe card with a single processor-dual core 2.5Ghz G5 and a video editing SSD.

    I use a daskeyboard with the roller wheel for volume and it works perfectly for me and accesses the Mac early bios, so perhaps that might work better for you. The keys are brown and feel nice. I also use a Lift vertical mouse with the wifi doggle plugged into the keyboard and it also works well. I use zvnc to switch keyboard to my PC that is also hooked up to both screens. You need to add another screen to add to the fun!

    As far as your network, you might want to try a pcie card as suggested, that is what I'm using in this box.

    Good luck, enjoy watching your journey.




    Quote:

    amigasociety wrote:
    I am only connected via the X5Ks motherboard ethernet port so that is what mine is on.

    I do own a small pci ethernet card that I pulled the day the on-board port driver was in place but could switch to a nic if I had to.

    Just googled it, the X5K ethernet supposed to be 1x Gigabit Ethernet

    When I did my copy from Nas to my MOS hdd, I did it by dragging and dropping from NAS window to MOS hdd window I had opened.

    Are there different speeds that drag and drop produce via network copy? Maybe that is why mine was so slow?

    TJ

    Quote:

    zukow wrote:
    Regarding NAS. I don't remember if MorphOS supports internal X5000 lan port but using Realtek 1GB Pcie card it copies ~20MB/s using SMB2 on PowerMac G5 PCIe, so it should be the same in X5000.







    [ Edited by matt3 13.01.2024 - 19:24 ]
  • »14.01.24 - 01:08
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 12113 from 2003/5/22
    From: Germany
    > I am still interested in seeing, how well the X5000 plays video.

    See his video he linked to in comment #11.
  • »14.01.24 - 20:45
    Profile
  • Caterpillar
    Caterpillar
    Posts: 25 from 2023/12/1
    Quote:

    Andreas_Wolf wrote:
    > I am still interested in seeing, how well the X5000 plays video.

    See his video he linked to in comment #11.


    yeh, the new drivers and new RX580 made a big difference for my video playback.

    TJ
  • »14.01.24 - 21:03
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    matt3
    Posts: 671 from 2004/2/10
    I was actually looking for a comparison between AOS4 and MorphOS.
  • »14.01.24 - 22:58
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 12113 from 2003/5/22
    From: Germany
    > I was actually looking for a comparison between AOS4 and MorphOS.

    Try to play a 4k video on your MorphOS machine and you'll see ;-)
  • »15.01.24 - 01:11
    Profile
  • Caterpillar
    Caterpillar
    Posts: 25 from 2023/12/1
    From what I am reading, the last version to work on X5K (or non Altivec systems) is 1.1 if I am reading that right.

    I will grab that one from Fab link you offered and see.

    Thanks

    TJ


    Quote:

    jPV wrote:
    Quote:

    matt3 wrote:
    I use MPlayer for watching videos. MPlayer



    The latest MPlayers require Altivec, which AmigaOne X5000 doesn't have. So better dig some old version.

    Check these:
    Link 1
    Link 2

    Fab's old ports are here.
  • »15.01.24 - 16:38
    Profile Visit Website
  • Butterfly
    Butterfly
    Posts: 84 from 2022/7/1
    Quote:

    amigasociety wrote:
    Lions & Tigers & Bears... Oh My!

    I mean...

    AmigaOne X5K & MorphOS & Dual Boot... Oh My!

    This is stage 1 of my efforts to make my AmigaOne X5K boot both the Amiga OS 4.1 and MorphOS 3.18.

    This is the 1st video about my plans, my system, some peaks inside, and 1st boot (from MorphOS Installer USB Stick) after installing a 2nd Video Card in my X5000.

    Long video but hope some find it fun!

    https://youtu.be/ZpwUkdsYGpU

    adding a 2nd video showing the final product of it all working.

    https://youtu.be/xli0F-cIa6k


    Hello amigasociety:

    Your post is interesting but I cannot see the youtube videos.

    How can I see it on Wayfarer 7.2?

    I have an AmigaOne X5000 too and with some problems

    Cheers
  • »23.01.24 - 16:54
    Profile
  • Caterpillar
    Caterpillar
    Skateman
    Posts: 22 from 2020/10/11
    You can try these settings in wayfarer on your X5000


    X5000_MOS_YT-scaled.jpg


    [ Edited by Skateman 23.01.2024 - 17:21 ]
  • »23.01.24 - 17:20
    Profile Visit Website
  • Caterpillar
    Caterpillar
    Posts: 25 from 2023/12/1
    Hopefully Skatman's settings help as I have not upgrades my Wayfarer yet or played any videos on my MorphOS setup. tj


    Quote:

    bearerofthetorch wrote:
    Quote:

    amigasociety wrote:
    Lions & Tigers & Bears... Oh My!

    I mean...

    AmigaOne X5K & MorphOS & Dual Boot... Oh My!

    This is stage 1 of my efforts to make my AmigaOne X5K boot both the Amiga OS 4.1 and MorphOS 3.18.

    This is the 1st video about my plans, my system, some peaks inside, and 1st boot (from MorphOS Installer USB Stick) after installing a 2nd Video Card in my X5000.

    Long video but hope some find it fun!

    https://youtu.be/ZpwUkdsYGpU

    adding a 2nd video showing the final product of it all working.

    https://youtu.be/xli0F-cIa6k


    Hello amigasociety:

    Your post is interesting but I cannot see the youtube videos.

    How can I see it on Wayfarer 7.2?

    I have an AmigaOne X5000 too and with some problems

    Cheers
  • »23.01.24 - 18:19
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Posts: 3030 from 2003/3/5
    From: Canada
    Quote:

    Skateman wrote:
    You can try these settings in wayfarer on your X5000



    These are not the right settings for Youtube. You are using wrong user-agent for the URL and have media source disabled.
  • »24.01.24 - 16:28
    Profile Visit Website