Problems to share a drawer on PC for MorphOS
  • MorphOS Developer
    jacadcaps
    Posts: 2943 from 2003/3/5
    From: Canada
    Quote:

    Papiosaur wrote:
    Hello,

    On MorphOS, i see the PC name in Networks icons and nothing inside after a share of a drawer on the PC (share for all).

    Any ideas please?


    Right click on the PC's entry in Networks and open Share Settings. Set the right login/password. It's also possible that you have configured your Windows machine to hide the shared folders. In that case you need to open the shares directly using View > Connect.

    [ Edited by jacadcaps 30.12.2023 - 20:24 ]
  • »30.12.23 - 19:23
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Papiosaur
    Posts: 2025 from 2003/4/10
    From: France
    Thanks jacadcaps for answer.

    Sorry, i didn't found these options on my Windows 10... You would like to say right click on the drawer to share?

    If i share with all, i don't need login and password, exact?

    Must i create an account in networkd/users prefs on MorphOS?

    Sorry, i 'm a newbie in network...
  • »31.12.23 - 07:02
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Posts: 2943 from 2003/3/5
    From: Canada
    I don't use Windows myself, but you can definitely set shares to be hidden.

    On MorphOS, you likely need to connect with correct login/password to the PC. Otherwise you might not be able to see all the shares. Even then, some shares may still be hidden and would need to be connected via full address.

    There's no need to create any accounts on MorphOS.
  • »01.01.24 - 02:32
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Papiosaur
    Posts: 2025 from 2003/4/10
    From: France
    Quote:

    jacadcaps a écrit :
    I don't use Windows myself, but you can definitely set shares to be hidden.

    On MorphOS, you likely need to connect with correct login/password to the PC. Otherwise you might not be able to see all the shares. Even then, some shares may still be hidden and would need to be connected via full address.

    There's no need to create any accounts on MorphOS.


    Thanks jaca, i have found Connexion option in contextual menu via Right click in Networks window under MorphOS

    Unfortunally, many try without succes...

    If somebody have a little tutorial, it will be fine.
  • »01.01.24 - 22:13
    Profile Visit Website
  • jPV
  • Yokemate of Keyboards
    Yokemate of Keyboards
    jPV
    Posts: 2015 from 2003/2/24
    From: po-RNO
    I don't know if it helps anymore, but you can see pretty much everything you can do in MorphOS side in this video. And if you're still suspecting something is wrong on the MorphOS side, you could try to delete related config files... I've done that couple times when testing, but can't remember the exact location now (and can't check currently).

    BTW. do you have disabled newer SMB protocol versions in your Windows setup? The share browsing works only with SMB 2 or 3, but if you have, for example, disabled these newer protocols to make the old SMBFS (1) to work on MorphOS previously, then you'll need to enable it back.

    [ Edited by jPV 02.01.2024 - 08:41 ]
  • »02.01.24 - 06:35
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Papiosaur
    Posts: 2025 from 2003/4/10
    From: France
    Thanks jPV for your video!

    Bizarely, when i open the computer in Networks, i don't have login/paswword requester... just nothing...

    On PC, SMB1.0 is desactivate but i don't know if SMB2 is activated and in Management of the computer, i don't have Users and groups option...
  • »02.01.24 - 12:03
    Profile Visit Website
  • jPV
  • Yokemate of Keyboards
    Yokemate of Keyboards
    jPV
    Posts: 2015 from 2003/2/24
    From: po-RNO
    Quote:

    Papiosaur wrote:
    Bizarely, when i open the computer in Networks, i don't have login/paswword requester... just nothing...


    It might have saved a wrong login/password when you have had a failed try. Open Networks and right click the computer (don't double click), and select "Share Settings..." to have another try with other options.
  • »03.01.24 - 09:48
    Profile Visit Website