YAM needs MUI? What MUI should be used with MorphOS?
  • Just looking around
    jaesonk
    Posts: 12 from 2005/12/2
    Trying to revive my OLD YAM and it wants MUI. Can I download and install MUI 3.8 from Aminet? Or should I be using some other version with MorphOS?

    Thanks,
    Jaeson
  • »14.03.21 - 06:08
    Profile
  • Paladin of the Pegasos
    Paladin of the Pegasos
    NewSense
    Posts: 1041 from 2012/11/10
    From: Manchester, UK/GB
    I used to be a fan of YAM when I used OS3.9, but once I swapped to MorphOS I used Simplemail as it's a lot more functional/easier to use, but then there's Iris emailer v0.114 now that's still in development, but has IMAP and is progressing very nicely through beta stages.
    MacMini 1.5GHz,10,2,64MB VRAM,1GB,Airport, Bluetooth,A1016 Keyboard,T-RB22 Mouse,DVD-RW-DL+CD-RW,Iomega MiniMax,Belkin 6 port 3 x Firewire/3 x, USB2, MorphOS 3.12, Mac OSX 10.4/10.5, A1138+A1139 PwrBk MOS v3.12,Model 5,8/5,9, & PowerMac G5 2.3GHz(DP)
  • »14.03.21 - 07:27
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11294 from 2003/5/22
    From: Germany
    > Trying to revive my OLD YAM

    I recommend using a MorphOS-native Nightly Build of YAM v2.10-dev:

    http://nightly.yam.ch/latest-dev/
    https://github.com/jens-maus/yam/releases/tag/nightly-builds

    > and it wants MUI. Can I download and install MUI 3.8 from Aminet?
    > Or should I be using some other version with MorphOS?

    MorphOS already comes with MUI (v5). In fact, MorphOS is very much based on its integrated MUI, so do not install another version.
  • »14.03.21 - 08:35
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Amigaharry2
    Posts: 836 from 2010/1/6
    From: EU-Austria (Wien)
    Nightly-build (2.10-dev) works flawless on MOS. MUI is essential part of MOS-GUI. Do not install older MUI-system - it can/will crash your system!
    Maybe some classes have to be updateted (Bettersting, NListtree, ......).YAM may urgent for them, if needed.
    Peg2, 3xPowerMac G5, 2xPowerbookG4, 2x MacMiniG4, Efika (again), A3000T and life is never boring.....
  • »14.03.21 - 09:23
    Profile
  • Just looking around
    jaesonk
    Posts: 12 from 2005/12/2
    Thanks. I will check on the newer YAM.

    My reason for trying to get YAM going is that I'd like to see what vintage emails I might have saved.

    When I launch the older version of YAM it says:
    Couldn't open MUI custom class 'Toolbar.mcc' V15.8. This class is not installed.


    If I install the newer YAM, will I need the above class and will I still be able to access the old emails?

    Thanks.
    Jaeson
  • »14.03.21 - 19:46
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Amigaharry2
    Posts: 836 from 2010/1/6
    From: EU-Austria (Wien)
    And why don't you install this custom-class?

    https://github.com/amiga-mui/toolbar/releases


    If you goto Systems MUI-Prefs you see all installed classes (click on button "More" first).
    Peg2, 3xPowerMac G5, 2xPowerbookG4, 2x MacMiniG4, Efika (again), A3000T and life is never boring.....
  • »14.03.21 - 20:01
    Profile
  • Just looking around
    jaesonk
    Posts: 12 from 2005/12/2
    Thank you.

    Jaeson
  • »14.03.21 - 21:37
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11294 from 2003/5/22
    From: Germany
    > If I install the newer YAM, [...] will I still be able to access the old emails?

    I don't remember when it was, but there was a change of the format the mail files are saved in. If your old YAM is from before this change, then recent YAM will (automatically?) convert your mails to the new format. This process is irreversible and old YAM cannot read the new format, so you may want to play save and operate on a copy of your mail files/dirs.
  • »15.03.21 - 01:15
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11294 from 2003/5/22
    From: Germany
    > Download http://aminet.net/package/dev/mui/MCC_TheBar-26.21
    > or https://www.morphos-storage.net/?id=1600933 package,
    > it contains the latest Toolbar.mcc too.
    > You probably need the above class(es) with any versions of YAM.

    v26.21 of the archive contains latest Toolbar.mcc which is just a wrapper to TheBar.mcc. So indeed, if he installs this archive then old programs expecting Toolbar.mcc as well as newer programs directly using TheBar.mcc should work. Newer versions of YAM work without having Toolbar.mcc installed (no matter if wrapper or 'real' version). Older versions of YAM don't know TheBar.mcc, so the 'real' version of Toolbar.mcc (v15.12) works, but instead installing both the new wrapping version of Toolbar.mcc and TheBar.mcc should work as well of course.
    Overall, installing all classes of the v26.21 archive is probably the easiest way as then only one archive is needed and both old and new programs should work :-)
  • »15.03.21 - 01:49
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11294 from 2003/5/22
    From: Germany
    >> https://github.com/amiga-mui/toolbar/releases

    > Unfortunately these separate releases are obsolete

    They are as obsolete as ancient YAM versions, so wouldn't be too bad a fit for those ;-)
  • »15.03.21 - 02:00
    Profile