MPlayer Problem
  • Caterpillar
    Caterpillar
    Posts: 26 from 2019/10/6
    I've set up in Ambient Mime/video settings for MPlayer to open a video file when it's double clicked and also a second menu option to open the video with Mplayer but with loop filter and framedrop parameters added (for 720P content.)
    For some reason, the double clicking/right clicking only works for some videos - others need to be opened from within the MPlayer app. These are all h264 .mp4 files, all with similar bitrates and all processed through Handbrake on OSX (including the ones that do work) - any ideas?
  • »11.10.19 - 21:17
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    KennyR
    Posts: 673 from 2003/3/4
    From: #AmigaZeux, Gu...
    Is there a space in the filename of the videos that won't work with double click, or do they contain non-alphanumeric characters (like '['), or are they particularly long?
  • »12.10.19 - 08:44
    Profile
  • Caterpillar
    Caterpillar
    Posts: 26 from 2019/10/6
    Quote:

    KennyR wrote:
    Is there a space in the filename of the videos that won't work with double click, or do they contain non-alphanumeric characters (like '['), or are they particularly long?


    Yes!! That's it - thank you so much, I'd have never thought of that - so used to that sort of thing being a part of the past. Until recently I still replaced a space with an underscore in filenames but stopped because there was no need....
    Thanks again!!

    [ Edited by Dronecatcher 12.10.2019 - 10:07 ]
  • »12.10.19 - 10:04
    Profile
  • jPV
  • Paladin of the Pegasos
    Paladin of the Pegasos
    jPV
    Posts: 1561 from 2003/2/24
    From: po-RNO
    Quote:

    Dronecatcher wrote:
    Quote:

    KennyR wrote:
    Is there a space in the filename of the videos that won't work with double click, or do they contain non-alphanumeric characters (like '['), or are they particularly long?


    Yes!! That's it - thank you so much, I'd have never thought of that - so used to that sort of thing being a part of the past. Until recently I still replaced a space with an underscore in filenames but stopped because there was no need....
    Thanks again!!

    It should work just fine with spaces in names if you have otherwise correct configuration. Do you happen to have "Don't quote arguments" option selected in your Ambient mimetypes for mplayer? It would break names with spaces at least...
  • »13.10.19 - 14:22
    Profile Visit Website
  • Caterpillar
    Caterpillar
    Posts: 26 from 2019/10/6
    Quote:


    It should work just fine with spaces in names if you have otherwise correct configuration. Do you happen to have "Don't quote arguments" option selected in your Ambient mimetypes for mplayer? It would break names with spaces at least...


    Yes, you are correct I did have that option selected - works great now :) Many thanks.
  • »13.10.19 - 16:02
    Profile