Powerbook dead?
  • Butterfly
    Butterfly
    emeck
    Posts: 91 from 2014/7/15
    Hello,

    This morning my PB 5,8 did not turn on. It has happened to me before some times but after letting it charge for like half an hour, it then started normally. But not this time. Tried with another battery but no luck. Both batteries, an original Apple and a replacement one, where failing. MOS was unable to tell the charge remaining, but it could still be usable for an hour or so.

    Tried just with the power adapter alone (no battery) but it doesn`t work either. I guess the batteries may be dead now and don`t let the PB turn on... or could it be my PB is dead?

    I have a working PB 5,2 with a failing battery also. Would it be ok to use its battery with the 5,8 or could that damage the battery more, or worse, the PB 5,8 if it still is recoverable?
    PowerBook 5.2 MorphOS 3.11
    PowerBook 5.8 MorphOS 3.11
    Amiga 1200 BPPC/BVision AOS4.1 FE
  • »28.02.19 - 15:10
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    koszer
    Posts: 908 from 2004/2/8
    From: Poland
    I'd check if the internal PRAM battery is OK.
  • »28.02.19 - 15:15
    Profile
  • jPV
  • Paladin of the Pegasos
    Paladin of the Pegasos
    jPV
    Posts: 1517 from 2003/2/24
    From: po-RNO
    I once got sudden problems on turning on my PB 5,9, and although I don't remember details that well anymore, I think it also didn't start with or without battery anymore (these computers should run without battery just fine too).

    Resetting PMU (Power Management Unit) did help in my case and the issue never came back after that, it's been running fine for years now after the incident with the same battery.

    So I'd advice to google how to reset the PMU on your particular model and try that, it was an easy operation.


    [ Edited by jPV 28.02.2019 - 16:33 ]
  • »28.02.19 - 15:32
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    Korni
    Posts: 429 from 2006/2/23
    From: the Planet of ...
    If PB runs from a charged battery, but does not charge it - It might be a broken power module. I assume that you have a 65W Apple PSU, 45W ones or non Apple ones can be problematic esp. w/o the battery. If your PB5,2 boots with its battery, then PB5,8 should boot with it as well.
    http://korni.ppa.pl/modkowypaczek/ | My Rifle, My Bunny, and Me
  • »28.02.19 - 18:08
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    KennyR
    Posts: 656 from 2003/3/4
    From: #AmigaZeux, Gu...
    Unfortunately, it's probably dead. The power input circuitry of laptops is what kills most of them, whether Apple or otherwise. I have an old laptop which to all appearances looks totally dead, but will on very rare occasions switch on for no apparent reason... only to not turn on again if shut down. I can't even imagine what's gone wrong electronically there.

    It tends to happen when the batteries are old and failing, so it may be something to do with damage trying to charge dead batteries. I always advise removing failing batteries ASAP.
  • »28.02.19 - 19:42
    Profile
  • Butterfly
    Butterfly
    emeck
    Posts: 91 from 2014/7/15
    @koszer
    If the internal PRAM battery is not OK, then date and time will reset after every turn off?

    @jPV
    Not luck with the reset. That worked with my PB 5,2 some time ago, but not now with the 5,8.

    @Korni
    Yes, I have an Apple 65W PSU. I`ll try swapping batteries.
    PowerBook 5.2 MorphOS 3.11
    PowerBook 5.8 MorphOS 3.11
    Amiga 1200 BPPC/BVision AOS4.1 FE
  • »28.02.19 - 19:58
    Profile
  • Butterfly
    Butterfly
    emeck
    Posts: 91 from 2014/7/15
    Quote:

    jPV wrote:
    I once got sudden problems on turning on my PB 5,9, and although I don't remember details that well anymore, I think it also didn't start with or without battery anymore (these computers should run without battery just fine too)...



    My PB 5,2 turns on without battery but my 5,8 doesn`t.

    Also, I`ve noticed that the light is always orange. Should be green for a couple of seconds while detecting the charge and then orange if not fully charged. Also, with no battery, it is always orange.
    PowerBook 5.2 MorphOS 3.11
    PowerBook 5.8 MorphOS 3.11
    Amiga 1200 BPPC/BVision AOS4.1 FE
  • »28.02.19 - 20:11
    Profile
  • Butterfly
    Butterfly
    emeck
    Posts: 91 from 2014/7/15
    Quote:

    KennyR wrote:
    ...It tends to happen when the batteries are old and failing, so it may be something to do with damage trying to charge dead batteries. I always advise removing failing batteries ASAP.


    I was planning on buying a replacement battery but now... I should buyi another Powerbook.
    PowerBook 5.2 MorphOS 3.11
    PowerBook 5.8 MorphOS 3.11
    Amiga 1200 BPPC/BVision AOS4.1 FE
  • »28.02.19 - 20:13
    Profile
  • Butterfly
    Butterfly
    emeck
    Posts: 91 from 2014/7/15
    Quote:

    emeck wrote:
    Quote:

    KennyR wrote:
    ...It tends to happen when the batteries are old and failing, so it may be something to do with damage trying to charge dead batteries. I always advise removing failing batteries ASAP.


    I was planning on buying a replacement battery but now... I should buyi another Powerbook.


    Update: charging the battery in the PB5,2 and then using it in the PB 5,8 works! So something is wrong with the later.
    PowerBook 5.2 MorphOS 3.11
    PowerBook 5.8 MorphOS 3.11
    Amiga 1200 BPPC/BVision AOS4.1 FE
  • »28.02.19 - 20:39
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    KennyR
    Posts: 656 from 2003/3/4
    From: #AmigaZeux, Gu...
    Quote:

    emeck wrote:
    Quote:

    emeck wrote:
    Quote:

    KennyR wrote:
    ...It tends to happen when the batteries are old and failing, so it may be something to do with damage trying to charge dead batteries. I always advise removing failing batteries ASAP.


    I was planning on buying a replacement battery but now... I should buyi another Powerbook.


    Update: charging the battery in the PB5,2 and then using it in the PB 5,8 works! So something is wrong with the later.


    So it only runs off battery but can't run off mains or charge batteries any more?
  • »01.03.19 - 19:19
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Korni
    Posts: 429 from 2006/2/23
    From: the Planet of ...
    Quote:

    emeck wrote:
    So something is wrong with the later.


    It's a power module board, relatively easy to replace.
    http://korni.ppa.pl/modkowypaczek/ | My Rifle, My Bunny, and Me
  • »01.03.19 - 20:15
    Profile Visit Website
  • Butterfly
    Butterfly
    emeck
    Posts: 91 from 2014/7/15
    Quote:

    KennyR wrote:
    So it only runs off battery but can't run off mains or charge batteries any more?

    Yes, that is the case.
    PowerBook 5.2 MorphOS 3.11
    PowerBook 5.8 MorphOS 3.11
    Amiga 1200 BPPC/BVision AOS4.1 FE
  • »01.03.19 - 20:32
    Profile
  • Butterfly
    Butterfly
    emeck
    Posts: 91 from 2014/7/15
    Quote:

    Korni wrote:
    It's a power module board, relatively easy to replace.


    Is that a DC-in and Soundcard board? It is mentioned in some searches I made looking about my problem. I'll see if I can get the part and maybe a PRAM battery while I'm on it.
    PowerBook 5.2 MorphOS 3.11
    PowerBook 5.8 MorphOS 3.11
    Amiga 1200 BPPC/BVision AOS4.1 FE
  • »01.03.19 - 20:44
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Korni
    Posts: 429 from 2006/2/23
    From: the Planet of ...
    Quote:

    emeck wrote:
    Quote:

    Korni wrote:
    It's a power module board, relatively easy to replace.


    Is that a DC-in and Soundcard board? It is mentioned in some searches I made looking about my problem. I'll see if I can get the part and maybe a PRAM battery while I'm on it.


    Yes.
    http://korni.ppa.pl/modkowypaczek/ | My Rifle, My Bunny, and Me
  • »01.03.19 - 21:21
    Profile Visit Website
  • Butterfly
    Butterfly
    emeck
    Posts: 91 from 2014/7/15
    Quote:

    Korni wrote:
    It's a power module board, relatively easy to replace.


    Replaced! PB5,8 now boots with the power supply and also charges the replacement battery I bought.

    Thank you all for the help.
    PowerBook 5.2 MorphOS 3.11
    PowerBook 5.8 MorphOS 3.11
    Amiga 1200 BPPC/BVision AOS4.1 FE
  • »30.07.19 - 15:12
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    NewSense
    Posts: 787 from 2012/11/10
    From: Manchester, UK/GB
    So, did you replace the DC-In-Board and fix your faulty machine or just buy a new/replacement A1138 (PwrBk 5,8)?
    MacMini 1.5GHz,10,2,64MB VRAM,1GB RAM,Airport, Bluetooth,A1016 Keyboard,T-RB22 Mouse,DVD-RW-DL+CD-RW,Iomega MiniMax,Belkin 6 port 3 x Firewire/3 x USB2,MorphOS 3.11,Mac OSX 10.4/10.5,A1138+A1139 PwrBk MOS v3.11,Model 5,8/5,9, & PowerMac G5 2.3GHz (DP)
  • »31.07.19 - 00:36
    Profile
  • Butterfly
    Butterfly
    emeck
    Posts: 91 from 2014/7/15
    Quote:

    NewSense wrote:
    So, did you replace the DC-In-Board and fix your faulty machine or just buy a new/replacement A1138 (PwrBk 5,8)?


    Replaced the DC-In. And the pcmcia bay which had the eject button broken, and the HDD with a bigger one, and the cmos battery. All parts from another working PB5,8 I found very cheap (46€ including shipping). Instead of transfering the MOS license, I opted for using it as spare parts, because it was externally very damaged compare to mine. And the screen has "spots" in it. So I still have some more spare parts :)
    PowerBook 5.2 MorphOS 3.11
    PowerBook 5.8 MorphOS 3.11
    Amiga 1200 BPPC/BVision AOS4.1 FE
  • »31.07.19 - 07:09
    Profile