MilkyTracker new release
  • Caterpillar
    Caterpillar
    Kokos
    Posts: 26 from 2009/10/27
    From: Poland
    Hi guys,

    Recently v1.01 was released and I'm wondering whether it's possible to release new port of this? Last port I'm aware is for release v90.80. Lots of bugs fixed, lot's of new cool features were implemented since 2008.

    I know MilkyTracker is now SDL2-based and SDL2 is not fully ported yet (not sure whether it's an issue for MilkyTracker port), but maybe someone could hear this voice and would consider implementation. Or at least I could get know what are the challenges related to this.

    Thanks!
    Kokos
  • »01.09.17 - 08:41
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    polluks
    Posts: 330 from 2007/10/23
    From: Gelsenkirchen,...
    Now it also uses CMake...
    Pegasos II G4: MorphOS 3.9, Zalman M220W
    Power Mac G3: OSX 10.3 · PowerBook 5,8: OSX 10.5, MorphOS 3.9
  • »01.09.17 - 23:22
    Profile
  • Caterpillar
    Caterpillar
    Kokos
    Posts: 26 from 2009/10/27
    From: Poland
    I know CMake was released for OS4. Would publishing its source code help building a port for MorphOS?
  • »02.09.17 - 03:23
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    polluks
    Posts: 330 from 2007/10/23
    From: Gelsenkirchen,...
    Well, someone told me the MorphOS Team already made a CMake port.
    So I was compiling MT by hand but four files didn't work...

    [ Editiert durch polluks 02.09.2017 - 16:18 ]
    Pegasos II G4: MorphOS 3.9, Zalman M220W
    Power Mac G3: OSX 10.3 · PowerBook 5,8: OSX 10.5, MorphOS 3.9
  • »02.09.17 - 13:38
    Profile
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    Posts: 138 from 2004/11/18
    Ohh Yeess it could be a great fisrt app using SDL2 port for morphos.
  • »10.09.17 - 19:29
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    polluks
    Posts: 330 from 2007/10/23
    From: Gelsenkirchen,...
    @acepeg
    Already done in 2015.
    Aminet

    [ Editiert durch polluks 13.09.2017 - 10:50 ]
    Pegasos II G4: MorphOS 3.9, Zalman M220W
    Power Mac G3: OSX 10.3 · PowerBook 5,8: OSX 10.5, MorphOS 3.9
  • »13.09.17 - 08:49
    Profile
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    Posts: 138 from 2004/11/18
    Awsome so someone can try to comile Milky for Morphos.
  • »13.09.17 - 19:37
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    polluks
    Posts: 330 from 2007/10/23
    From: Gelsenkirchen,...
    Well, I compiled the last version, it was much work without CMake.
    But nothing happens, no screen is opening. Sorry, SDL2 is still beta.
    Pegasos II G4: MorphOS 3.9, Zalman M220W
    Power Mac G3: OSX 10.3 · PowerBook 5,8: OSX 10.5, MorphOS 3.9
  • »19.09.17 - 17:44
    Profile
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    Posts: 138 from 2004/11/18
    Thank you for the job, maybe in the future it will easier with a more advanced port of sdl2
  • »20.09.17 - 21:06
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Stevo
    Posts: 793 from 2004/1/24
    From: #AmigaZeux
    Over at EAB, Marlon_ made a MorphOS test build available of his MilkyTracker V1.01 port for Vampire and 060.

    He's asking for feedback, so do try and let him know :-)
    ---
    http://www.iki.fi/sintonen/logs/its_only_football.txt
  • »29.12.17 - 12:31
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    NewSense
    Posts: 544 from 2012/11/10
    From: Manchester, Gr...
    I ran it (MorphOS Test Build - Milky Tracker v1.01), but when I stopped the .mod as it was playing, well tried to using the STOP button, nothing happened, so I clicked the Play button and the .mod just went all 'weird-sounding' - "wailed like an old cat" !!! then the program hung for a moment, then it exited.

    Second time I ran it I loaded the same sample, and then clicked on the About button, which after a few moments of nothing happening then loaded, but on clicking on the logo it didn't exit, and so none of the main buttons were visible, and the instrument buttons were inactive, so I pressed 'Esc' and the .mod went all weird sounding again, and soon after that the requester to exit/quit popped onto the screen, so I clicked on it which worked and exited the program, but I don't think it exited cleanly.

    I'll take a look at the log tool later and see if there's anything in it that be of use to Marlon @ EAB - and then pass him feedback.
    Mac Mini 1.5GHz, Model 10.2, 64MB VRam, 250GB HDD, 1GB RAM, Airport, Bluetooth, Wireless Keyboard & Mouse, DVD-RW-DL+CD-RW, Iomega MiniMax, Belkin 6 port 3 x Firewire/3 x USB2, MorphOS 3.9, Mac OS X 10.4 & 10.5 & A1138 Powerbook MOS v3.9, Model 5,8 (Also
  • »29.12.17 - 21:27
    Profile