Morphos 3.5 installation on PowerMac G5(Powermac 7,2)
  • Just looking around
    dkaram
    Posts: 8 from 2010/1/26
    From: ATHENS/GREECE
    Hello everyone,

    I received an ati 9600 from a member here(Jim) a few days ago and installed in on a powermac 7,2(G5) successfully.

    I am haveing issues with my ide dvd drive as it seems so I Tried to perform an installation from usb.

    I formatted the usb with fat 32 , copied the boot.img from the ppc64 directory and the morphos iso and after I entered the open firmware typed in

    boot usb2/disk@2:,\boot.img bi=umsd0:morphos.iso vouala Morphos screen popped up.

    Two remarks here

    a)The = was needed after the bi otherwise it did not boot
    b)After typing in the command only Loading ELF and DO-QUIESCE finished prompted in the powermac, nothing was shown for the cpu's as listed in the instruction.

    Anyway, I selected the regional settings etc but in the hdconfig there was no listing for my internal sata disk.Does it need anything special to show the internal sata of the powermac g5 or is it a problem of my g5 machine?

    I was disapointed so I tried installing on to another usb drive.Installation finished successfully on a 8gb usb stick but can someone help on the command I should try on open firmware so the powermac can boot morphos(operating system) from the usb stick?

    [ Edited by dkaram 15.06.2014 - 09:53 ]
  • »15.06.14 - 09:52
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    roschmyr
    Posts: 201 from 2003/2/20
    From: Oberhausen/Ger...
    Quote:

    dkaram schrieb:

    Anyway, I selected the regional settings etc but in the hdconfig there was no listing for my internal sata disk.Does it need anything special to show the internal sata of the powermac g5 or is it a problem of my g5 machine?

    [ Edited by dkaram 15.06.2014 - 09:53 ]


    does the SATA hd a jumper 1,5Gb/s, i had the same problem with a newer SataII hd
    and solved the problem with this jumper.
  • »15.06.14 - 11:34
    Profile
  • Just looking around
    dkaram
    Posts: 8 from 2010/1/26
    From: ATHENS/GREECE
    Yup , that was probably it roschmyr , thanks for the answer.

    I should mention though that booting from usb using open firmware still did not recognize the internal sata, booting from the morphos iso cd did the job :)
  • »16.06.14 - 06:46
    Profile
  • Visitor
  • Normaly yes! But I'm not sure whether your PB model is supported......
  • »20.02.15 - 05:22