SDL2 sources, progress and ports
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    eliot
    Posts: 560 from 2004/4/15
    Hi,

    I reworked the code a little bit and now I got the gol stuff working on MorphOs too (not using the VBO stuff
    anymore).
    But now I am facon the next problem: all images which are using alpha channel (like the character) are
    not visible anymore. On Linux, Windows, AOS4 everything is fine.
    Sadly I did not had the time to have a deeper look into it.
    Here is a screenshot of the problem:
    ermentrud_ogl_alplha_error.pnghttps://exdev.selfhost.eu/mos/ermentrud_ogl_alplha_error.png
    regards
    eliot
  • »10.09.21 - 07:07
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    beworld
    Posts: 538 from 2010/2/10
    From: FRANCE
    hi,

    You use alpha with OpenGL renderer... no chance... it's a big bug of SDL2 now....

    in SDL2 readme :

    KNOW BUGS:
    *************

    - SDL_CreateRenderer with SDL_RENDERER_ACCELERATED is broken if you use SDL_BLENDMODE or
    tranparency color with OpenGL renderer, you need to use SDL_RENDERER_SOFTWARE.
    Dont ask me to fix that, i dont have any information on it, maybe fix on next release of MorphOS (3.16)..)
    IMac G5 2.1,PowerMac 2.7,PowerBook 1.5
    My MOS ports
  • »10.09.21 - 09:12
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    eliot
    Posts: 560 from 2004/4/15
    Yes, this should not be a bug in SDL2, because it's working fine on other platforms.

    EDIT: So no OGL support on mos for now, but neverstheless, it's mostly done:
    ermentrud_mos.png

    [ Edited by eliot 10.09.2021 - 13:04 ]
    regards
    eliot
  • »10.09.21 - 10:08
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    beworld
    Posts: 538 from 2010/2/10
    From: FRANCE
    New SDL2 packages : 2.0.20

    New SDL2, SDL2_image, SDL2_ttf libraries
    Check changelogs into archive

    https://www.morphos-storage.net/?id=1715242



    [ Edité par beworld 16.02.2022 - 08:28 ]
    IMac G5 2.1,PowerMac 2.7,PowerBook 1.5
    My MOS ports
  • »15.01.22 - 10:36
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    beworld
    Posts: 538 from 2010/2/10
    From: FRANCE
    New SDL packages 2.0.20 available with some fix

    Dont hesites to update it !

    https://www.morphos-storage.net/?find=SDL_2

    I update some of my ports and work on new port (Thanks to MorphOS 3.16)... so wait and survey MorphOS-storage

    Have fun !
    And thanks top MorphOS team.
    IMac G5 2.1,PowerMac 2.7,PowerBook 1.5
    My MOS ports
  • »12.03.22 - 19:37
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    beworld
    Posts: 538 from 2010/2/10
    From: FRANCE
    I'm glad to see that the SDL2 is now used more than by myself :-) (Doom3/SM64, deviluationx... to name the biggest ones)

    Now in next release of SDL2, I implemented some missing features:

    - SDL_WINDOW_FULLSCREEN_DESKTOP
    - SDL_RENDERER_PRESENTVSYNC (note: vsync is always present in real fullscreen mode)

    just one exemple with SDL_WINDOW_FULLSCREEN_DESKTOP and opacity window (to test i just edit my bePlayer): https://ibb.co/7CL1S3W
    IMac G5 2.1,PowerMac 2.7,PowerBook 1.5
    My MOS ports
  • »23.04.22 - 05:38
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    beworld
    Posts: 538 from 2010/2/10
    From: FRANCE
    New update with some fixes in SDL 2.0.22

    https://www.morphos-storage.net/?id=1746996
    IMac G5 2.1,PowerMac 2.7,PowerBook 1.5
    My MOS ports
  • »08.05.22 - 18:02
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    beworld
    Posts: 538 from 2010/2/10
    From: FRANCE
    New update with some fixes in SDL 2.0.22

    https://www.morphos-storage.net/?id=1746996
    IMac G5 2.1,PowerMac 2.7,PowerBook 1.5
    My MOS ports
  • »08.05.22 - 18:02
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    Zetec-s
    Posts: 188 from 2008/7/10
    From: Cheshire, UK
    Quote:

    Quote:

    Quote:

    [ Edité par beworld 01.04.2020 - 09:58 ]


    Thanks for your hardwork to get SDL2 done. Also thank you for your awsome game ports.
    I just tested full version of HODE, and looks and plays awesome, but before I finish first level (when first animation starts, where you see whole world below), game exit with message.. fileio.cpp:90: failed assertion `crc == 0' , Program aborted, Using joystick 'Port 0 is a Game Controller'.

    I have all files in DATA dir. (hod.paf, all .lvl,.mst,.sss files).



    Now I added setup.dat in DATA and pressed esc during animation and new level starts.... :)
    (wierd is that I first added only hod.paf from CD and start to play game just fine, and after game crashed I added all lvl,mst and sss files from RIP version but that didn't solve crash, but now with added setup.dat I can continue to play)
    Anyway, good is that I can continue to play because HODE is really good game. :)

    ...and thanks for your fast answer. (you answered just before I post this)


    Sorry for dragging up an old post, but I am having the exact same issue with HODE now as the above.

    When I get to Level 1 Screen 8, the animations play but then the game exits back to the menu and you are stuck in a loop.

    Anybody have any ideas of how to solve this?
    PowerMac G5 Quad 2.5Ghz/2GB MorphOS 3.17 Registered
    Powerbook 1.67Ghz/1.5GB MorphOS 3.17 Registered
    MacMini 1.5Ghz/1GB MorphOS 3.17 Registered
    Efika 5200B 400Mhz/128MB MorphOS 2.3 Registered
  • »17.07.22 - 09:09
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    beworld
    Posts: 538 from 2010/2/10
    From: FRANCE
    Hi, i update Hode (last sources from master)

    https://www.morphos-storage.net/?id=1777902

    Try it, maybe fix your problem.
    IMac G5 2.1,PowerMac 2.7,PowerBook 1.5
    My MOS ports
  • »17.07.22 - 13:38
    Profile Visit Website