X5000/20: Sound- und Grafikprobleme
  • Just looking around
    xeno74
    Posts: 9 from 2020/6/8
    Hi,

    ich habe auf der Amiga34 versprochen, MorphOS auf dem X5000 zu testen und auf der nächsten Neuss-Show am A-EON-Stand zu präsentieren. Hier erstmal ein paar technische Daten von dem X5000.

    - X5000 mit einem FSL P5020 SoC (2x e5500)
    - 8 GB RAM
    - ATi Radeon X1650 SE mit 512 MB RAM (256 MB RAM werden erkannt)
    - SoundBlaster Play! 2 USB-Soundkarte
    - C-Media CMI8738 PCI-Soundkarte
    - 1 TB Festplatte

    Laut der MorphOS Hardware-Compatibility-Seite entspricht die o.g. X5000-Konfiguration einem gut unterstützen MorphOS-Rechner. Das heißt, Hardware 3D-Beschleunigung, Netzwerk und Sound werden unterstützt.

    Die Installation war wirklich einfach. MorphOS-Img runterladen und mit dd unter Linux auf einem USB-Stick kopieren. Danach den X5000 mit dem USB-Stick starten und nach einem USB-Reset unter U-Boot wurde MorphOS vom USB-Stick gestartet. Dann die Partitionierung und Installation. Nach einem Reboot startete MorphOS problemlos von der Festplatte. Schön ist, dass MorphOS automatisch bootet, wenn ich den X5000 einschalte. Fantastisch.

    Grundsätzlich finde ich MorphOS sehr interessant und möchte unbedingt mehr damit machen. Später soll dieser X5000 am A-EON-Stand in Neuss gezeigt werden. Die Onboard-Netzwerkhardware (p50x0eth.device:0) funktionierte auf Anhieb.

    Leider habe ich 2 Probleme, die das Präsentieren am Stand schon fast unmöglich machen.

    Punkt 1 ist die Grafikkarte. Die ATi Radeon X1650 SE funktioniert grundsätzlich. Ich habe Transparenz in den Fenstern und kann ein paar 3D-Spiele wie zum Beispiel Speed Dreams und Mutli Racer ausführen. Leider tauchen in den 3D-Spielen hier und da Artefakte auf. Ich weiß, dass das MorphOS-Team diese Grafikkarte auch in ihrem X5000 am MorphOS-Stand in Betrieb hatte.

    Punkt 2 sind die Soundkarten. Ich habe bei beiden Soundkarten extrem kratzende Geräusche. Manchmal habe ich das Gefühl, dass der Datenstrom unregelmäßig ist. Manchmal ist der Sound klar und nach 3 Minuten versteht man durch Rauschen und Kratzen nichts mehr. Ich habe schon unheimlich viel ausprobiert (Musikeinheit, Einheit 0). Ich habe auch das Prinzip der Soundkarten-Einstellung in MorphOS verstanden aber ich bekomme es einfach nicht hin. Unter Linux funktioniert z.B. die Soundblaster Play! 2 USB-Soundkarte problemlos. Nach dem Zugriff auf die Sounblaster USB-Soundkarte, lässt sich die Anwendung unter MorphOS nicht mehr beenden. Da hilft nur ein Neustart. Das lustige ist, dass ich das MorphOS nicht registrieren muss weil ich die Zeit, wo es langsamer wird, kaum erreiche durch die zwingenden Neustarts.

    Eine Präsentation von diesem X5000 auf der Neuss-Show ist dadurch nicht möglich. So kann ich unserer Community MorphOS nicht schmackhaft machen. Klar, ich könnte ein Schild mit "Nicht berühren" aufstellen aber mein Prinzip ist, dass die Leute sich davor setzen können und den Rechner ausprobieren können.

    Ich weiß, dass Ehrlichkeit manchmal wehtut aber ich möchte nur einen stabilen X5000 präsentieren und würde auch einiges dafür investieren. MorphOS kam bisher einfach zu kurz bei uns und ich möchte einfach, dass unsere Community sieht, wie toll es auf dem X5000 läuft.

    Vielleicht hat hier jemand eine Idee zu den o.g. Problemen.

    Hier einige Screenshots von MorphOS auf meinem X5000:

    056a4263b07f4ef8bee3541d710ad5d3.png

    f6b0c4e4cfc31799f4075106f4b7beb4.png

    59aa322bfe6ac4c2cce15efa325d8c34.png

    Gruß

    Christian
  • »22.06.20 - 11:22
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Spectre660
    Posts: 257 from 2015/6/30
    @Christian


    PCI SoundBlaster Live! was the sound card that worked with Linux ,AmigaOS 4.1 and MorphOS .
  • »22.06.20 - 13:17
    Profile
  • Just looking around
    xeno74
    Posts: 9 from 2020/6/8
    Quote:

    Spectre660 schrieb:
    @Christian


    PCI SoundBlaster Live! was the sound card that worked with Linux ,AmigaOS 4.1 and MorphOS .


    But I am not sure if the sound card is the problem. Maybe the issue is before the data stream has reached the sound card because both sound cards have the same problem but they are different (USB/PCI/Soundchip etc).
  • »22.06.20 - 13:56
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Spectre660
    Posts: 257 from 2015/6/30
    Have you tried with only one sound card installed ? .
  • »22.06.20 - 15:02
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    polluks
    Posts: 504 from 2007/10/23
    From: Gelsenkirchen,...
    "... lässt sich die Anwendung unter MorphOS nicht mehr beenden"
    Gibt es auch eine Meldung im LogTool?
  • »22.06.20 - 18:57
    Profile
  • Just looking around
    xeno74
    Posts: 9 from 2020/6/8
    Gute Idee. Leider wird nach dem Einfrieren des Spiels nichts protokolliert. Wo finde ich das Syslog von MorphOS?
  • »23.06.20 - 06:34
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    polluks
    Posts: 504 from 2007/10/23
    From: Gelsenkirchen,...
    LogTool zeigt das "Syslog".
  • »03.07.20 - 17:09
    Profile