Iris - An upcoming E-Mail client blog
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Jambalah
    Posts: 807 from 2008/3/30
    From: Roma, Italy
    No Odissy didn't and IMAP access doesn't work...
    Pegasos II 1 ghz
    Powermac G4 Quicksilver with Sonnet Encore 1.8 ghz
    Powermac G4 MDD single 1.25 ghz, silenced for ears health...
    Powermac G5 dual 2.7 ghz I'll be back...
    Powermac G5 dual 2.0 ghz
    Powerbook G4 1.67 ghz 17
  • »11.05.20 - 19:38
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2015 from 2003/3/5
    From: Canada
    https://iris-morphos.com/

    Iris beta 84 now out. Plenty of fixes included. GMail autoconfiguration for emails outside of the gmail domain was simplified. Yahoo autoconfiguration works again. There's now basic support for email threads when using GMail. A lot of bugs were fixed and systems refactored.
  • »21.05.20 - 04:02
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Amigaharry2
    Posts: 698 from 2010/1/6
    From: EU-Austria (Wien)
    Wow. Thank you.
    Peg2, 3xPowerMac G5, 2xPowerbookG4, 2x MacMiniG4, Efika (again), A3000T and life is never boring.....
  • »21.05.20 - 08:36
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Jambalah
    Posts: 807 from 2008/3/30
    From: Roma, Italy
    Thanks! Upgraded and configured flawlessy Yahoo mail. Great work!
    Pegasos II 1 ghz
    Powermac G4 Quicksilver with Sonnet Encore 1.8 ghz
    Powermac G4 MDD single 1.25 ghz, silenced for ears health...
    Powermac G5 dual 2.7 ghz I'll be back...
    Powermac G5 dual 2.0 ghz
    Powerbook G4 1.67 ghz 17
  • »21.05.20 - 11:24
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2015 from 2003/3/5
    From: Canada
    Beta 86 is now up.
  • »22.05.20 - 18:00
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    ernsteiswuerfel
    Posts: 360 from 2015/6/18
    From: Funeralopolis
    Was there a change how deleted emails are handled in latest versions?

    When I delete an email in Iris it does (correcty) not show up in Iris any longer but it does in other clients. In Claws 3.17.5 (Linux) the email is marked with an X and header is greyed out but I can still access it. The email is only deleted for good if I sync folders in Iris after deleting mails.

    I jumped from Iris <0.84 to 0.86.
    Talos II. [Gentoo Linux] | PMac G5 11,2. PMac G4 3,6. PBook G4 5,8. [MorphOS 3.13 / Void Linux / Gentoo Linux] | A1200. ACA-1233, Indivision AGA Mk2. [Amiga OS 3.2]
  • »23.05.20 - 16:25
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2015 from 2003/3/5
    From: Canada
    OK... I did change how delete is handled in Iris. What email server are you using? It's possible I'll need to add some per-server setting...
  • »23.05.20 - 18:18
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    ernsteiswuerfel
    Posts: 360 from 2015/6/18
    From: Funeralopolis
    Quote:

    jacadcaps schrieb:
    OK... I did change how delete is handled in Iris. What email server are you using?

    mailbox.org.
    Klick here for the settings.
    Talos II. [Gentoo Linux] | PMac G5 11,2. PMac G4 3,6. PBook G4 5,8. [MorphOS 3.13 / Void Linux / Gentoo Linux] | A1200. ACA-1233, Indivision AGA Mk2. [Amiga OS 3.2]
  • »23.05.20 - 19:23
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2015 from 2003/3/5
    From: Canada
    Beta 88 is now out. Changes since last public release:

    beta88:
    - Fixed a problem with Drafts upload when sending messages via wp.pl
    - Fixed a problem with email list selection being retained after folder change
    - Tweaked printer Page Format handling

    beta87:
    - Restored EXPUNGE when deleting emails
    - Added a way to input a readable password when configuring new account
    - Improved attachment handling in the email editor
    - Fixed internal message counts after deleting single messages in a folder (making
    'reload index' functionality fail, etc)
    - Fixed a crash in autoconfiguration window when pressing 'Show all settings'
    - Fixed printer profile scanner
  • »27.05.20 - 14:01
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Amigaharry2
    Posts: 698 from 2010/1/6
    From: EU-Austria (Wien)
    In the past IRIS could load xxx.msg files from Outlook. It seems that's not possible anymore. IRIS loads the file, opens a window and displays nothing......
    Peg2, 3xPowerMac G5, 2xPowerbookG4, 2x MacMiniG4, Efika (again), A3000T and life is never boring.....
  • »27.05.20 - 19:33
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Amigaharry2
    Posts: 698 from 2010/1/6
    From: EU-Austria (Wien)
    Not really! It works after decrunching original package and adding (only!) one account. But when adding a second accound, loaded messages (.msg) are not displayed (blank window) - only attatchments are shown in bottom line and are saveable....
    Copying original accounts.json back to settings brings back display, but then I've only the first account...........
    Peg2, 3xPowerMac G5, 2xPowerbookG4, 2x MacMiniG4, Efika (again), A3000T and life is never boring.....
  • »28.05.20 - 11:48
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2015 from 2003/3/5
    From: Canada
    Now that's odd. I'll see if I can repro...

    Edit: nope. Works fine here. Any chance this is down to some particular file? Does http://file.fyicenter.com/b/sample.msg work ?

    [ Edited by jacadcaps 28.05.2020 - 14:34 ]
  • »28.05.20 - 13:13
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Amigaharry2
    Posts: 698 from 2010/1/6
    From: EU-Austria (Wien)
    I've testet that with a lot of Outlook-files (some of them, I know, are working before). Something at config-files changed when adding a second account. It does'nt turn back, if I remove second account: does'nt load msg-files anymore - or better: it loads, but does'nt show text (font?). (->screenshot)
    Cannot load your sampe.msg - loads directly to browser-window and copy&paste would cause a corrupt msg file....


    38648049oe.jpg
    Peg2, 3xPowerMac G5, 2xPowerbookG4, 2x MacMiniG4, Efika (again), A3000T and life is never boring.....
  • »28.05.20 - 16:27
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2015 from 2003/3/5
    From: Canada
    Interesting. Please try this: open a .msg file, then go to Iris's directory, then into 'tmp' : there should be one subdirectory there with a html file in. Load it into Odyssey and, if possible, email to me.
  • »28.05.20 - 18:54
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Amigaharry2
    Posts: 698 from 2010/1/6
    From: EU-Austria (Wien)
    You're right! There is email.html there and can be read in OWB.
    Mail is on the way.....
    Peg2, 3xPowerMac G5, 2xPowerbookG4, 2x MacMiniG4, Efika (again), A3000T and life is never boring.....
  • »28.05.20 - 19:05
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2015 from 2003/3/5
    From: Canada
    You seem to be getting into a case where the built-in odyssey of Iris is failing to display stuff... Will probably make a debug version for you to check later on. Sorry for that!
  • »28.05.20 - 20:08
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Amigaharry2
    Posts: 698 from 2010/1/6
    From: EU-Austria (Wien)
    Never mind! These are beta-releasis...........
    Peg2, 3xPowerMac G5, 2xPowerbookG4, 2x MacMiniG4, Efika (again), A3000T and life is never boring.....
  • »29.05.20 - 07:43
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    ernsteiswuerfel
    Posts: 360 from 2015/6/18
    From: Funeralopolis
    @jadacaps: Deleting (& expunging) emails works fine again. Thanks!
    Talos II. [Gentoo Linux] | PMac G5 11,2. PMac G4 3,6. PBook G4 5,8. [MorphOS 3.13 / Void Linux / Gentoo Linux] | A1200. ACA-1233, Indivision AGA Mk2. [Amiga OS 3.2]
  • »03.06.20 - 11:30
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2015 from 2003/3/5
    From: Canada
    Great!

    Meanwhile, beta 90 is up!
  • »04.06.20 - 13:12
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Amigaharry2
    Posts: 698 from 2010/1/6
    From: EU-Austria (Wien)
    Great, but my problem isn't solved.....can see local loaded Email (email.htm) in OWB, but not in Iris......


    Edit: Found out something strange: when I change size of window, the text appears!!

    [ Editiert durch Amigaharry2 04.06.2020 - 21:57 ]
    Peg2, 3xPowerMac G5, 2xPowerbookG4, 2x MacMiniG4, Efika (again), A3000T and life is never boring.....
  • »04.06.20 - 20:50
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2015 from 2003/3/5
    From: Canada
    Interesting. I got a repro of this once, but it isn't easy. Glad you have a workaround for now.
  • »04.06.20 - 21:13
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Amigaharry2
    Posts: 698 from 2010/1/6
    From: EU-Austria (Wien)
    Could it be a MUI-problem? If I go to MUI-Prefs and press "test" (without any action or selection of class before), text appears too.....
    Peg2, 3xPowerMac G5, 2xPowerbookG4, 2x MacMiniG4, Efika (again), A3000T and life is never boring.....
  • »05.06.20 - 07:59
    Profile