• Caterpillar
    Caterpillar
    Waitsnake
    Posts: 26 from 2014/7/21
    Hi Jambalah,
    thanks for your answer and sorry. I guess I miss the point in my last post.

    1.) I tried to install WB 3.1 in E-UAE on MOS and I was using filesystem2 to mount directories from MOS into E-UAE (for System and Games).
    I tried the installation a couple of times and always at 12% the complete emulation hangs, well even the MOS hangs more or less (windows moving around still reacts, but any other action hangs as well). I take a closer look at installation and see that first 11% of installation do nothing else than interact with user. The copy of files and directories just starts at 12% and this is the moment when E-UAE hangs.

    2.) I just boot from a WB 3.1 start diskette and try only try to copy 1 or 2 files (e.g. the calculator app or something else) from the start diskette to the folders mounted by filesystem2. Sometimes the copy works. But more often this simple file copy also hangs up the E-UAE. So problem is not the WB 3.1 installer itself but it seems to be an issue of E-UAE when using the feature of filesystem2 and copy any file to it.

    In both cases I see these ā€˛FILESYS: UNKNOWN PACKET 1f" error messages in E-UAE console output at the time of first file access to an filesystem2 mounted device. So I was thinking something could be wrong with E-UAE and I was hoping one of the developers of this software is active in this forum and he could take an eye on it. As I mentioned in my last post I was guessing the issue of E-UAE seems to be related to that missing implementation of the ACTION_INHIBIT feature from Amiga DOS.


    3.) I was creating an empty hardfile on an other operating system and than use this file with the hardfile2 feature of E-UAE and than I could install WB 3.1 without any problem. So the issue is only related to filesystem2 and hardfile2 works a treat.


    Problem I see in future with this workaround of 3.) is that even if I have now a working WB 3.1 installation using hardfile2 I still need the filesystem2 for the game folder that bridges iGame application on MOS with WB 3.1 on E-UAE. And I saw in 2.) that any simple write access from WB 3.1 to an filesystem2 mounted device could lead to an hangup and this could really ruin your day.
  • »22.07.14 - 22:15
    Profile Visit Website