• Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    NewSense
    Posts: 717 from 2012/11/10
    From: Manchester, UK...
    Thanks for your reply, and suggestions - you've been as helpful as usual 8-D jPV
    Quote:

    jPV wrote:
    I didn't try the beta printing system before (IIRC), because my printer worked just fine when printing PS directly to it otherwise too. But now with 3.10 I tried to add PPD for my (network) printer, and the PPD file I first tried does work fine. But now when you mentioned about problems, I did remember that the PPD archive came with two files, ISOLatin1 and UTF-8 versions. What I have in use is the ISOLatin1 version, and I now tried to add UTF-8 version too, but it doesn't seem to be recognized. So, do your files happen to be UTF-8 versions (check the LanguageEncoding line inside the file)?

    OK, here's some of what is in the top section of the PPD file
    ___________________________
    *% PPD File Version Information
    *FormatVersion: "4.3"
    *FileVersion: "1.0.21"
    *LanguageVersion: English
    *LanguageEncoding: ISOLatin1
    *PCFileName: "HP2500_6.PPD"

    *% Product Name and Version Information
    *Manufacturer: "HP"
    *Product: "(HP Color LaserJet 2500)"
    *ModelName: "HP Color LaserJet 2500 PS"
    *ShortNickName: "HP Color LaserJet 2500 PS"
    *NickName: "HP Color LaserJet 2500 PS v3010.107"
    *PSVersion: "(3010.107) 0"
    __________________________

    So, it should be quite obvious it's ISO Latin 1, so there's no reason, from what you've said, as to why I can't see why the PPD file won't add it into the printer list. I should also mention that I don't seem to be able to add a Profile UNTIL I've added the PPD file (seems logical), and obviously that relies on it being recognised - which it isn't, so this sort of issue, the number of printers tested should have been tested better, and with a greater variety of users' printers before it was fully implemented, as it does not seem to be working for me anyway. :-(

    Also, my HP 2500 CLJ only came with the one PPD file, and that seems to be ISOLatin1, yet surely there should have been a selection of PPD files for known/supported/tested printers for a user to choose from with the MorphOS v3.10 release, rather than this situation me/we now find ourselves in. :-(

    I've even checked the one I put in PageStream's Printers to see if that is any different, and even the HP Color LaserJet 5M that I also own is, surprise, surprise, also not recognised in the Printers PPD requester/allocation window, so there is something wrong there it seems as thst is a Supported Printer!

    I should also mention that I used a MorphOS v3.10 Booted CD-RW - that had been "Injected" with MY MorphOS keyfile, using the now updated v1.12 RegisterISO tool by Guido "Geit" Mersmann, to be able to boot and install the hardware without the CD-RW 'timing-out'. So, as the RegisterISO tool has been modified, and possibly not fully tested - is this also an unknown factor that this may have 'affected' the ISO in such a way that some of the data in the ISO file has been manipulated into a different data format/structure, and this has caused some of the issues I am now experiencing/noticing? Of course, I cannot know if it is, but this obviously could be a factor as well.

    Quote:

    jPV wrote: I guess the printer list at homepage is what TurboPrint supports by dedicated drivers? Maybe it's too much to ask to list every compatible PS printer or so? :)

    Maybe every currently available printer would be far too much to ask, but those tested with the early-Beta and during Beta-testing should have been added to the MorphOS Supported Printer list, which it doesn't seem to have been done, or my HP 2500 CLJ would already be on the list! :-(

    Maybe someone will begin to see my frustration with this v3.10 release, that seems great on the surface, but boy oh boy, it surely doesn't deliver what all users would have been hoping for. No new OWB version, other than some beautification, and fixing, but it's not working with some sites that even I use, so how many other users are disappointed with it I dread to think.

    Then there's this Printer system mis-firing, well actually for me it's not working, and that's a backward step from using the Beta Printing in v3.9!

    Then my C-Media USB headphone and microphone adapter is also not recognised with the new Isochronous transfer implementation, but then ... I've only just found out its basically worthless Isochronous discussed on Forum.

    So, is it surprising we find ourselves with the PPD Printers system not working as expected ... you decide for yourself, as I've already made my own decisioin, as it's too rude to publish !!!!
    MacMini 1.5GHz,Model 10.2,64MB VRAM,250GB HDD,1GB RAM,Airport, Bluetooth,A1016 Keyboard,T-RB22 Mouse,DVD-RW-DL+CD-RW,Iomega MiniMax,Belkin 6 port 3 x Firewire/3 x USB2,MorphOS 3.11,Mac OSX 10.4/10.5,A1138+A1139 PwrBk MOS v3.11,Model 5,8/5,9
  • »07.04.18 - 02:38
    Profile