SCUMMVM 2.5
  • Butterfly
    Butterfly
    Posts: 91 from 2020/12/24
    Your scene is very different from my bugs.

    Don't know if really GL_EXT_packed_depth_stencil is really necessary here.

    On my system looks like this:

    https://ibb.co/T2ZWWZF

    As seen, Manny as his shadow (the player) is rendered in front of wheels and stuff in the garage due to failure of depth testing. Same happen in other scenes.

    The large stretch of the shadow is due to "no" stencil working.
  • »10.01.22 - 19:39
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    beworld
    Posts: 590 from 2010/2/10
    From: FRANCE
    Same here : https://ibb.co/HFPHY0J
    IMac G5 2.1,PowerBook G4 1.5,MacMini 1.5, PowerMac G5 2.7 died !!!
    My MOS ports
  • »10.01.22 - 20:18
    Profile Visit Website
  • Butterfly
    Butterfly
    Posts: 91 from 2020/12/24
    At least some common ground between drivers. For glreadpixels failing with R300 maybe scummvm tinygl code can be used as an example for a workaround like converting the pixelformat to a working one before calling glreadpixel.
  • »11.01.22 - 08:20
    Profile
  • Butterfly
    Butterfly
    kas1e
    Posts: 97 from 2005/10/31
    @BSzili
    Can you check plz if you have the same problems on morphos build:
    https://bugs.scummvm.org/ticket/13417

    So we will know if it general big-endian issue, or platform specific

    Thanks!
  • »13.04.22 - 09:20
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    beworld
    Posts: 590 from 2010/2/10
    From: FRANCE
    @kas1e
    I build last master (not BSzili ?), and i test sq45

    Worse.... not working here...

    ERROR: Unable to determine game data. (Searched in: ./)

    User picked target 'sq45' (engine ID 'ags', game ID 'sq45')...
    Looking for a plugin supporting this target... Adventure Game Studio
    Running Space Quest IV.5 - Roger Wilco And The Voyage Home
    SQ4,5.exe: 5cd8db602cedc8f04cd3ca290a4a2693, 6886082 bytes.
    WARNING: TODO: SetCurrentDirectory: Games:ScummVM/games/SQ45/!
    Initializing backend libs
    Initializing game data


    I continue to test, but ./ with MorphOS seem not a good idea.

    path information: (same here not really amigaos/morphos friendly ?)
    https://github.com/scummvm/scummvm/blob/master/engines/ags/shared/util/path.cpp

    [ Edité par beworld 13.04.2022 - 14:12 ]
    IMac G5 2.1,PowerBook G4 1.5,MacMini 1.5, PowerMac G5 2.7 died !!!
    My MOS ports
  • »13.04.22 - 12:04
    Profile Visit Website
  • Butterfly
    Butterfly
    kas1e
    Posts: 97 from 2005/10/31
    @beworld

    Sorry i just by ancident mess the nicknames, of course i mean you :) Yeah, seems there something wrong with ./ on mos side as well so you didn't go till the moment when we died on os4 :(
  • »13.04.22 - 17:41
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    beworld
    Posts: 590 from 2010/2/10
    From: FRANCE
    ScummVM 2.6.0 release

    https://www.morphos-storage.net/?id=1783587
    IMac G5 2.1,PowerBook G4 1.5,MacMini 1.5, PowerMac G5 2.7 died !!!
    My MOS ports
  • »02.08.22 - 10:40
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Cool_amigaN
    Posts: 745 from 2011/11/30
    Hey, got an issue to report: fired up recently scummvm 2.7.0 and though it was always working normally, it refused to appear (despite consuming ram, hd leds on sbar actively blinking when loading binary etc). I checked with 2.5.1 and was same story. Downloaded latest 2.7.1 and again nothing appeared on Ambient. I re-installed latest tinygl and sdl, rebooted but again no go. Checked with the old 2.2.0 git version and scummvm was loading properly :? Opened Snoopium and it appeared that it was failing to read some local timezone data which was pointing at Sys:data/zoneinfo/europe/athens where there is no drawer of such, which I copied from MOSSYS:data/zoneinfo at SYS destination. Rebooted and now it's working back again. Has anything changed with MorphOS 3.18 since I think it's been a while since I checked scummvm..?
    Amiga gaming Tribute: Watch, rate, comment :)
  • »17.12.23 - 21:38
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    beworld
    Posts: 590 from 2010/2/10
    From: FRANCE
    - Do you reinstall SDL2 with installer ? (installer force to disabled SHADERS use, because ScummVM crash directly with this SDL2 option)
    - You can launch DebugTool to check if ScummVM crash before open window and send me debug.crash log
    - last change, rename scummvm.ini and relaunch it
    IMac G5 2.1,PowerBook G4 1.5,MacMini 1.5, PowerMac G5 2.7 died !!!
    My MOS ports
  • »18.12.23 - 13:34
    Profile Visit Website
  • ghh
  • Cocoon
    Cocoon
    ghh
    Posts: 52 from 2017/7/16
    From: Prague
    ScummVM 2.8.0
    I have a similar problem to Cool_amigaN. If I turn on my computer and start ScummVM first, it starts normally. But if I run several programs before that (e.g. Wayfarer), ScummVM usually doesn't start (consumes ram, hd leds actively blink). Resetting usually doesn't help and it only works after a cold start (?!).
    The problem is that I can't reproduce it exactly every time.
    Logs here:
    http://ghh.8u.cz/friends/scummvmlogs.lha
  • »01.01.24 - 16:09
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    beworld
    Posts: 590 from 2010/2/10
    From: FRANCE
    ok thanks @ghh
    i see problem with sdl2 and scummvm, i check that

    [ Edité par beworld 02.01.2024 - 14:39 ]
    IMac G5 2.1,PowerBook G4 1.5,MacMini 1.5, PowerMac G5 2.7 died !!!
    My MOS ports
  • »02.01.24 - 14:36
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    beworld
    Posts: 590 from 2010/2/10
    From: FRANCE
    New build: https://www.morphos-storage.net/?id=2030665

    Fix crash at startup (SDL2 problem with created window hidden and test context opengl...)
    Disabled libjpeg_shared (too old from SDK), add jpeg9e, that fix problem with Myst games

    Happy New Year 2024 ALL !
    IMac G5 2.1,PowerBook G4 1.5,MacMini 1.5, PowerMac G5 2.7 died !!!
    My MOS ports
  • »02.01.24 - 16:12
    Profile Visit Website
  • ghh
  • Cocoon
    Cocoon
    ghh
    Posts: 52 from 2017/7/16
    From: Prague
    Perfect! Everything works as it should.
    It's clear that you really understand your job:)
    Thank You!
  • »02.01.24 - 17:32
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    polluks
    Posts: 778 from 2007/10/23
    From: Gelsenkirchen,...
    Quote:

    beworld schrieb:
    Disabled libjpeg_shared (too old from SDK), add jpeg9e, that fix problem with Myst games


    You may request an update in the ticket tracker...
    Pegasos II G4: MorphOS 3.9, Zalman M220W · iMac G5 12,1 17", MorphOS 3.18
    Power Mac G3: OSX 10.3 · PowerBook 5,8: OSX 10.5, MorphOS 3.18
  • »04.01.24 - 10:13
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    beworld
    Posts: 590 from 2010/2/10
    From: FRANCE
    Quote:

    polluks a écrit :
    You may request an update in the ticket tracker...



    Done, you right ;-)
    IMac G5 2.1,PowerBook G4 1.5,MacMini 1.5, PowerMac G5 2.7 died !!!
    My MOS ports
  • »04.01.24 - 11:37
    Profile Visit Website