Playing MODs in AmiNet Radio player
  • Order of the Butterfly
    Order of the Butterfly
    WeiXing3D
    Posts: 326 from 2012/6/13
    From: Pacifica, CA
    I was trying to play some Mod files that I moved from a previous OS4.1 system that I owed before, in AmiNet Radio Player, but all I get is high pitched short bursts of noise.

    Is this a compatibility issue? Or is there any other way to play those files?

    Are there any other sources to download MOds compatible with Morphos players?
    MacMini G4 1.5GHz with MorphOS 3.9 FPGA MiST w/AmigaOS 3.9 (PFS3), FPGA Replay w/AmigaOS3.9, Amiga 1200 SCSI CD-RW, X-SURF 100 w/Rapidroad USB, External FDD with Chinon and Gotek units and Acer Aspire One ICAROS
  • »09.10.13 - 22:22
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 9956 from 2003/5/22
    From: Germany
    > I was trying to play some Mod files that I moved from a previous OS4.1 system that
    > I owed before, in AmiNet Radio Player, but all I get is high pitched short bursts of noise.
    > Is this a compatibility issue?

    No, this is most likely an issue of disabled ANR MOD player. Go to "Settings" -> "Settings" -> "Players", select "ptplay.player", tick "Activate" and click "Save".
    There're also other MOD-compatible players for ANR:

    http://aminet.net/package/mus/play/ANR_modplayer
    http://aminet.net/package/mus/play/anr-modplug

    > Or is there any other way to play those files?

    Yes, UADE and Delitracker come to mind.

    > Are there any other sources to download MOds compatible with Morphos players?

    Other sources than what? Your question sounds somewhat weird as basically any MOD file in existence should play with any of the above-mentioned programs and ANR players.
  • »10.10.13 - 00:06
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    WeiXing3D
    Posts: 326 from 2012/6/13
    From: Pacifica, CA
    Thank you Andreas.

    It turned out that "ptplay.player" was activated. I clicked on Save anyways, but still all I get is noise, like the audio is playing at a ery high speed.


    Quote:

    Andreas_Wolf wrote:
    > I was trying to play some Mod files that I moved from a previous OS4.1 system that
    > I owed before, in AmiNet Radio Player, but all I get is high pitched short bursts of noise.
    > Is this a compatibility issue?

    No, this is most likely an issue of disabled ANR MOD player. Go to "Settings" -> "Settings" -> "Players", select "ptplay.player", tick "Activate" and click "Save".
    There're also other MOD-compatible players for ANR:

    http://aminet.net/package/mus/play/ANR_modplayer
    http://aminet.net/package/mus/play/anr-modplug

    > Or is there any other way to play those files?

    Yes, UADE and Delitracker come to mind.

    > Are there any other sources to download MOds compatible with Morphos players?

    Other sources than what? Your question sounds somewhat weird as basically any MOD file in existence should play with any of the above-mentioned programs and ANR players.
    MacMini G4 1.5GHz with MorphOS 3.9 FPGA MiST w/AmigaOS 3.9 (PFS3), FPGA Replay w/AmigaOS3.9, Amiga 1200 SCSI CD-RW, X-SURF 100 w/Rapidroad USB, External FDD with Chinon and Gotek units and Acer Aspire One ICAROS
  • »10.10.13 - 01:02
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 9956 from 2003/5/22
    From: Germany
    > It turned out that "ptplay.player" was activated. I clicked on Save anyways, but still all
    > I get is noise, like the audio is playing at a ery high speed.

    Do other file formats like MP3 play well in ANR?
  • »10.10.13 - 01:19
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    WeiXing3D
    Posts: 326 from 2012/6/13
    From: Pacifica, CA
    Quote:

    Andreas_Wolf wrote:
    > It turned out that "ptplay.player" was activated. I clicked on Save anyways, but still all
    > I get is noise, like the audio is playing at a ery high speed.

    Do other file formats like MP3 play well in ANR?


    I just realized that the files that I ported from that O4.1 computer were, for some unknown reason, saved as "mod.filename" format and their respective icons show them as tools.

    I'm wondering if there is a way of editing them so that I can play them. I'd be a shame to lose such a complete compilation of 199 songs,
    MacMini G4 1.5GHz with MorphOS 3.9 FPGA MiST w/AmigaOS 3.9 (PFS3), FPGA Replay w/AmigaOS3.9, Amiga 1200 SCSI CD-RW, X-SURF 100 w/Rapidroad USB, External FDD with Chinon and Gotek units and Acer Aspire One ICAROS
  • »10.10.13 - 02:23
    Profile
  • MorphOS Developer
    itix
    Posts: 1514 from 2003/2/24
    From: Finland
    There are several MOD players for ANR and they definitely work. I suspect those MODs are detected in another format and are assigned to wrong player. You can assign MOD player to higher priority so it would be checked first. Also make sure you have ptplay.library installed. I dont remember if it is included in ANR package.
    1 + 1 = 3 with very large values of 1
  • »10.10.13 - 06:48
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 9956 from 2003/5/22
    From: Germany
    > I just realized that the files that I ported from that O4.1 computer were, for
    > some unknown reason, saved as "mod.filename" format

    Using "mod" as prefix instead of as suffix for MOD file names has been (for reasons I'm not aware of) quite common on the Amiga. However, this affects neither ANR nor its players (tested here). It should play fine nonetheless.

    > their respective icons show them as tools.

    This shouldn't matter either.

    > I'm wondering if there is a way of editing them so that I can play them.

    I doubt that editing the MOD files would amount to anything. To make sure the MOD files are okay you can test them with another player like UADE.
  • »10.10.13 - 09:10
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 9956 from 2003/5/22
    From: Germany
    > make sure you have ptplay.library installed. I dont remember if it is included in ANR package.

    It is, but in an older version. He can install the most recent one from http://aminet.net/package/mus/play/PTPlayLibrary but not sure if that'll help with his problem.
  • »10.10.13 - 09:41
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    WeiXing3D
    Posts: 326 from 2012/6/13
    From: Pacifica, CA
    I downloaded and installed the new ptplay.library following your link. Thank you.

    I also downloaded a couple of new mod songs and they play well.

    But I still can't make the other mod.songname files to play.

    I haven't been able to try UAED since I haven't figured it out. The colder inside the UAED directory (System:Applications/AUDIO/UAED/Players) only shows tools and not an executable player.

    I'm sure I'm missing something.

    Quote:

    Andreas_Wolf wrote:
    > make sure you have ptplay.library installed. I dont remember if it is included in ANR package.

    It is, but in an older version. He can install the most recent one from http://aminet.net/package/mus/play/PTPlayLibrary but not sure if that'll help with his problem.
    MacMini G4 1.5GHz with MorphOS 3.9 FPGA MiST w/AmigaOS 3.9 (PFS3), FPGA Replay w/AmigaOS3.9, Amiga 1200 SCSI CD-RW, X-SURF 100 w/Rapidroad USB, External FDD with Chinon and Gotek units and Acer Aspire One ICAROS
  • »10.10.13 - 20:17
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 9956 from 2003/5/22
    From: Germany
    > I also downloaded a couple of new mod songs and they play well. But I still can't make
    > the other mod.songname files to play.

    Okay, that very much hints at a problem with your MOD files specifically. But I have no idea what it might be. Maybe you can upload one of those files somewhere and give a link to it so we can try it on our systems with ANR.

    > I haven't been able to try UAED since I haven't figured it out. The colder inside the
    > UAED directory (System:Applications/AUDIO/UAED/Players) only shows tools and
    > not an executable player. I'm sure I'm missing something.

    Indeed. On your system, the UADE executable should be System:Applications/AUDIO/UAED/uade.
  • »10.10.13 - 21:18
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    WeiXing3D
    Posts: 326 from 2012/6/13
    From: Pacifica, CA
    Thank you Andreas.

    I will upload and past a link to Dropbox with a couple of these files when I come back from work today (I'm in California).

    Regarding UAED, there's exactly where I'm looking for it but there's not executable.

    Funny thing is that I downloaded a newer version from Aminte, and the same thing happens after installation...there isn't an executable anywhere.

    Cheers.

    Quote:

    Andreas_Wolf wrote:
    > I also downloaded a couple of new mod songs and they play well. But I still can't make
    > the other mod.songname files to play.

    Okay, that very much hints at a problem with your MOD files specifically. But I have no idea what it might be. Maybe you can upload one of those files somewhere and give a link to it so we can try it on our systems with ANR.

    > I haven't been able to try UAED since I haven't figured it out. The colder inside the
    > UAED directory (System:Applications/AUDIO/UAED/Players) only shows tools and
    > not an executable player. I'm sure I'm missing something.

    Indeed. On your system, the UADE executable should be System:Applications/AUDIO/UAED/uade.
    MacMini G4 1.5GHz with MorphOS 3.9 FPGA MiST w/AmigaOS 3.9 (PFS3), FPGA Replay w/AmigaOS3.9, Amiga 1200 SCSI CD-RW, X-SURF 100 w/Rapidroad USB, External FDD with Chinon and Gotek units and Acer Aspire One ICAROS
  • »10.10.13 - 21:23
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 9956 from 2003/5/22
    From: Germany
    >> On your system, the UADE executable should be System:Applications/AUDIO/UAED/uade.

    > there's exactly where I'm looking for it but there's not executable.

    If you don't have an executable in that path then your UADE installation seems borked. If that's the case you should re-install it, from http://downloads.morph.zone/find.php?find=uade for instance.

    > I downloaded a newer version from Aminte, and the same thing happens after
    > installation...there isn't an executable anywhere.

    Do you have a link to that newer UADE version on Aminet so I can have a look?
    The only newer version I know is this UADE2 one:

    http://bszili.morphos.me/ports/uade-mos.lha

    In this version, which isn't on Aminet, the executable file is called "uade123".
  • »10.10.13 - 21:43
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    WeiXing3D
    Posts: 326 from 2012/6/13
    From: Pacifica, CA
    This is the link to a couple of mods which are not playing in AmiNetRadio.

    Sorry it's a Dropbox link :-(

    https://www.dropbox.com/sh/3zbhom0rlavxn7y/2KCraqrXfV

    Link to screen grabs of content in UADE folder at System:Applications/Audio/UADE/

    https://www.dropbox.com/sh/4sttphxwbo0o42r/U_P0rzdr6n
    MacMini G4 1.5GHz with MorphOS 3.9 FPGA MiST w/AmigaOS 3.9 (PFS3), FPGA Replay w/AmigaOS3.9, Amiga 1200 SCSI CD-RW, X-SURF 100 w/Rapidroad USB, External FDD with Chinon and Gotek units and Acer Aspire One ICAROS
  • »10.10.13 - 22:58
    Profile
  • k8o
  • Cocoon
    Cocoon
    k8o
    Posts: 57 from 2013/5/29
    From: London / UK
    Is it possible your old mods were XPK'ed and thus require depacking now?
  • »10.10.13 - 23:27
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 9956 from 2003/5/22
    From: Germany
    > https://www.dropbox.com/sh/3zbhom0rlavxn7y/2KCraqrXfV

    I downloaded them and have found the following things:

    1. Both files are PowerPacker-packed (PP20). You should decrunch them using for instance one of the following tools:
    http://aminet.net/package/util/arc/ppunpack10-mos
    http://aminet.net/package/util/crypt/ppcrack_MOS

    2. The file "mod.AncientStories" is not a classic MOD file but a FastTracker 2 Extended Module file so should be named "AncientStories.xm".

    3. The file "mod.Somewhere_In_Time" is not a classic MOD file but a Scream Tracker 3 Module file so should be named "Somewhere_In_Time.s3m".

    Both file formats XM and S3M can be played with any of the two ANR players "mod.player" and "modplug.player" linked to in a previous posting.

    > https://www.dropbox.com/sh/4sttphxwbo0o42r/U_P0rzdr6n

    Your leftmost screenshot (Grab2) shows the "uade123" executable file I talked about in my previous posting. Is this the UADE version which you said you had from Aminet and which I asked for a link for?
  • »10.10.13 - 23:35
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    WeiXing3D
    Posts: 326 from 2012/6/13
    From: Pacifica, CA
    Thank you Andreas.

    I downloaded ppunpack and decompressed the lha file, but I didn't find instructions on how to use it to decrunch the files, in the readme files included in the directory.

    Do I run it as command from shell?

    Cheers.

    Quote:

    Andreas_Wolf wrote:
    > https://www.dropbox.com/sh/3zbhom0rlavxn7y/2KCraqrXfV

    I downloaded them and have found the following things:

    1. Both files are PowerPacker-packed (PP20). You should decrunch them using for instance one of the following tools:
    http://aminet.net/package/util/arc/ppunpack10-mos
    http://aminet.net/package/util/crypt/ppcrack_MOS

    2. The file "mod.AncientStories" is not a classic MOD file but a FastTracker 2 Extended Module file so should be named "AncientStories.xm".

    3. The file "mod.Somewhere_In_Time" is not a classic MOD file but a Scream Tracker 3 Module file so should be named "Somewhere_In_Time.s3m".

    Both file formats XM and S3M can be played with any of the two ANR players "mod.player" and "modplug.player" linked to in a previous posting.

    > https://www.dropbox.com/sh/4sttphxwbo0o42r/U_P0rzdr6n

    Your leftmost screenshot (Grab2) shows the "uade123" executable file I talked about in my previous posting. Is this the UADE version which you said you had from Aminet and which I asked for a link for?
    MacMini G4 1.5GHz with MorphOS 3.9 FPGA MiST w/AmigaOS 3.9 (PFS3), FPGA Replay w/AmigaOS3.9, Amiga 1200 SCSI CD-RW, X-SURF 100 w/Rapidroad USB, External FDD with Chinon and Gotek units and Acer Aspire One ICAROS
  • »11.10.13 - 04:37
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 9956 from 2003/5/22
    From: Germany
    > I downloaded ppunpack and decompressed the lha file, but I didn't find instructions on
    > how to use it to decrunch the files, in the readme files included in the directory.

    Running the program without parameters gives "Usage: ppunpack infile outfile".

    > Do I run it as command from shell?

    Yes.
  • »11.10.13 - 09:25
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    WeiXing3D
    Posts: 326 from 2012/6/13
    From: Pacifica, CA
    Sorry to be a pest@Andreas_Wolf.

    I can't get i to work. Running the following command in shell:
    Work:Utilities/PPUnpack1.0/ppunpack infile outfile
    Gives me a can't open input file message

    In my case my Mods are at Work:Audio/Mods/

    Please help.



    Quote:

    Andreas_Wolf wrote:
    > I downloaded ppunpack and decompressed the lha file, but I didn't find instructions on
    > how to use it to decrunch the files, in the readme files included in the directory.

    Running the program without parameters gives "Usage: ppunpack infile outfile".

    > Do I run it as command from shell?

    Yes.
    MacMini G4 1.5GHz with MorphOS 3.9 FPGA MiST w/AmigaOS 3.9 (PFS3), FPGA Replay w/AmigaOS3.9, Amiga 1200 SCSI CD-RW, X-SURF 100 w/Rapidroad USB, External FDD with Chinon and Gotek units and Acer Aspire One ICAROS
  • »13.10.13 - 02:42
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 9956 from 2003/5/22
    From: Germany
    > Running the following command in shell:
    > Work:Utilities/PPUnpack1.0/ppunpack infile outfile
    > Gives me a can't open input file message
    > In my case my Mods are at Work:Audio/Mods/

    infile is a placeholder for the path to the file you want it to decrunch (Work:Audio/Mods/<filename>), outfile is a placeholder for the path to the file you want it to save the decrunched MOD to. You get the error message because it can't find any file called 'infile'.
  • »13.10.13 - 09:59
    Profile
  • Paladin of the Pegasos
    Paladin of the Pegasos
    Intuition
    Posts: 1014 from 2013/5/24
    From: Englistan
    Try xadunfile filename ram:
    1.67GHz 15" PowerBook G4, 1GB RAM, 128MB Radeon 9700M Pro, 64GB SSD, MorphOS 3.9

    2.7GHz DP G5, 4GB RAM, 512MB Radeon X1950 Pro, OSX 10.5.8, 500GB SSHD, MorphOS 3.9
  • »13.10.13 - 13:28
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 9956 from 2003/5/22
    From: Germany
    > Try xadunfile filename ram:

    I think he will need http://aminet.net/package/util/arc/xad_xfd and http://aminet.net/package/util/pack/xfdmaster for this to work.
  • »13.10.13 - 13:45
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    WeiXing3D
    Posts: 326 from 2012/6/13
    From: Pacifica, CA
    @Andreas_Wolf Thank you for all the help. It worked, but some files still don't play after decrounching; for instance the mod.Somewhere_In_Time mod I posted in one my postings above.
    MacMini G4 1.5GHz with MorphOS 3.9 FPGA MiST w/AmigaOS 3.9 (PFS3), FPGA Replay w/AmigaOS3.9, Amiga 1200 SCSI CD-RW, X-SURF 100 w/Rapidroad USB, External FDD with Chinon and Gotek units and Acer Aspire One ICAROS
  • »13.10.13 - 22:30
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 9956 from 2003/5/22
    From: Germany
    > some files still don't play after decrounching; for instance the mod.Somewhere_In_Time
    > mod I posted in one my postings above.

    As I wrote to you this is not a MOD file but an S3M file and it plays fine here with ANR. How do you try to play it? Have you installed any of the two ANR players I told you were needed for S3M file playback?
  • »13.10.13 - 23:06
    Profile
  • Paladin of the Pegasos
    Paladin of the Pegasos
    Intuition
    Posts: 1014 from 2013/5/24
    From: Englistan
    Quote:

    Andreas_Wolf wrote:
    > Try xadunfile filename ram:

    I think he will need http://aminet.net/package/util/arc/xad_xfd and http://aminet.net/package/util/pack/xfdmaster for this to work.


    Quite right.

    I have all kinds of xad/xfd/xpk stuff installed and I often get confused as to which does what.
    1.67GHz 15" PowerBook G4, 1GB RAM, 128MB Radeon 9700M Pro, 64GB SSD, MorphOS 3.9

    2.7GHz DP G5, 4GB RAM, 512MB Radeon X1950 Pro, OSX 10.5.8, 500GB SSHD, MorphOS 3.9
  • »13.10.13 - 23:17
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 9956 from 2003/5/22
    From: Germany
    > I have all kinds of xad/xfd/xpk stuff installed and I often get confused as to which does what.

    There's a nice summary by the 'X-Systems' author:

    http://cd.textfiles.com/amigaplus/sonderheft26/Tools/Packer/xad/X-Systems.TXT
  • »13.10.13 - 23:41
    Profile