Odyssey Font Downloader gives "failed: No route to host"
  • Just looking around
    aurora72
    Posts: 20 from 2013/1/26
    From: Turkey
    Hello

    I'm trying to install Fonts using the "Download Fonts" application in Odyssey WB folder but it constantly gives this message

    Connecting to kent.dl.sourceforge.net [212.219.56.167]:80... failed: No route to host
    Retrying
    ....

    It looks like a Network Settings problem but other network apps such as OWB and Grunch works perfectly across the network.

    How to repair this? I need to have Arial fonts downloaded; currently webpages show with inappropraite fonts. Thanks.
  • »27.01.13 - 15:20
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    stephen_robinson
    Posts: 729 from 2007/4/22
    Which version of OWB are you using? the last time I tried an old one many of the downloads seemed broken, but the last version of OWB had a fixed version that worked fine, but then that was a month ago and locations change.
  • »27.01.13 - 15:24
    Profile
  • Just looking around
    aurora72
    Posts: 20 from 2013/1/26
    From: Turkey
    It's version 1.17 (14.05.2012) Meanwhile let me check if I can install a newwe version if there's any.
  • »27.01.13 - 15:43
    Profile
  • Just looking around
    aurora72
    Posts: 20 from 2013/1/26
    From: Turkey
    Grunch has displayed it as Outdated and I've started to download the newer version. After it completes, I'll post the result.
  • »27.01.13 - 15:47
    Profile
  • Just looking around
    aurora72
    Posts: 20 from 2013/1/26
    From: Turkey
    Hello

    It must have been definitely a problem with the version, because after I updated to the newest version 1.8, first the "Download Fonts" has worked and then the correct fonts in OWB appeared.

    Problem solved.

    [ Edited by aurora72 27.01.2013 - 16:43 ]
  • »27.01.13 - 16:38
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Brumiga
    Posts: 176 from 2004/4/3
    From: France
    Hello folks,

    I did several small essays during the weekend and I managed to download the m$ truetype fonts. The problem comes from the wget command included in 'owb/datas' version 1.8.2 of 2009. it is very or even too old. Trying with version 1.19.3 of July 2015, available at http://morphos-files.net/download/wget, I almost succeed, an argument is asked '--no-check-certificate'. I then modify the script for downloading and installing the fonts and it works.

    <Script>
    ; OWB font downloader

    .KEY foo
    .BRA {
    . KET}

    failat 21

    Echo "Welcome to OWB font downloader!"

    If not exists c: xadUnFile
    Requestchoice> nil: "OWB font downloader" "You need to have a functional XADMaster in your system" "Ok"
    quit 5
    endif

    Requestchoice> env: OWBch {$$} "OWB font downloader" * Do you want to download and install fonts? * * OWB needs to download ~ 4MB of fonts. * N * Installing fonts will result in copying a few ttf fonts SYS: Fonts / _ttf "" Yes "" No "
    If not val "$ OWBch {$$}" eq "1"
    Unsetenv OWBch {$$}
    quit
    endif
    Unsetenv OWBch {$$}

    Echo> t: fetchfont {$$} ".KEY F * NC: wget --no-check-certificate --tries 10 --waitretry 10 http://downloads.sourceforge.net/project/corefonts/the%20fonts/ \ N \ n \ n \ n \ n \ n \ n \ n \ n \ n \ n \ n \ n \ n \ n \ n \ n " . OWB WILL NOT work * * * * * Nquit * Nendif * Nc: xadUnFile t: ff_tmp <* $ * $> sys: fonts / _ttf file = #? 0 * Nrequestchoice> nil: * "OWB font downloader *" * "Failed to unpack '<F>' do archive. OWB WILL NOT WORK * "*" Ok * "* nquit 22 * ​​Nendif"
    Protect "t: fetchfont {$$}" +

    "T: fetchfont {$$}" andale32
    "T: fetchfont {$$}" arial32
    "T: fetchfont {$$}" arialb32
    "T: fetchfont {$$}" comic32
    "T: fetchfont {$$}" courie32
    "T: fetchfont {$$}" georgi32
    "T: fetchfont {$$}" impact32
    "T: fetchfont {$$}" times32
    "T: fetchfont {$$}" trebuc32
    "T: fetchfont {$$}" verdan32
    "T: fetchfont {$$}" webdin32

    Delete "t: fetchfont {$$}" "t: ff_tmp {$$}" all quiet

    Echo "* NDownload full"
    </ Script>

    There I put c: wget to use the latest version instead of the old one. However, why does this argument have to be added to the wget command ? Me, I do not know.

    Could anyone change the tags to indicate that this is an amigados script ?

    Brumiga
  • »05.12.16 - 09:21
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 8935 from 2003/5/22
    From: Germany
    > version 1.19.3 of July 2015, available at http://morphos-files.net/download/wget

    Isn't that version 1.16.3?

    > why does this argument have to be added to the wget command ?

    That's because MorphOS doesn't have a system-specified location for CA certificates so wget wouldn't know where to find them for verification, even if installed.

    http://www.gnu.org/software/wget/manual/html_node/HTTPS-_0028SSL_002fTLS_0029-Options.html

    > Could anyone change the tags to indicate that this is an amigados script ?

    Use the 'code' tags.
  • »05.12.16 - 15:44
    Profile
  • Just looking around
    Posts: 9 from 2017/3/16
    Hi everyone

    I tried this version but hit the same problem. Sourceforge, as far as I can tell, no longer houses the fonts.

    So I end up with "OWB will not work." after various statements that it cannot load the very first font (andale I think).

    Does anyone know the site where I can fetch those fonts? Of course it will mean modifying the script.

    Thanks in advance for any advice.

    RD



    Quote:

    Brumiga wrote:
    Hello folks,

    I did several small essays during the weekend and I managed to download the m$ truetype fonts. The problem comes from the wget command included in 'owb/datas' version 1.8.2 of 2009. it is very or even too old. Trying with version 1.19.3 of July 2015, available at http://morphos-files.net/download/wget, I almost succeed, an argument is asked '--no-check-certificate'. I then modify the script for downloading and installing the fonts and it works.

    <Script>
    ; OWB font downloader

    .KEY foo
    .BRA {
    . KET}

    failat 21

    Echo "Welcome to OWB font downloader!"

    If not exists c: xadUnFile
    Requestchoice> nil: "OWB font downloader" "You need to have a functional XADMaster in your system" "Ok"
    quit 5
    endif

    Requestchoice> env: OWBch {$$} "OWB font downloader" * Do you want to download and install fonts? * * OWB needs to download ~ 4MB of fonts. * N * Installing fonts will result in copying a few ttf fonts SYS: Fonts / _ttf "" Yes "" No "
    If not val "$ OWBch {$$}" eq "1"
    Unsetenv OWBch {$$}
    quit
    endif
    Unsetenv OWBch {$$}

    Echo> t: fetchfont {$$} ".KEY F * NC: wget --no-check-certificate --tries 10 --waitretry 10 http://downloads.sourceforge.net/project/corefonts/the%20fonts/ \ N \ n \ n \ n \ n \ n \ n \ n \ n \ n \ n \ n \ n \ n \ n \ n \ n " . OWB WILL NOT work * * * * * Nquit * Nendif * Nc: xadUnFile t: ff_tmp <* $ * $> sys: fonts / _ttf file = #? 0 * Nrequestchoice> nil: * "OWB font downloader *" * "Failed to unpack '<F>' do archive. OWB WILL NOT WORK * "*" Ok * "* nquit 22 * ​​Nendif"
    Protect "t: fetchfont {$$}" +

    "T: fetchfont {$$}" andale32
    "T: fetchfont {$$}" arial32
    "T: fetchfont {$$}" arialb32
    "T: fetchfont {$$}" comic32
    "T: fetchfont {$$}" courie32
    "T: fetchfont {$$}" georgi32
    "T: fetchfont {$$}" impact32
    "T: fetchfont {$$}" times32
    "T: fetchfont {$$}" trebuc32
    "T: fetchfont {$$}" verdan32
    "T: fetchfont {$$}" webdin32

    Delete "t: fetchfont {$$}" "t: ff_tmp {$$}" all quiet

    Echo "* NDownload full"
    </ Script>

    There I put c: wget to use the latest version instead of the old one. However, why does this argument have to be added to the wget command ? Me, I do not know.

    Could anyone change the tags to indicate that this is an amigados script ?

    Brumiga
  • »08.05.17 - 09:58
    Profile
  • Just looking around
    Posts: 9 from 2017/3/16
    Thank you. I will try your explanation tomorrow. If you hear no further from me it means that your suggestion worked! RD


    Quote:

    Papiosaur wrote:
    Hi Robdel,

    you must copy files from archive to sys: then launch the installation script in OWB drawer.

    Sorry, it's my fault, I will add a Readme file to explain that.
  • »10.05.17 - 10:20
    Profile