OWB eating all memory and meditating
  • Order of the Butterfly
    Order of the Butterfly
    amyren
    Posts: 219 from 2010/5/15
    From: Norway
    This happens when I log into the following website, www.plus500.com and start using the webtrader.

    Its been a long time since I visited this site on OWB, so in general there have been an improvenment in OWB on this page.
    Before I could not see the online graph at all. Now the graph is loading, and is shown. But then the memory in use gauge starts to fill and OWB is meditating.
    I can quit OWB, but the memory doesnt return, so I need to reboot.

    [ Edited by amyren 09.09.2011 - 13:12 ]
  • »09.09.11 - 12:11
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Stevo
    Posts: 888 from 2004/1/24
    From: #AmigaZeux
    Not sure if it helps, but the site seems to work for me without any problems. Mind you, didn't log in or anything. OWB 1.14 on a Peg2.
    ---
    http://www.iki.fi/sintonen/logs/its_only_football.txt
  • »11.09.11 - 00:37
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    dIGIMAN
    Posts: 273 from 2005/11/7
    I get forwared to a subfolder (/de/), everything works without logging in.
  • »11.09.11 - 07:22
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    amyren
    Posts: 219 from 2010/5/15
    From: Norway
    Thanks for the reply. But I guess what you have been to is only the front page.
    Its when you start the webtrader and the dynamic graphs are being loaded thet the memory usage starts.
    I think you need to be logged in with a real or a demo account to see them.
  • »11.09.11 - 20:10
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Motosampy
    Posts: 199 from 2004/8/14
    From: Järvenp&a...
    I confirm this issue. Registered and signed in and once the graphs are loaded OWB starts to eat memory and at some point meditates. Could it be a javascript issue (infinite loop ?) ?

    OWB 1.14 , MorphOS 2.7, PowerMac MDD 2xG4 @ 867MHz
  • »11.09.11 - 21:03
    Profile
  • Fab
  • MorphOS Developer
    Fab
    Posts: 1331 from 2003/6/16
    So i gave it a try, and it's not an OWB issue (if it was, you would see a specific out of memory requester, anyway).

    These graphs actually use Flash, and it must be a bug in swfdec (which won't be fixed, unfortunately, since swfdec is dead). If you disable plugins for the page (or globally, whatever), the graph doesn't load and there's no such behaviour.
  • »14.09.11 - 01:56
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    amyren
    Posts: 219 from 2010/5/15
    From: Norway
    Ok, thanks.
    Its a pity swfdec is dead though, since this is very close to working and probably is a minor bug.
  • »15.09.11 - 14:02
    Profile