Setup Wacom Intuos Tablets
  • Order of the Butterfly
    Order of the Butterfly
    Yomgui
    Posts: 348 from 2004/8/31
    From: Québec - Canada
    Good news to all lucky Wacom Intuos tablet owners!
    After spending some time on the weird HID.class configuration action window,
    I've succeed to autamically setup these wacom tablets to act in tablet mode (pressure, tilt, ....) than just in 'mouse' mode.

    This setting acts as my Wacom fix program I was done in 2009.

    Now the trick:
    1) Open the System Settings window, and go into USB devices setttings.
    2) Select the "Devices" item in the left list, then search for your tablet in the right list
    => for me (Intuos3) it's named "PTZ-631W"
    3) double click on this device to open its Information window.
    4) In the information window, double click on the interface assigned to the Mouse/hid.class.
    5) A HID.class configuration window appears, select the 'Action' tab on top.
    6) Select the "[Extra]" item in "Repports and collections" list and configure the "Inital startup actions" item (right list) like this picture:

    wacom_hid_poseidon.jpg

    (Note: the "Array values" string box is "2,2" and the Operation is not 'Set' as written in the image, but 'Assign')

    7) save and it's done.

    Important note:
    After some tests yesterday, it seems that the HID.class is bugged, using always the same Array values on some other features, I've got errors messages indicates various array data len! And the data assigned is always 1!
    So my config works or not depending on some strange conditions...



    [ Edited by Yomgui on 2011/1/7 10:26 ]
    And now... next project!
  • »04.01.11 - 23:54
    Profile Visit Website
  • rms
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    rms
    Posts: 595 from 2004/11/27
    Hi Yomgui, thanks for this info, I did do the settings and tested with Gribouills but it seems not to work for me :-(

    I checked twice my settings vs yours and they seem to be the same! What else could be the problem? Ah, btw, I use the same tablett as you.
  • »05.01.11 - 05:36
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    Yomgui
    Posts: 348 from 2004/8/31
    From: Québec - Canada
    Don't know... try to remove all device settings saved for this tablet into Poseidon, then reconfigure.

    There are no spaces between the two, the comma and the second two.
    I've not set anything else.
    And now... next project!
  • »05.01.11 - 07:27
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    Yomgui
    Posts: 348 from 2004/8/31
    From: Québec - Canada
    This is my poseidon setting used for my Wacom intuos3 A5 Wide.
    Can be imported directly from poseidon Config item.

    Intuos3 A5 Wide Poseidon Config


    [ Edited by Yomgui on 2011/1/5 18:22 ]
    And now... next project!
  • »05.01.11 - 16:22
    Profile Visit Website
  • Just looking around
    amiga23
    Posts: 13 from 2014/5/5
    I'm trying to setup an Wacom Intuos pen & touch small CTH-480.

    Poseidon detects it as HID device, but neither touch nor pen seem to do anything.

    Yomgui's domain seems to be deleted, so I have no clue what do configure in the HID Settings.

    Is it possible to get this tablet to work on MorphOS? Will it work with ArtEffect?

    Could someone please help me with the settings?
  • »21.06.14 - 20:48
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Yomgui
    Posts: 348 from 2004/8/31
    From: Québec - Canada
    Quote:

    amiga23 wrote:
    I'm trying to setup an Wacom Intuos pen & touch small CTH-480.

    Poseidon detects it as HID device, but neither touch nor pen seem to do anything.

    Yomgui's domain seems to be deleted, so I have no clue what do configure in the HID Settings.

    Is it possible to get this tablet to work on MorphOS? Will it work with ArtEffect?

    Could someone please help me with the settings?


    Can you try this: http://yellowblue.free.fr/projects/WacomFix.elf
    And now... next project!
  • »25.06.14 - 17:13
    Profile Visit Website
  • Just looking around
    amiga23
    Posts: 13 from 2014/5/5
    Hi Yomgui, thanks for your help and the work you invested in wacom tablets.

    WacomFix.elf detects the tablet and gives the following output;
    Code:

    Wacom HID (Mouse) device found: VID/DID = 056a-0302, Name: 'Intuos PTS'
    Current Tablet Mode: 0
    Reset tablet mode...
    New Tablet Mode OK


    ArtEffect shows "Tableau: Intuos" in settings after running "WacomFix.elf".

    But Nothing happens if I use the a finger are the pen.

    Are there any additional settings necessary?
  • »26.06.14 - 18:21
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Yomgui
    Posts: 348 from 2004/8/31
    From: Québec - Canada
    Quote:

    amiga23 wrote:
    Hi Yomgui, thanks for your help and the work you invested in wacom tablets.

    WacomFix.elf detects the tablet and gives the following output;
    Code:

    Wacom HID (Mouse) device found: VID/DID = 056a-0302, Name: 'Intuos PTS'
    Current Tablet Mode: 0
    Reset tablet mode...
    New Tablet Mode OK


    ArtEffect shows "Tableau: Intuos" in settings after running "WacomFix.elf".

    But Nothing happens if I use the a finger are the pen.

    Are there any additional settings necessary?



    In MorphOS USB preferences, you can setup various bindings under your device.
    And now... next project!
  • »27.06.14 - 14:42
    Profile Visit Website