Fab did it again - OWB 1.11 released
  • Fab
  • MorphOS Developer
    Fab
    Posts: 1331 from 2003/6/16
    @stephen

    No, flash hasn't been improved. Swfdec compatibility will be more and more obsolete as time goes, since the project is dead.

    The only area where it could improve a bit would be speed (recompiling it with more recent cairo/pixman versions, and possibly hw accel someday).

    In the long term, as i think i already said a couple times, another candidate for Flash would be lightspark, or maybe even gnash if it gets significantly better than swfdec.

    [ Edited by Fab on 2010/11/8 8:19 ]
  • »08.11.10 - 00:02
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    magnetic
    Posts: 2129 from 2003/3/1
    From: Los Angeles
    You rock fab!

    Thanks alot man. Nice improvements feels faster. Youtube experience much improved

    i'm getting 40% cpu @ 720p hd in overlay mode! There is a little stutter though.. if I do other tasks though not usable really... any help on improving speed?
    Pegasos 2 Rev 2B3 w/ Freescale 7447 "G4" @ 1ghz / 1gb Nanya Ram
    Quad Boot: MorphOS 2.7 | Amiga OS4.1 U4 | Ubuntu PPC GNU/Linux | OS X 10.4
  • »08.11.10 - 05:25
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    vulture
    Posts: 189 from 2008/2/4
    From: Greece
    What can I say? Fab rules! :)
  • »08.11.10 - 07:29
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 12075 from 2003/5/22
    From: Germany
    > i'm getting 40% cpu @ 720p hd in overlay mode!

    On the 1.0 GHz G4 from your signature? With H264 on Youtube?
  • »08.11.10 - 07:55
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    magnetic
    Posts: 2129 from 2003/3/1
    From: Los Angeles
    dont know about h264 but was watching The History Channel "ancient aliens" in HD 720 setting!
    Pegasos 2 Rev 2B3 w/ Freescale 7447 "G4" @ 1ghz / 1gb Nanya Ram
    Quad Boot: MorphOS 2.7 | Amiga OS4.1 U4 | Ubuntu PPC GNU/Linux | OS X 10.4
  • »08.11.10 - 09:48
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 12075 from 2003/5/22
    From: Germany
    > dont know about h264 but was watching The History Channel
    > "ancient aliens" in HD 720 setting!

    Unfortunately you didn't answer if it was on Youtube or elsewhere. On Youtube it would be MP4/H264 (or the even more demanding WebM/VP8).
  • »08.11.10 - 10:08
    Profile
  • Paladin of the Pegasos
    Paladin of the Pegasos
    pampers
    Posts: 1061 from 2009/2/26
    From: Tczew, Poland
    I've got the felling that browsing is way faster than it was before!

    Fab is there any chance to fix the progress indicator on gmail when adding attachement?
    MorphOS 3.x
  • »08.11.10 - 12:06
    Profile Visit Website
  • MorphOS Developer
    Krashan
    Posts: 1107 from 2003/6/11
    From: Białystok...
    If you experience slow page loading (not OWB loading), check the size of conf/webpageIcons.db file. It grown up to 20 MB on my Pegasos. After I deleted it, pages load much faster.

    [ Edited by Krashan on 2010/11/8 13:08 ]
  • »08.11.10 - 13:08
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 12075 from 2003/5/22
    From: Germany
    > dont know about h264 but was watching The History Channel
    > "ancient aliens" in HD 720 setting!

    I just tried with OWB 1.11 and noticed that H264 videos at 720p still bring my 1.5 GHz G4 to its knees. Could you give a link to that History Channel video?
  • »08.11.10 - 15:36
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 12075 from 2003/5/22
    From: Germany
    With OWB 1.11 I have problems with typeface. For instance here on MorphZone, hyperlinks are not boldfaced any more. They were with OWB 1.10. Can anyone confirm?
  • »08.11.10 - 15:40
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    DoctorMorbius_FP
    Posts: 315 from 2004/2/14
    From: Naples - Italy
    @ Andreas_Wolf

    >With OWB 1.11 I have problems with typeface.
    > For instance here on MorphZone, hyperlinks are not boldfaced any more.
    > They were with OWB 1.10. Can anyone confirm?

    Yes, I confirm.
    Powered by PegasosII-G4, MacMini, PowerMac MDD.
  • »08.11.10 - 20:33
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 12075 from 2003/5/22
    From: Germany
    > Yes, I confirm.

    Thanks. Now we have to wait for Fab to come in I guess :-)
  • »08.11.10 - 20:52
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    takemehomegrandma
    Posts: 2720 from 2003/2/24
    Time to re-open the renaming discussion! :-)

    I have a few suggestions for a starter:

    "Papillon" - Meaning butterfly in French, sounding exotic to all other languages. Also highlighting the browsers French heritage (through Fab). Butterflies travels freely, going wherever they want!

    "Papilio" - Meaning butterfly in Esperanto, sounding exotic to all other languages. Perhaps easier to pronounce correctly than the French word?

    "Rastafari" - a nudge towards its "Safari" webkit sister browser, but in a way reflecting the non-mainstream path of MorphOS. Rastafaris are going places as well, they travel light (and high)! :-P ;-)

    "Aminda" - I was looking in the Esperanto dictionary for "Amiga" just for fun, and a few lines down I found this nice-sounding word, easily pronounced by most nationalities, meaning "lovable".
    MorphOS is Amiga done right! :-)
    MorphOS NG will be AROS done right! :-)
  • »09.11.10 - 07:53
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    bash64
    Posts: 934 from 2010/10/29
    From: USA
    Is there a section in the docs for using YouTube?
    Confused over what to check/uncheck.
    Powerbook G4 1.67ghz 2GB, ATI 9700M Pro 128mb
    1TB hd, DL-DVD Burner, Netgear pcmcia wireless card.
    Powermac G5 2.3ghz 2GB, ATI 9600 Pro
    ImageFX 4.5, PageStream 3.3, PhotoGenics 5.0
  • »09.11.10 - 10:48
    Profile Visit Website
  • Butterfly
    Butterfly
    Mabo
    Posts: 67 from 2010/5/3
    Fab rock!

    Thanks :)
  • »09.11.10 - 16:43
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    xyphoid
    Posts: 870 from 2008/7/11
    From: Delaware, USA
    "Rastafari" Also A Dread in certain cultures (Jamaican)but I likes too.
  • »09.11.10 - 17:13
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    xyphoid
    Posts: 870 from 2008/7/11
    From: Delaware, USA
    uh oo, seems to have a severe mem leak! I left it up all night, while working on google docs, and a few other pages, and came back to 5mb mem and a requestor regarding webkit not checking for min mem and will crash or something. It then meditated and I rebooted.
  • »09.11.10 - 21:32
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    amigadave
    Posts: 2794 from 2006/3/21
    From: Northern Calif...
    Quote:


    takemehomegrandma wrote:
    Time to re-open the renaming discussion! :-)

    I have a few suggestions for a starter:

    "Papillon" - Meaning butterfly in French, sounding exotic to all other languages. Also highlighting the browsers French heritage (through Fab). Butterflies travels freely, going wherever they want!

    "Papilio" - Meaning butterfly in Esperanto, sounding exotic to all other languages. Perhaps easier to pronounce correctly than the French word?

    "Rastafari" - a nudge towards its "Safari" webkit sister browser, but in a way reflecting the non-mainstream path of MorphOS. Rastafaris are going places as well, they travel light (and high)! :-P ;-)

    "Aminda" - I was looking in the Esperanto dictionary for "Amiga" just for fun, and a few lines down I found this nice-sounding word, easily pronounced by most nationalities, meaning "lovable".


    I like Papillon, good first choice and I think others have mentioned it as well.
    MorphOS - The best Next Gen Amiga choice.
  • »09.11.10 - 22:03
    Profile
  • Fab
  • MorphOS Developer
    Fab
    Posts: 1331 from 2003/6/16
    @xyphoid

    Try to be more precise and isolate the exact page causing the leak.
    I tried on google docs with some random document, and it doesn't leak so far (even when active with cursor blinking). But in any case, it would be a generic webkit bug. :)

    [ Edited by Fab on 2010/11/9 22:17 ]
  • »09.11.10 - 22:16
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 12075 from 2003/5/22
    From: Germany
    > dont know about h264 but was watching The History Channel
    > "ancient aliens" in HD 720 setting!

    I just came across this posting of yours:

    http://amigaworld.net/modules/newbb/viewtopic.php?topic_id=32700&forum=28#588412

    There you say it's on Youtube. Thus I conclude it must be MP4/H264. It's really hard for me to believe you have only 40% CPU load on this with your 1.0 GHz G4. So may I once more ask you to provide a link to that specific video so that others can compare?
  • »11.11.10 - 00:42
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    magnetic
    Posts: 2129 from 2003/3/1
    From: Los Angeles
    Andreas

    This is the 3rd time you have asked me this. Dont really be a bot man. Look, i'm in San Fransico all week until Friday. When I get back to my studio I'll fire up the peg and report it...

    Look, It was late at night, I just installed owb 1.11 and was testing youtube.. I went to a doc on Ancient Aliens and could have sworn I chose 720p "hd" mode on youtube.. maybe it was 480p hd? dont know take it easy and i'll report back. Note I said 40% cpu but I really couldnt move the mouse at all or the vid would almost freeze... from what I remember..
    Pegasos 2 Rev 2B3 w/ Freescale 7447 "G4" @ 1ghz / 1gb Nanya Ram
    Quad Boot: MorphOS 2.7 | Amiga OS4.1 U4 | Ubuntu PPC GNU/Linux | OS X 10.4
  • »11.11.10 - 02:59
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 12075 from 2003/5/22
    From: Germany
    > This is the 3rd time you have asked me this.

    No, count again. It's only the 2nd time I asked you for the link to that video. And the reasons for asking a 2nd time have been that you ignored my question the 1st time and that I stumbled upon your amigaworld.net message containing some information you (despite me asking for it) omitted here (i.e. that it was on Youtube).

    > Dont really be a bot man.

    It's rather you who seem to have become a bot, programmed to call me a bot all along against all sanity and regardless of the specific situation :-P

    > When I get back to my studio I'll fire up the peg and report it

    I don't think you need your Pegasos to post the link to that History Channel video ;-)

    > maybe it was 480p hd?

    480p wouldn't be HD.

    > i'll report back.

    Looking forward to it.

    > I said 40% cpu but I really couldnt move the mouse at all or the
    > vid would almost freeze

    Sounds really strange, and thus would be in perfect line with a 1.0 GHz G4 being able to play H264 at 720p in realtime ;-)
  • »11.11.10 - 14:36
    Profile
  • Caterpillar
    Caterpillar
    jvdbossc
    Posts: 25 from 2010/9/17
    It is faster - even the emo icons on the left to use in this post are there a lot quicker. Nice it takes away some frustration.

    It feels more like the os - fast.

    Noticed still a few issues. (like in google after long working time, I get where it should read like "images" I get only some blocks.

    But hey, it's moving ahead !
  • »11.11.10 - 20:25
    Profile
  • Caterpillar
    Caterpillar
    jvdbossc
    Posts: 25 from 2010/9/17
    like this - i think it is while logged in to gmail: समूह
  • »11.11.10 - 20:27
    Profile