ANR update?
  • Paladin of the Pegasos
    Paladin of the Pegasos
    pampers
    Posts: 1058 from 2009/2/26
    From: Tczew, Poland
    I'm just wondering is there any update on that great piece of software called AmiNetRadio? I think there was some kind of updates by one of the MOSZone members at some stage (Andreas will probably come with some links :) stating that there is some work done on ANR.

    I would really like to see that great app being updated..
    MorphOS 3.x
  • »13.03.10 - 00:28
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 10926 from 2003/5/22
    From: Germany
    > is there any update on that great piece of software called AmiNetRadio? I think there was
    > some kind of updates by one of the MOSZone members at some stage (Andreas will
    > probably come with some links :) stating that there is some work done on ANR.

    The most recent unofficial version that was accessible via an unofficial link here on MZ that I know of is v5.9221 dating August 2008.

    See:
    https://morph.zone/modules/newbb_plus/viewtopic.php?topic_id=6388&forum=3#64527
  • »13.03.10 - 01:04
    Profile
  • Cocoon
    Cocoon
    jalla
    Posts: 57 from 2004/10/4
    From: Norway
    It's a great pice of software indeed. Anyone knows if it exists players for MED (octamed modules) and SID (c64 modules) for it ? If not, that would be my request for a next release. That would just make it complete :) One application for "all" soundformats.

    It does even play midi's with the geronto library (and the instruments package).
    A great thanks to the guys in #AmigaZeux for ANR!

    Another little improvement I could request it the option to load and play more than one song
    without entering the playlist function. (create a temporary playlist on the fly).
    ------------------------------------------------------
    Pegasos II/G4/512MB/Radeon9200
    ------------------------------------------------------
  • »13.03.10 - 05:12
    Profile
  • rms
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    rms
    Posts: 585 from 2004/11/27
    Hi,

    is this version available somewhere in order to test it? Would be really great to have un update by now.
  • »13.03.10 - 10:00
    Profile Visit Website
  • Paladin of the Pegasos
    Paladin of the Pegasos
    SoundSquare
    Posts: 1207 from 2004/12/1
    From: Paris, France
    instead of asking for an upgrade (which doesn't mean anything) you should better make a feature request, if there's something ANR doesn't do and you would like it to do. Otherwise, i'm sure it shouldn't be too much work to increase the version number to please you : )

    The only thing i miss with ANR is a shoutcast/icecast plugin to stream music to my shoutcast server. That would definately make MorphOS my radio station OS : )
  • »13.03.10 - 11:09
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    kriz
    Posts: 245 from 2005/10/18
    From: No(R)way
    Maybe someone else experience this with ANR: When playing(files or streams) it sometime stutter, just halfsecond then playing again.. I have tried with AmigaAmp (68k version) and that always plays it fine... Just me ? Experienced this on peg2 mos1.4->2 and now on mac mini 2.4...
    -- Amiga 1200/4000 - Pegasos2 - MacMiniG4 / PowerBookG4 -- Horrordelic Records - Darkpsy Psychedelic Label - Based in Norway (Hell) --
  • »13.03.10 - 13:20
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    AmigaMancer
    Posts: 265 from 2005/8/25
    Quote:

    instead of asking for an upgrade (which doesn't mean anything) you should better make a feature request, if there's something ANR doesn't do and you would like it to do. Otherwise, i'm sure it shouldn't be too much work to increase the version number to please you : )

    I'm not sure iirc. I think that there was a problem with searching for streams. It ceased to work at some point.

    Edit: Oh, nevermind about this:
    https://morph.zone/modules/newbb_plus/viewtopic.php?topic_id=6962&forum=9

    Quote:

    Maybe someone else experience this with ANR: When playing(files or streams) it
    sometime stutter, just halfsecond then playing again.. I have tried with AmigaAmp (68k version) and that always plays it fine... Just me ? Experienced this on peg2 mos1.4->2 and now on mac mini 2.4...

    I experience the same thing under AmigaOS while listening to streams and do anything that draws even the slightest amount of CPU. I know that this isn't hardware related, as my CPU and internet speed are fast enough for mp3 streaming. I have tried to tweak the settings, but it didn't help.

    [ Edited by AmigaMancer on 2010/3/15 7:10 ]
    Amiga 1200 user.
  • »15.03.10 - 03:07
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    kriz
    Posts: 245 from 2005/10/18
    From: No(R)way
    Yes, but with mplayer or amigaamp none of these skips occurs.. Nobody else than me and AmigaMancer who have this issue ?
    -- Amiga 1200/4000 - Pegasos2 - MacMiniG4 / PowerBookG4 -- Horrordelic Records - Darkpsy Psychedelic Label - Based in Norway (Hell) --
  • »15.03.10 - 10:09
    Profile Visit Website
  • Butterfly
    Butterfly
    Condor
    Posts: 89 from 2005/9/1
    From: Zagreb/Croatia
    Quote:


    kriz wrote:
    .. Nobody else than me and AmigaMancer who have this issue ?


    Hy
    I also have this problem with ANR on my MacMini with registred Mos2.4.
    It sometime stutter also with modules, not mp3 only. MPlayer and SongPlayer stutter sometime for half sec also.
    Playing same mp3 files with AmigaAmp(68k)/Amplifier(68k) is perfect.
    I don't know how to solve this problem, (maybe is audio.device/ahi problem or only MacMini port related, i don't know??).
  • »21.04.10 - 13:48
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    xyphoid
    Posts: 870 from 2008/7/11
    From: Delaware, USA
    As far as features I again would like art work display of song. ( like rythmnbox....or itune) ;-)
  • »21.04.10 - 23:02
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2008 from 2003/3/5
    From: Canada
    @ Condor

    You should probably raise the decoder task priority. It's done using the DP tooltype (refer to the ANR guide).
  • »22.04.10 - 06:58
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    dIGIMAN
    Posts: 273 from 2005/11/7
    I have this shuttering too, even with songplayer sometimes.

    I didnt have shuttering with songplayer on my A4K.
  • »22.04.10 - 11:00
    Profile Visit Website
  • Butterfly
    Butterfly
    Condor
    Posts: 89 from 2005/9/1
    From: Zagreb/Croatia
    Quote:


    jacadcaps wrote:
    @ Condor

    You should probably raise the decoder task priority. It's done using the DP tooltype (refer to the ANR guide).


    Ok, thanks, I will try that, but its strange that even mod-files stutter from time to time (and I run only ANR, nothing more, without any visual effect or background task).
  • »22.04.10 - 11:31
    Profile
  • Paladin of the Pegasos
    Paladin of the Pegasos
    jcmarcos
    Posts: 1178 from 2003/3/13
    From: Pinto, Madrid ...
    Funny those modules played perfectly on a 7.16 Mhz computer... :-D
  • »22.04.10 - 13:32
    Profile
  • Butterfly
    Butterfly
    Condor
    Posts: 89 from 2005/9/1
    From: Zagreb/Croatia
    After more testing with priority and ANR, and playing mp3 files with SongPlayer, ANR, AmigaAmp, Amplifier, MPlayer, Kaya player, and with default Mos player I found that skiping in ALL players. This is not only ANR related problem. Some players skip more, some less (68k) and I think this is a problem with ahi/audio/memory/task in Mos.

    I really like Mos on my MacMini (have also 9 classic Amigas and Efika board), but this problem drive me nuts. I need help to fix this or confirm that this is known problem and maybe update will fix this. Thank You.
  • »23.04.10 - 06:08
    Profile
  • Just looking around
    Jason
    Posts: 14 from 2009/11/6
    I'm glad I found this thread. I thought my mac mini was having hardware problems.

    Playing audio with ANR causes all sorts of problems and cpu spiking. After playing music for a while with ANR the whole system comes to a crawl. Moving windows causes graphical glitches, copyinf files causes weird stuttering and lockups, etc.

    All of these issues only occur after playing audio in ANR; the issues, too, are permanent. Playing audio in ANR basically hoses the system in some weird way until reboot.

    MPlayer seems to work alright and doesn't cause these problems.

    Mac Mini 1.5ghz, 1gig ram, 64mb vram


    [ Edited by Jason on 2010/4/29 23:50 ]
  • »30.04.10 - 03:50
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    xyphoid
    Posts: 870 from 2008/7/11
    From: Delaware, USA
    wow! no such issues here, though I mostly play mp3 radio. It's weird how different macmini's perform differently under morphos....then again, the classic amigas did too.
    Anyway I'll give it a 1hr run on ANR
  • »30.04.10 - 04:29
    Profile
  • Fab
  • MorphOS Developer
    Fab
    Posts: 1331 from 2003/6/16
    @Condor

    No idea about ANR (as it might heavily depend on the version, too), but it's clearly not normal to get sound issue with other players, at least (providing debug log might really give a hint at what's going on).
  • »30.04.10 - 13:16
    Profile Visit Website
  • Butterfly
    Butterfly
    Condor
    Posts: 89 from 2005/9/1
    From: Zagreb/Croatia
    Strange, but 5 days everything works just perfect, i play mp3 with ANR + 4 visual effects and MPlayer play some movie (without sound ;-)) in same time and sound is just perfect. I was happy, my problem is gone, but 2 days later stuttering starts again. Debug log don't write anything during this sound skiping.Why is everything superb for 5 days and after that sound problem is back. (I didn't change anything, just normal Mos boot and start ANR every time).
    I use audio jack to conect audio to my LG TV (which have VGA+audio input). This way I have volume control via remote. I didn't test Mac internal speaker.
  • »10.05.10 - 06:23
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Crumb
    Posts: 706 from 2003/2/24
    From: aGaS & CUAZ Al...
    @Condor

    perhaps some internal buffer should be aligned to get optimal performance and the code doesn't take care of that. :-P
  • »10.05.10 - 16:26
    Profile Visit Website