Wayfarer läßt sich nicht starten
  • Butterfly
    Butterfly
    ThorstenS
    Posts: 64 from 2014/1/20
    Wayfarer - sowohl die Version die sich auf der MorphOS 3.18 CD befindet, als auch die Version 7.3 von der Webseite - läßt sich nicht starten. Der Request zeigt, dass die openssl3.library Version 5 bzw. 6 benötigt wird.

    Version 5 zeigt er mir bei Wayfarer 7.3 an. Version 6 bei der von der MorphOS 3.18 CD.

    Installiert ist, die openssl3.library Version 7 (openssl3.library - May 2023 Hotfix for MorphOS 3.18) von der MorphOS-Webseite.


    English:
    Wayfarer - both the version on the MorphOS 3.18 CD and the version 7.3 from the website - cannot be started. The request shows that openssl3.library version 5 or 6 is required.

    Version 5 is shown for Wayfarer 7.3. Version 6 for the MorphOS 3.18 CD.

    Installed is the openssl3.library version 7 (openssl3.library - May 2023 Hotfix for MorphOS 3.18) from the MorphOS website.

    [ Editiert durch ThorstenS 27.02.2024 - 16:02 ]
  • »27.02.24 - 12:00
    Profile
  • Paladin of the Pegasos
    Paladin of the Pegasos
    Amigaharry2
    Posts: 1224 from 2010/1/6
    From: EU-Austria (Wien)
    Wirf einmal dei MUI-Prefs raus:

    Lösche (oder benenne sie um): System:Prefs/Env-Archive/MUI/WAYFARER.prefs

    und mach danach sofort einen Reboot.

    Edit: Fast vergessen: Ich habe dieselbe library installiert

    [ Editiert durch Amigaharry2 27.02.2024 - 15:45 ]
  • »27.02.24 - 15:42
    Profile
  • Butterfly
    Butterfly
    ThorstenS
    Posts: 64 from 2014/1/20
    Quote:

    Amigaharry2 schrieb:
    Lösche (oder benenne sie um): System:Prefs/Env-Archive/MUI/WAYFARER.prefs


    Die WAYFARER.prefs ist - nicht - vorhanden, siehe:
    Abb. 1

    Im Hintergrund starte ich gerade Wayfarer 7.3 und erhalte die entsprechende Fehlermeldung.
    Interessanterweise fordert die Wayfarer-Version von der MorphOS 3.18 CD - ich habe jetzt auch mal die Versionsabfrage gemacht, es ist die Version 7.1 - die etwas neuere Version 6 der openssl.library.

    Allerdings und überhaupt... kann alles auch damit zusammenhängen (eventuell), dass ich das Ganze hier unter einer Emulation (qemu) betreibe. Vielleicht also ist hier irgendwas nicht kompatibel.

    English:
    he WAYFARER.prefs is - not - available, see: Fig. 1
    I am currently starting Wayfarer 7.3 in the background and receive the corresponding error message. Interestingly, the Wayfarer version from the MorphOS 3.18 CD - I have now also done the version query, it is version 7.1 - requires the slightly newer version 6 of the openssl.library. However, and in general... everything can (possibly) have something to do with the fact that I'm running the whole thing here under an emulation (qemu). So maybe something is not compatible here.

    [ Editiert durch ThorstenS 27.02.2024 - 15:59 ]
  • »27.02.24 - 15:54
    Profile
  • Paladin of the Pegasos
    Paladin of the Pegasos
    Amigaharry2
    Posts: 1224 from 2010/1/6
    From: EU-Austria (Wien)
    Die MUI-Prefs müssen normal existieren und sie sind oft für seltsamste Fehlermeldungen verantwortlich.

    Was aber sein kann: Wo hast du denn die neue openssl.library installiert? In sys:LIBS oder MOSSYS:LiIBS?
  • »27.02.24 - 18:42
    Profile
  • Butterfly
    Butterfly
    ThorstenS
    Posts: 64 from 2014/1/20
    Die Library habe ich in MOSSYS:LIBS installiert, wo eine alte Version ersetzt wurde.

    Ein unerhört interessantes Problem...

    English:
    I installed the library in MOSSYS:LIBS, where an old version was replaced. An incredibly interesting problem...
  • »27.02.24 - 19:08
    Profile
  • Paladin of the Pegasos
    Paladin of the Pegasos
    Amigaharry2
    Posts: 1224 from 2010/1/6
    From: EU-Austria (Wien)
    Und in Sys:Libs ist nicht vielleicht noch eine alte Version?
  • »27.02.24 - 22:40
    Profile
  • Butterfly
    Butterfly
    ThorstenS
    Posts: 64 from 2014/1/20
    Dieser Ordner ist komplett leer.

    Ich werde nachher mal "Scout" mitlaufen lassen. Vielleicht hat das Problem einen anderen Ursprung.

    English:
    This folder is completely empty. I'll let "Scout" run along later. Maybe the problem has another origin.
  • »28.02.24 - 05:40
    Profile
  • Paladin of the Pegasos
    Paladin of the Pegasos
    Amigaharry2
    Posts: 1224 from 2010/1/6
    From: EU-Austria (Wien)
    Schau dir auch die Protection-Bits an - das hat mich bei was ähnlichem beinahe zur Weißglut gebracht....
  • »28.02.24 - 08:34
    Profile
  • Butterfly
    Butterfly
    ThorstenS
    Posts: 64 from 2014/1/20
    Hat MorphOS ein Programm an Bord mit dem ich testen kann, ob eine Internetverbindung besteht?

    Ich habe in Verdacht, dass es mit der Internetverbindung zusammenhängt, das Wayfarer nicht starten möchte.
    Das gleiche Problem habe ich nämlich auch bei IRIS und dem MorphOS Registrierungstool...
  • »28.02.24 - 11:44
    Profile
  • MorphOS Developer
    geit
    Posts: 1031 from 2004/9/23
    Ping vielleicht?
  • »28.02.24 - 12:00
    Profile
  • Butterfly
    Butterfly
    ThorstenS
    Posts: 64 from 2014/1/20
    Habe ping ausprobiert. Hier bekomme ich jedoch den Hinweis, dass die bsdsocket.library benötigt wird.

    Auf folgender QEMU-Seite steht allerdings:
    "Hinweis: Wenn Sie das (Standard-)SLiRP-Benutzernetzwerk verwenden, funktioniert Ping (ICMP) nicht, TCP und UDP jedoch. Versuchen Sie nicht, Ping zum Testen Ihrer QEMU-Netzwerkkonfiguration zu verwenden! "
    https://wiki.qemu.org/Documentation/Networking

    Ich kontrolliere jetzt mal die genauen Einstellungen um QEMU mit dem Internet verbinden zu können...

    Aktuell nutze ich folgenden Aufruf dazu: Code:
    -device rtl8139,netdev=net0 -netdev user,id=net0


    ENGLISH:
    I tried ping. However, here I get the message that the bsdsocket.library is required. However, the following QEMU page says: "Note: If you are using the (standard) SLiRP user network, Ping (ICMP) will not work, but TCP and UDP will. Do not attempt to use Ping to test your QEMU network configuration!" I'm now checking the exact settings to be able to connect QEMU to the Internet... I'm currently using the following call: Code:
    -device rtl8139,netdev=net0 -netdev user,id=net0

    https://wiki.qemu.org/Documentation/Networking

    [ Editiert durch ThorstenS 28.02.2024 - 12:58 ]
  • »28.02.24 - 12:57
    Profile
  • Butterfly
    Butterfly
    ThorstenS
    Posts: 64 from 2014/1/20
    Es schaut in der Tat so aus, als dass das Problem an einer fehlenden Internetverbindung liegt !

    In den PREFS wird mir zwar die RTL8139 Netzwerkkarte angezeigt und auch als aktiv angezeigt. Öffne ich allerdings den Netzwerkmonitor ist dort tote Hose. Auch wird mir dort die Netzwerkkarte nicht angezeigt und auch sonst sind keine Bewegungen ersichtlich.

    Habe es auch testweise mit dem RTL8029 (-device ne2k_pci) Netzwerkadapter probiert. Ebenfalls ohne Erfolg.

    Nun bin ich etwas ratlos und frage mich, wo das Problem liegt. An QEMU wohl weniger, da die Roten mit deren OS ja mittels der emulierten RTL8139 Netzwerkkarte ins Internet gehen können.

    ENGLISH:
    It actually looks like the problem is due to a lack of internet connection! The RTL8139 network card is shown to me in the PREFS and is also shown as active. However, when I open the network monitor, it's dead. The network card is also not displayed there and no other movements are visible. I also tried it as a test with the RTL8029 (-device ne2k_pci) network adapter. Also without success. Now I'm a bit at a loss and wondering what the problem is. Probably less so with QEMU, since the red ones with their OS can access the Internet using the emulated RTL8139 network card.
  • »28.02.24 - 13:37
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2971 from 2003/3/5
    From: Canada
    If you are using QEmu, I strongly recommend emulating a Mac and using -netdev user,id=mynet0 -device sungem,netdev=mynet0
  • »28.02.24 - 13:59
    Profile Visit Website
  • Cocoon
    Cocoon
    SkulleateR
    Posts: 43 from 2023/9/19
    Ist leider wohl ein Bug ...

    - Entweder mac99 Emulation mit Netzwerk aber ohne Sound
    - oder Peg2 Emulation ohne Netzwerk aber mit Sound

    hier gibts einen Workaround : https://osdn.net/projects/qmiga/ticket/48376

    Scheint sich auch noch auf die aktuellen QEMU Versionen zu beziehen, konnte ich bis hin zu 8.1.0 nachvollziehen, weiter habe ich nicht getestet ...
  • »28.02.24 - 18:10
    Profile
  • man
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    man
    Posts: 104 from 2019/11/11
    i have youtube.tv i think not working with amazonfirestick wih wayfarer 7.4
  • »28.02.24 - 19:13
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 12073 from 2003/5/22
    From: Germany
    > - Entweder mac99 Emulation mit Netzwerk aber ohne Sound
    > - oder Peg2 Emulation ohne Netzwerk aber mit Sound

    Wie ist der aktuelle Stand der Sam460-Emulation mit MorphOS?
  • »28.02.24 - 20:18
    Profile
  • Cocoon
    Cocoon
    SkulleateR
    Posts: 43 from 2023/9/19
    Quote:

    Andreas_Wolf schrieb:
    > - Entweder mac99 Emulation mit Netzwerk aber ohne Sound
    > - oder Peg2 Emulation ohne Netzwerk aber mit Sound

    Wie ist der aktuelle Stand der Sam460-Emulation mit MorphOS?


    Ok, DAS hab ich tatsächlich auch noch nicht getestet :-D Naja, der nächste Urlaub kommt bald ;-)
  • »28.02.24 - 23:30
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    DanicaTalos
    Posts: 397 from 2010/10/15
    From: 01101110011100...
    Nimm die Peg2 Installation.

    Dann, unter deiner MorphOS Installation:

    Move MorphOS/Devs/AudioModes/PEGASOS to MorphOS/Storage/AudioModes/PEGASOS
    Run AddAudioModes SYS:MorphOS/Storage/AudioModes/PEGASOS from user-network-startup

    Dadurch wird zuerst der Netzwerktreiber geladen (der dann auch funktioniert) und erst dann der Audio Treiber (der dann auch funktioniert).
  • »16.03.24 - 16:10
    Profile
  • Butterfly
    Butterfly
    ThorstenS
    Posts: 64 from 2014/1/20
    Quote:

    DanicaTalos schrieb:

    Move MorphOS/Devs/AudioModes/PEGASOS to MorphOS/Storage/AudioModes/PEGASOS
    Run AddAudioModes SYS:MorphOS/Storage/AudioModes/PEGASOS from user-network-startup



    Sehr cool!

    Das werde ich zeitnah ausprobieren. Internet UND Sound wäre schon fein.

    Sollte der Code nicht eher so sein?:
    Code:

    --user-network-startup--
    copy sys:MorphOS/Devs/AHI/pegasos.audio.org sys:MorphOS/Devs/AHI/pegasos.audio
    sys:MorphOS/C/AddAudioModes sys:MorphOS/Devs/AudioModes/PEGASOS
    delete sys:MorphOS/Devs/AHI/pegasos.audio


    Allerdings ist die Geschwindigkeit bei mir sehr zäh. Anders bspw. die Emulation von AmigaOS4 unter WinUAE/QEMU. Das läuft deutlich flotter, obwohl beides unter QEMU ausgeführt wird.

    Um kleinere Sachen zu testen, reicht die MorphOS-Emulation aber aus!

    [ Editiert durch ThorstenS 17.03.2024 - 12:35 ]
  • »17.03.24 - 07:38
    Profile
  • Cocoon
    Cocoon
    SkulleateR
    Posts: 43 from 2023/9/19
    Quote:

    ThorstenS schrieb:

    Allerdings ist die Geschwindigkeit bei mir sehr zäh. Anders bspw. die Emulation von AmigaOS4 unter WinUAE/QEMU. Das läuft deutlich flotter, obwohl beides unter QEMU ausgeführt wird.



    Liegt wohl daran, dass die neueren QEMU Versionen auf OS4 getrimmt wurden, vieles wurde a optimiert. AnpassungenVerbesserungen an der MOS Emulation gab es schon lange nicht mehr ...
  • »17.03.24 - 16:54
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 12073 from 2003/5/22
    From: Germany
    > AnpassungenVerbesserungen an der MOS Emulation
    > gab es schon lange nicht mehr ...

    QEMU enthält gar keine MorphOS-Emulation. Emuliert wird lediglich die jeweilige Hardware. Da die Emulation aber nicht absolut vollständig bzw. korrekt ist, kann es natürlich sein, dass so manche Unvollständigkeit bzw. so mancher Fehler die Lauffähigkeit von MorphOS mehr beeinträchtigt als die von OS4.
  • »17.03.24 - 21:19
    Profile
  • Butterfly
    Butterfly
    ThorstenS
    Posts: 64 from 2014/1/20
    Quote:

    DanicaTalos schrieb:
    Nimm die Peg2 Installation.

    Dann, unter deiner MorphOS Installation:

    Move MorphOS/Devs/AudioModes/PEGASOS to MorphOS/Storage/AudioModes/PEGASOS
    Run AddAudioModes SYS:MorphOS/Storage/AudioModes/PEGASOS from user-network-startup

    Dadurch wird zuerst der Netzwerktreiber geladen (der dann auch funktioniert) und erst dann der Audio Treiber (der dann auch funktioniert).


    Habe deinen Code in der PEG2-Emulation ausprobiert. Leider funktioniert das Internet nach wie vor nicht.
    Oder hast du dich mit der MAC99-Emulation vertan?

    Zur Erklärung:
    Die PEGASOS2-Emulation verfügt über Sound, aber kein Internet.
    Die MAC99-Emulation verfügt über Internet, aber kein Sound.
  • »18.03.24 - 08:33
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    DanicaTalos
    Posts: 397 from 2010/10/15
    From: 01101110011100...
    Quote:

    Habe deinen Code in der PEG2-Emulation ausprobiert. Leider funktioniert das Internet nach wie vor nicht.
    Oder hast du dich mit der MAC99-Emulation vertan?



    Ich habe die Peg2 Emulation. Du musst die "PEGASOS" Datei nach "Storage" verschieben.

    Anschließend kommt in die "user-network startup" wörtlich! :

    Run AddAudioModes SYS:MorphOS/Storage/AudioModes/PEGASOS

    Dies ist die einfache Methode. Du kannst auch die andere Methode testen, die hat aber bei mir nicht funktioniert.

    222b25684c

    [ Editiert durch DanicaTalos 18.03.2024 - 13:44 ]
  • »18.03.24 - 14:19
    Profile
  • Butterfly
    Butterfly
    ThorstenS
    Posts: 64 from 2014/1/20
    Quote:

    DanicaTalos schrieb:

    Ich habe die Peg2 Emulation. Du musst die "PEGASOS" Datei nach "Storage" verschieben.

    Anschließend kommt in die "user-network startup" wörtlich! :

    Run AddAudioModes SYS:MorphOS/Storage/AudioModes/PEGASOS

    Dies ist die einfache Methode. Du kannst auch die andere Methode testen, die hat aber bei mir nicht funktioniert.

    222b25684c


    DANKE!

    Mit diesem Aufruf funktioniert es jetzt. Sehr schön, Sound UND Internet... :-)

    Diesen Beitrag schreibe ich soeben mit Wayfarer 7.6 unter QEMU 8.1 und höre nebenbei in einem zweiten Tab den Audio-Streamingsender 90s90s. Für Audiostreaming empfehle ich: www.audials.com/live
  • »19.03.24 - 15:56
    Profile
  • MorphOS Developer
    geit
    Posts: 1031 from 2004/9/23
    Quote:

    ThorstenS wrote:

    Diesen Beitrag schreibe ich soeben mit Wayfarer 7.6 unter QEMU 8.1 und höre nebenbei in einem zweiten Tab den Audio-Streamingsender 90s90s. Für Audiostreaming empfehle ich: www.audials.com/live


    Ich empfehle dafür RNORadio. Eine coole Applikation für diese Aufgabe.
  • »21.03.24 - 01:14
    Profile