GPU Compatibility - what determines?
  • Just looking around
    Posts: 11 from 2016/2/19
    What determines whether a GPU will be supported?

    Does MOS whitelist the GPU chip itself or the configuration?

    https://www.techpowerup.com/gpu-specs/?architecture=R500&sort=generation

    There are many "different" chips but with same config of TMUs etc so effectively the same? OK, some differ with VRam being DDR, DDR2 or GDDR3 which I could understand could be an issue.

    MOS says it supports:
    ATI Radeon X1300 (no W3D)
    ATI Radeon X1300 Pro (no W3D)
    ATI Radeon X1550 (no W3D)
    ATI Radeon X1600 (no W3D)
    ATI Radeon X1600 Pro (no W3D)
    ATI Radeon X1800 (no W3D)
    ATI Radeon X1900 GT (no W3D)
    ATI Radeon X1950 XT (no W3D)
    ATI Radeon X1950 Pro (no W3D)

    But
    Radeon X1600 PRO & X1600 XT are same GPU, same memory type and size and same TMU etc config but X1600 XT isn't listed?

    And ATI being ATI means there are MANY different configs of X1600 Pro (DDR2 etc) to add to confusion

    Personally I am looking at a GDDR3 X1650 Pro to buy... its R535 but the config is same as "compatible" GPUs... No idea if it will work?
  • »31.05.22 - 09:12
    Profile
  • MorphOS Developer
    bigfoot
    Posts: 427 from 2003/4/11
    It's an oversight. An X1600 XT and X1650 Pro will both work. Happy GPU hunting :)
    I rarely log in to MorphZone which means that I often miss private messages sent on here. If you wish to contact me, please email me at [username]@asgaard.morphos-team.net, where [username] is my username here on MorphZone.
  • »31.05.22 - 09:30
    Profile Visit Website
  • Just looking around
    Amiga_Dave
    Posts: 6 from 2020/11/29
    -What about a flashed ATi X1900GT? I'm getting a white screen on MOS in my G5 (11,2)... Works fine with OSX Tiger & Sorbet Leopard.

    https://forums.macrumors.com/threads/radeon-x1900-g5-mac-edition-cheap-n-easy-flashing-guide.2308103/
    Amiga A500
    -Classic 520 '020
    -32GB CF, 8MB, 1MB Chip mod
    -Amiga OS 3.2.1

    PowerMac 5G DC 2.3Ghz (11,2)
    -12GB Ram/240GB SSD
    -Tiger 10.4.11 w/ OS9 Classic environment
    -Sorbet Leopard 10.5.9
    -Flashed ATi X1900 not MorphOS compatible
  • »06.06.22 - 18:16
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2720 from 2003/3/5
    From: Canada
    @Amiga_Dave

    Did you try the other output on the card? Still, no guarantees if it's a flashed card.
  • »06.06.22 - 20:17
    Profile Visit Website
  • Just looking around
    Amiga_Dave
    Posts: 6 from 2020/11/29
    Thank for the quick reply, yes I did and I even rebooted... I also posted some questions in MacRumors > MorphOS Thread...

    https://forums.macrumors.com/threads/the-morphos-thread.2294963/page-4?post=31148894#post-31148894

    "Flashed cards are hit and miss with MorphOS.
    With a clear emphasis on "miss"....."


    [ Edited by Amiga_Dave 08.06.2022 - 07:23 ]
    Amiga A500
    -Classic 520 '020
    -32GB CF, 8MB, 1MB Chip mod
    -Amiga OS 3.2.1

    PowerMac 5G DC 2.3Ghz (11,2)
    -12GB Ram/240GB SSD
    -Tiger 10.4.11 w/ OS9 Classic environment
    -Sorbet Leopard 10.5.9
    -Flashed ATi X1900 not MorphOS compatible
  • »06.06.22 - 20:20
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    amigadave
    Posts: 2793 from 2006/3/21
    From: Northern Calif...
    Just an FYI, I've been using the nickname AmigaDave since around 1987 on just about every Amiga related forum website, and many years here, so don't be surprised if several people in the overall Amiga community get confused and mistake you for me. I'm not writing this to influence you to change your nickname, just to make you aware of any possible confusion that may occur in the future.
    MorphOS - The best Next Gen Amiga choice.
  • »07.06.22 - 01:26
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11719 from 2003/5/22
    From: Germany
    > I've been using the nickname AmigaDave since around 1987
    > on just about every Amiga related forum website

    ...whereas the first Amiga-related forum websites emerged only about a decade later ;-)
  • »07.06.22 - 07:53
    Profile
  • Just looking around
    Amiga_Dave
    Posts: 6 from 2020/11/29
    Yes I'm very aware...
    https://morph.zone/modules/newbb_plus/viewtopic.php?forum=38&topic_id=13014&post_id=148133&viewmode=flat&sortorder=0&showonepost=1
    Quote:

    amigadave wrote:
    Just an FYI, I've been using the nickname AmigaDave since around 1987...

    Quote:

    Andreas_Wolf wrote:
    ...whereas the first Amiga-related forum websites emerged only about a decade later ;-)

    :D


    [ Edited by Amiga_Dave 08.06.2022 - 09:04 ]
    Amiga A500
    -Classic 520 '020
    -32GB CF, 8MB, 1MB Chip mod
    -Amiga OS 3.2.1

    PowerMac 5G DC 2.3Ghz (11,2)
    -12GB Ram/240GB SSD
    -Tiger 10.4.11 w/ OS9 Classic environment
    -Sorbet Leopard 10.5.9
    -Flashed ATi X1900 not MorphOS compatible
  • »08.06.22 - 14:00
    Profile