OWB and mobile phone streaming
  • Order of the Butterfly
    Order of the Butterfly
    Posts: 155 from 2019/4/6
    Today I wanted to do a little experiment,
    Using OWB and the mobile phone.
    I am not familiar with Morphos but I have seen that it is not possible to switch user-agents with OWB.
    So I did it like this:
    I needed to have the nintendo wii U as a user agent

    (does not require nintendo wii U hardware only user agent)

    I added this at the bottom of the user-startup:
    SETENV OWB_USER_AGENT "Mozilla / 5.0 (Nintendo WiiU) AppleWebKit / 536.30 (KHTML, like Gecko) NX / 3.0.4.2.13 NintendoBrowser / 4.3.2.11274.US"

    On reboot OWB changed user-agent

    The purpose of this was to try youtube with the nintendo wii U interface.
    In this way when we visit Youtube we will have full control from the mobile on youtube and the Morphos browser by selecting the one that interests us comfortably from the mobile phone.
    While using Morphos, just go to the settings and associate the TV or wi-fi code directly on the Youtube web page.
    In nintendo wii U settings

    To have control of the browser from a mobile phone without using the keyboard.

    I hope it will be useful, perhaps also for other online streaming uses that require access with a mobile phone.

    I also tried with Wayfarer the device makes the connection but instead the screen remains black.
    Using customize user-agent with:
    Mozilla / 5.0 (Nintendo WiiU) AppleWebKit / 536.30 (KHTML, like Gecko) NX / 3.0.4.2.13 NintendoBrowser / 4.3.2.11274.US

    but with Wayfarer it doesn't seem to work.

    [ Edited by white 08.02.2022 - 19:54 ]
  • »08.02.22 - 19:47
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Posts: 155 from 2019/4/6
    Here a short video for the operating principle
    here we see winuae with 4.1
    but with Morphos the operation is identical:
    tv code etc etc.
    it does not require hardware only user-agent and mobile phone

    https://we.tl/t-om1F2BCjzj
  • »08.02.22 - 21:45
    Profile
  • jPV
  • Paladin of the Pegasos
    Paladin of the Pegasos
    jPV
    Posts: 1883 from 2003/2/24
    From: po-RNO
    Quote:

    white wrote:
    I added this at the bottom of the user-startup:
    SETENV OWB_USER_AGENT "Mozilla / 5.0 (Nintendo WiiU) AppleWebKit / 536.30 (KHTML, like Gecko) NX / 3.0.4.2.13 NintendoBrowser / 4.3.2.11274.US"


    BTW. this is a wrong way to set permanent environment variables, it works, but it isn't designed like that. You should use the SAVE option with the SetEnv command. Then the variable is stored in the env archive directory (ENVARC:) and will be available after reboots.

    So, this would make a permanent variable (no need to set it elsewhere in every reboot):
    SetEnv OWB_USER_AGENT SAVE "Mozilla / 5.0 (Nintendo WiiU) AppleWebKit / 536.30 (KHTML, like Gecko) NX / 3.0.4.2.13 NintendoBrowser / 4.3.2.11274.US"
  • »09.02.22 - 11:21
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    Posts: 155 from 2019/4/6
    @jPV
    Hi,
    Thanks for the advice :-)

    I wanted to ask you with "OWB morphos" it works but the video is jerky.
    Could it be due to the limited bandwidth of morphos?
    Or there are other factors,
    Thank you.

    [ Edited by white 09.02.2022 - 12:57 ]
  • »09.02.22 - 12:52
    Profile
  • jPV
  • Paladin of the Pegasos
    Paladin of the Pegasos
    jPV
    Posts: 1883 from 2003/2/24
    From: po-RNO
    OWB's video playback is jerky if you play it as an embedded video on a web page. It doesn't use the overlay at all then (Wayfarer uses) and it's very very CPU heavy. To fix it you'll have to get the video to play either with the OWB's internal video player (find a direct URL from the Network Activity window and paste that in the URL string) or use a "Fullscreen Fix" script that is available for YouTube and some other pages. Then if you play video in the fullscreen mode it uses the overlay function and will play much better, you can see the difference for example here https://m.youtube.com/watch?v=PRQlibGzMYM
  • »09.02.22 - 14:49
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    Posts: 155 from 2019/4/6
    @jPV
    I'm sorry I asked the question wrong,
    OWB and Wayfarer work perfectly.

    I meant if I use the mobile phone function to watch videos with the youtube app via "tv code".
    also for example with this user-agent:
    Mozilla / 5.0 (Linux; GoogleTV 3.2; NSZ-GS7 / GX70 Build / MASTER) AppleWebKit / 534.24 (KHTML, like Gecko) Chrome / 11.0.696.77 Safari / 534.24

    the video is not played perfectly.
  • »09.02.22 - 15:10
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2649 from 2003/3/5
    From: Canada
    Well, what video exactly? My 1st guess would always be: your CPU is too slow for the selected video quality/codec.

    I've tried https://www.youtube.com/tv#/watch?v=t0Q2otsqC4I and https://www.youtube.com/tv#/watch?v=GVqjpcvKfHY with the User Agent you pasted above and it's working just fine.

    [ Edited by jacadcaps 09.02.2022 - 18:44 ]
  • »09.02.22 - 18:29
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    Posts: 155 from 2019/4/6
    @jacadcaps
    Ok, now it works fine with Wayfarer,
    The only problem is that the first video you choose to see you will have to press for example "space bar" from the PowerBook but from that moment on any video searched with the youtube-mobile app will start without problems.

    Without using Wayfarer or the PowerBook keyboard it will basically work like a remote control etc.

    While with OWB the video starts immediately.

    That's why with Wayfarer the black screen remained, I had to start the first video with the "space bar".

    Thanks for your suggestions.

    here a short video with Wayfarer:
    https://we.tl/t-OJjDvQ2Wew
  • »09.02.22 - 19:32
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2649 from 2003/3/5
    From: Canada
    That likely is due to the user feedback media setting.
  • »09.02.22 - 19:55
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    Posts: 155 from 2019/4/6
    @jacadcaps
    I will see better the various options,
    very nice I'm happy with this function :-)

    Thanks for your work with Wayfarer

    [ Edited by white 09.02.2022 - 20:17 ]
  • »09.02.22 - 20:16
    Profile