File search in Morphos (doesn't seem to work)
  • Order of the Butterfly
    Order of the Butterfly
    Posts: 158 from 2019/4/6
    I had probably already asked the question I don't remember,
    Because I always ask a lot of questions :-)

    I noticed that if I search for a file it doesn't actually find anything.
    But is it just my problem?
    Or will this problem be solved in the future?

    Is there any utility in Morphos-Storage to search for files in the morphos system?

    because every time I have to search for them manually and with many files it becomes difficult to do so.

    Thank you.
  • »23.01.22 - 11:40
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    igracki
    Posts: 375 from 2003/2/24
    From: Berlin
    How do you tried to search for files?

    Ambient can search for files and you can also use the Search shell command.

    Both methods are working fine here!
  • »23.01.22 - 13:12
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    Posts: 158 from 2019/4/6
    @igracki
    Hi,
    From the drop-down menu I choose "find"

    when the window opens I insert in the first item at the top for example:
    "addbuffers"
    selecting:
    morphos (partition)
    and the file is found regularly.

    But if I don't write the exact name, nothing appears in the search.

    Example in find I write:
    "add" (only)
    here the search program is unable to find the file I am looking for and nothing appears.
    In practice, if I write the exact name "it finds it"
    but if for example I write:
    "addbuff"
    because I don't remember the full name
    here the program finds nothing
    while there are actually other files starting with "add"

    it seems to be able to find only the full and correct names and not the initials of the file to search for such as:
    "addbuff"
    in this case the search program returns nothing.

    Maybe something wrong?
    Thanks again.

    can you take a test as described ?
    Thank you.
    Maybe I'm the one doing something wrong
  • »23.01.22 - 14:16
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Posts: 158 from 2019/4/6
    @jPV
    Hi,
    Thanks for the explanation,
    Now the search works fine.

    separate note:
    I point out that in this case the "Italian users" are unable to use the special characters if not applying the appropriate patch on morphos-storage for Italian keyboards at the following link:

    https://www.morphos-storage.net/dl.php?id=1592027

    if you are not aware of this patch to map the symbols on the keyboard it becomes difficult to use it.

    Thanks again for the tip.


    [ Edited by white 23.01.2022 - 18:32 ]
  • »23.01.22 - 17:31
    Profile
  • Moderator
    guruman
    Posts: 461 from 2003/7/21
    The "issue" of the Italian keyboard is really long standing, most Italian users in the good old days used to use the one created by Fulvio Peruggi that now is quite difficult to find (basically, you need a fellow older user to pass it to you). There was a short thread but full of details here a lot of years ago:
    https://morph.zone/modules/newbb_plus/viewtopic.php?topic_id=2608&forum=27
    The keyboard you pointed is not so complete, for instance from the point of view of support of the "dead keys" and in general addressing the issue directly in MorphOS is long due and is partially my own fault as I was tasked to help the team updating the Italian keyboard to a decent usability level, but I have been delaying this for years, really. Good news is, I finally found some time a few months ago, so the next MorphOS release should include an half decent Italian keyboard by default.

    Sorry for the off-topic.

    Kind regards,
    Andrea

    [ Edited by guruman 25.01.2022 - 00:12 ]
  • »24.01.22 - 23:11
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Daff
    Posts: 240 from 2003/4/5
    @white: I recommand you to use SimpleFind from Aminet (http://aminet.net/package/util/dir/simplefind3). Much powerful than the find function in MorphOS.
    Obligement - L'Amiga au maximum
    http://obligement.free.fr
  • »25.01.22 - 06:24
    Profile Visit Website