Flacapella and Ripper not getting track names
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    Travis_H
    Posts: 114 from 2009/12/17
    From: Salem, Oregon,...
    So I busted out some CDs to encoded the other day found neither Ripper nor Flacapella were able to get some track names. Internet connection was fine. MorphOS is up to date.

    Flacapella scans the CD for what seems like an eternity.

    Ripper gives an error in the console: "gethostbyname: undefined error: 0"

    These are mainstream CDs, so I doubt it's because the names are missing from online databases.

    Any ideas?
  • »21.09.20 - 20:40
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2152 from 2003/3/5
    From: Canada
    Perhaps the URLs have changed again... I'll check Flacapella. The problem is that there are no free lookup services one could use anymore.
  • »21.09.20 - 21:10
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Posts: 2152 from 2003/3/5
    From: Canada
    Please try
    setenv save CDDBP_SERVER "gnudb.gnudb.org"
    in a shell, then re-scan the CD. Let me know if that helps!
  • »21.09.20 - 21:20
    Profile Visit Website
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    Travis_H
    Posts: 114 from 2009/12/17
    From: Salem, Oregon,...
    It worked!

    Should I add the command to the WBStartup?
  • »21.09.20 - 22:12
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2152 from 2003/3/5
    From: Canada
    No need. It's already persistent. It'll be fixed in the upcoming OS release too - thanks for bringing this to my attention.

    [ Edited by jacadcaps 22.09.2020 - 03:01 ]
  • »21.09.20 - 23:14
    Profile Visit Website