PMAC ejects tray on boot
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Cool_amigaN
    Posts: 576 from 2011/11/30
    Hey, my PMAC 3.1 (sawtooth) has recently decided to spit the cd tray while on OF.

    This happens every time, without any hw or sw change (or at least any recent which I can think of) :/

    Specifically, it reads (cd-rom led is blinking) and ejects the tray (while being empty), then loads from HD and boots on MorphOS (this has always been a single boot system, no OSX/OS9/Linux).

    Think the system tries to boot first from the cd, but how can I stop this?

    [ Edited by Cool_amigaN 09.08.2020 - 23:41 ]
    Amiga gaming Tribute: Watch, rate, comment :)
  • »09.08.20 - 21:40
    Profile Visit Website
  • Paladin of the Pegasos
    Paladin of the Pegasos
    koszer
    Posts: 1014 from 2004/2/8
    From: Poland
    Well, at first I would check what are your boot settings, especially:

    Code:
    printenv boot-device


    Then I would try disconnecting the optical drive to see what happens.

    And then just a silly question: You don't have an Apple keyboard with "eject" button that's somewhat stuck?
  • »10.08.20 - 12:58
    Profile
  • jPV
  • Paladin of the Pegasos
    Paladin of the Pegasos
    jPV
    Posts: 1677 from 2003/2/24
    From: po-RNO
    Did Macs also eject the CD when the left mouse button is pressed even with MorphOS? Or was that hw or OSX feature at the end?

    But the easy test would be to detach both keyboard and mouse from the machine and try to boot without them if there would be something to do with them.
  • »10.08.20 - 16:50
    Profile Visit Website
  • Paladin of the Pegasos
    Paladin of the Pegasos
    koszer
    Posts: 1014 from 2004/2/8
    From: Poland
    That's right, LMB opens the tray too, but when the OF is up it's already too late for this trick.
  • »10.08.20 - 17:31
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Cool_amigaN
    Posts: 576 from 2011/11/30
    Hey, it's due to my recent keyboard purchase! wtf? I 've disconnected it and it boots straight into Ambient as usual. It's connected directly on onboard usb port. I switched it to another 1.1 onboard port and got same behavior. However this is a cooler master mk110/ms110, I don't understand what it has to do with the OF (doesn't have any eject button or the likes, it's pretty basic kboard ffs!).

    If I connect on a nec pci usb 2.0, will MorphOS face any difficulty to handle it as keyboard?

    Will do more tests. Damn it and it works great on MorphOS! Such a dissapointment :/
    Amiga gaming Tribute: Watch, rate, comment :)
  • »10.08.20 - 21:04
    Profile Visit Website
  • Paladin of the Pegasos
    Paladin of the Pegasos
    redrumloa
    Posts: 1420 from 2003/4/13
    Quote:

    Cool_amigaN wrote:
    Hey, it's due to my recent keyboard purchase! wtf? I 've disconnected it and it boots straight into Ambient as usual. It's connected directly on onboard usb port. I switched it to another 1.1 onboard port and got same behavior.


    My reply probably won't help, sorry. I just wanted to mention that OF seems real finicky with non-Apple Mac keyboards. I keep a Mac keyboard around just for emergencies. Non-Mac keyboards don't seem to work for OF keyboard commands on boot.
  • »11.08.20 - 02:12
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Amigaharry2
    Posts: 720 from 2010/1/6
    From: EU-Austria (Wien)
    Most of non-Apple-keyboards works well in OF - there just a few exotic or lowcost CE types, which won't work ( CE = China developed Equippement ). In some cases keyboards are not recognized during OF-startup, but that behavior above I've never seen.....
    Probably the keyboard-matrix generates a wrong code during initialisation, which MAC interprets as "Tray-open".
    Would be interresting, what happens when Caps-Lock is pressed during startup
    Peg2, 3xPowerMac G5, 2xPowerbookG4, 2x MacMiniG4, Efika (again), A3000T and life is never boring.....
  • »11.08.20 - 08:40
    Profile
  • Paladin of the Pegasos
    Paladin of the Pegasos
    koszer
    Posts: 1014 from 2004/2/8
    From: Poland
    Quote:

    Cool_amigaN wrote:
    Hey, it's due to my recent keyboard purchase! wtf? I 've disconnected it and it boots straight into Ambient as usual. It's connected directly on onboard usb port. I switched it to another 1.1 onboard port and got same behavior. However this is a cooler master mk110/ms110, I don't understand what it has to do with the OF (doesn't have any eject button or the likes, it's pretty basic kboard ffs!).



    Well, probably your keyboard sends something that your PowerMac recognizes as 'Eject CD' command when powered on. What happens if you connect it via PCI USB controller or an external hub?
  • »11.08.20 - 08:40
    Profile
  • Butterfly
    Butterfly
    Posts: 62 from 2017/8/7
    On a PC keyboard F12 replaces the eject key, so maybe this one is stuck?
  • »11.08.20 - 11:57
    Profile
  • MorphOS Developer
    geit
    Posts: 945 from 2004/9/23
    I had exactly the issue years ago with a no name keyboard.

    It seems some random ps/2 / usb chip is generating keys during power up/initi and cause the problem.
  • »28.08.20 - 04:59
    Profile