New Modern Webkit-based Browser In Development
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    Posts: 114 from 2017/8/6
    Nice update, @jacadcaps, thank you.
    It is still running nicely on my iBook.
    html5test.com reports 365 of 555 points scored, of course all video/audio is missing, obviously.
    And it recognized MorphOS☺

    Edit
    browserbench.org/JetStream/ javascript test seems to bring my machine to a halt, full CPU load and no finish of the test in sight...
  • »21.11.20 - 13:59
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2191 from 2003/3/5
    From: Canada
    Quote:

    Zetec-s wrote:
    I installed 1.7 last night on my G5 and the loading time for starting it up is now massive. In fact it went over 5 minutes twice and I simply rebooted.



    Disk fragmentation / very large cache / not enough disk buffers would be my bet. Nothing to do with 1.7 vs 1.6.
  • »21.11.20 - 14:09
    Profile Visit Website
  • Butterfly
    Butterfly
    Zetec-s
    Posts: 93 from 2008/7/10
    From: Cheshire, UK
    Quote:

    jacadcaps wrote:
    Quote:

    Zetec-s wrote:
    I installed 1.7 last night on my G5 and the loading time for starting it up is now massive. In fact it went over 5 minutes twice and I simply rebooted.



    Disk fragmentation / very large cache / not enough disk buffers would be my bet. Nothing to do with 1.7 vs 1.6.


    Thanks but it actually got a lot worse when I dropped the cache from 465meg to 60meg. Plus 1.6 and 1.7 are both running on the same drive.

    I’ll reinstall 1.7 tonight and see what happens as it did seem to slow down after being on the web for around an hour this morning.

    I’ll also have a go at defragging the hard drive when I get a chance.
    PowerMac G5 Quad 2.5Ghz/2GB MorphOS 3.14 Unregistered (but will be)
    Powerbook 1.67Ghz/1.5GB MorphOS 3.14 Registered
    MacMini 1.5Ghz/1GB MorphOS 3.14 Registered
    Efika 5200B 400Mhz/128MB MorphOS 2.3 Registered
  • »21.11.20 - 14:21
    Profile
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    Posts: 114 from 2017/8/6
    Is it possible to reroute the cache location to, lets say, an USB flash drive? Would that matter?
  • »21.11.20 - 14:30
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2191 from 2003/3/5
    From: Canada
    Quote:

    Thanks but it actually got a lot worse when I dropped the cache from 465meg to 60meg. Plus 1.6 and 1.7 are both running on the same drive.



    Reducing size may take a while.

    Quote:

    Is it possible to reroute the cache location to, lets say, an USB flash drive? Would that matter?


    You can softlink it whereever you like. That said, USB will likely make it a lot slower. If performance is an issue, I suggest you set the disk cache size to 0, quit Wayfarer, then delete the Wayfarer/Cache/curl folder. An SSD would likely help too.
  • »21.11.20 - 15:01
    Profile Visit Website
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    Posts: 114 from 2017/8/6
    I try it anyway.🙃
    But i cannot make the USB partition of SFS type, only FAT and so on.

    Ok, dit it. Had to create RDB first.

    [ Edited by amifrog 21.11.2020 - 16:06 ]
  • »21.11.20 - 15:03
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    ernsteiswuerfel
    Posts: 399 from 2015/6/18
    From: Funeralopolis
    I can't complain at v1.7 being slow. It feels faster than v1.6 did. That is on a G5 running it from a 2,5" HDD, no SSD involved.

    Was only a bit astonished default cache settings were 4 GiB. I set it to 1 GiB, not that I noticed any difference in speed. In-Memory Cache Setting is balacned.
    Talos II. [Gentoo Linux] | PMac G5 11,2. PMac G4 3,6. PBook G4 5,8. [MorphOS 3.14 / Void Linux / Gentoo Linux] | A1200. ACA-1233, Indivision AGA Mk2. [Amiga OS 3.2]
  • »21.11.20 - 15:22
    Profile
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    Posts: 114 from 2017/8/6
    Is there a way i can test my USB caching speed? I guess once Microsoft did this with Readyboost it must have benefits?
  • »21.11.20 - 15:28
    Profile
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    Posts: 114 from 2017/8/6
    Can we get a 'Downloads' button somewhere, maybe right next to the url field, please?😉
  • »21.11.20 - 15:58
    Profile
  • Butterfly
    Butterfly
    Posts: 70 from 2019/10/15
    Quote:

    jacadcaps wrote:
    Quote:

    Thanks but it actually got a lot worse when I dropped the cache from 465meg to 60meg. Plus 1.6 and 1.7 are both running on the same drive.



    Reducing size may take a while.

    Quote:

    Is it possible to reroute the cache location to, lets say, an USB flash drive? Would that matter?


    You can softlink it whereever you like. That said, USB will likely make it a lot slower. If performance is an issue, I suggest you set the disk cache size to 0, quit Wayfarer, then delete the Wayfarer/Cache/curl folder. An SSD would likely help too.


    I've set cache to 0 , deleted the curl folder and it starts immediately ( Given, I have a SSD ), previously it took about a minute to start.

    Next test, I've set space to 1gb and will see if it slows down again in time.
    Question, will Wayfarer handle the curl directory correctly to do clean ups when it hits the threshold of said limit in the settings?
  • »21.11.20 - 16:13
    Profile
  • Caterpillar
    Caterpillar
    xeno74
    Posts: 21 from 2020/6/8
    Quote:

    jacadcaps schrieb:
    A minor update to 1.7 is now out.

    Implemented an optional online version check
    Added a Safari/iPad spoofing option
    Tweaked to save settings periodically after edits
    Added Local Storage and Application Cache settings
    Enabled Application Cache
    Worked around servers that compress file downloads
    Fixed a crash when opening host settings from menu

    [ Edited by jacadcaps 20.11.2020 - 15:00 ]


    Great! Thank you! I successfully tested it today. I can download files without any problems. (see screenshot)
  • »21.11.20 - 16:56
    Profile
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    Posts: 114 from 2017/8/6
    That's some slow connection...🤪
  • »21.11.20 - 17:00
    Profile
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    Posts: 114 from 2017/8/6
    When i remove the column 'destination' from the downloads tab this setting doesn't remain. The column comes back the next time. As it is not required to see this can we get it removed or otherwise the columns layout be stored?

    Also,
    the settings are not stored globally in the system, so when i install a new version next to the old one instead of replacing it i need to adjust all settings once more. Especially the 'third party cookie' thing and the download folder.

    [ Edited by amifrog 21.11.2020 - 18:29 ]
  • »21.11.20 - 17:21
    Profile
  • Butterfly
    Butterfly
    Zetec-s
    Posts: 93 from 2008/7/10
    From: Cheshire, UK
    Quote:

    jacadcaps wrote:
    Quote:

    Thanks but it actually got a lot worse when I dropped the cache from 465meg to 60meg. Plus 1.6 and 1.7 are both running on the same drive.



    Reducing size may take a while.


    That makes sense then. It’s the change of cache size that was holding it up opening.

    I’ve since deleted the Curl folder and it starts up instantly.

    Thanks for your help.

    I’d agreed with the others that there is a definite speed increase with 1.7. I was using it today to buy Christmas presents with no issues. Worked great on eBay and PayPal.
    PowerMac G5 Quad 2.5Ghz/2GB MorphOS 3.14 Unregistered (but will be)
    Powerbook 1.67Ghz/1.5GB MorphOS 3.14 Registered
    MacMini 1.5Ghz/1GB MorphOS 3.14 Registered
    Efika 5200B 400Mhz/128MB MorphOS 2.3 Registered
  • »21.11.20 - 19:58
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2191 from 2003/3/5
    From: Canada
    Quote:

    amifrog wrote:
    the settings are not stored globally in the system, so when i install a new version next to the old one instead of replacing it i need to adjust all settings once more. Especially the 'third party cookie' thing and the download folder.


    Well, you're supposed to overwrite the old directory with the updated files and not create a copy alongside. It's in the FAQ.
  • »21.11.20 - 22:00
    Profile Visit Website
  • Butterfly
    Butterfly
    Posts: 70 from 2019/10/15
    Quote:

    amifrog wrote:
    That's some slow connection...🤪


    My 200MBps fibre connection runs at about the same speed when download via LAN or WIFI. I can't get it to go any faster.
  • »22.11.20 - 06:04
    Profile
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    Posts: 114 from 2017/8/6
    I just downloaded this tar.gz, i am getting around 1.3Mbps via my iBooks wifi?
  • »22.11.20 - 07:30
    Profile
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    Posts: 114 from 2017/8/6
    Quote:

    jacadcaps wrote:
    Quote:

    amifrog wrote:
    the settings are not stored globally in the system, so when i install a new version next to the old one instead of replacing it i need to adjust all settings once more. Especially the 'third party cookie' thing and the download folder.


    Well, you're supposed to overwrite the old directory with the updated files and not create a copy alongside. It's in the FAQ.


    So i drop the Wayfarer folder from the downloaded lha to sys:Apps and answer the requester for replacement with yes, all?
  • »22.11.20 - 19:05
    Profile
  • K-L
  • Just looking around
    K-L
    Posts: 2 from 2020/11/17
    From: Lyon, France
    Yes. It is explained in the readme.
    PowerMac G5 2,7 Ghz / Radeon 9650 / MorphOS 3.14
    AmigaOne X1000 (unused ATM)
  • »22.11.20 - 20:07
    Profile
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    Posts: 114 from 2017/8/6
    Wouldn't this delete my settings in the older folder?
  • »22.11.20 - 20:09
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    tolkien
    Posts: 345 from 2013/5/29
    No. Your settings are safe.

    And @jacadcaps...this is brilliant!! It seems faster each release.
    PowerMac G5 - PowerBook G4 - MacMini with MorphOS. Amiga 1200/060 AmigaOS 3.x
  • »22.11.20 - 20:37
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2191 from 2003/3/5
    From: Canada
    Quote:

    amifrog wrote:
    So i drop the Wayfarer folder from the downloaded lha to sys:Apps and answer the requester for replacement with yes, all?


    Exactly. Your settings, cookies and whatnot are safe since none of those are included in the archive.
  • »22.11.20 - 22:17
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    analogkid
    Posts: 592 from 2004/11/3
    From: near myself
    Thanks for this update. On most sides, the rendering speed of Wayfarer is okay for me on a G5. When I try to use Wayfarer on editing an article in WordPress, the CPU load rises to 100% and nothing happens in the editor screen for minutes. When I close the window, CPU load gets back to a normal level. What could be wrong?
  • »23.11.20 - 05:32
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    eliot
    Posts: 523 from 2004/4/15
    Nice work, on my Mac Mini it replaces now the good old OWB.
    regards
    eliot
  • »23.11.20 - 06:52
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    NewSense
    Posts: 966 from 2012/11/10
    From: Manchester, UK/GB
    Running Wayfarer v1.7 on my MacMini when I go to the ebay.co.uk website I get a "black" header, top 2-3 cms of the screen where the search option, page links, and ebay logo are. When I load v1.6 I get the usual white area for the page, and as this is displayed in white on other Windows systems I own, I believe there is an issue with v1.7 in this regard.

    Has anyone else seen this unusual rendering issue on their MorphOS system with v1.7? :-?
    MacMini 1.5GHz,10,2,64MB VRAM,1GB,Airport, Bluetooth,A1016 Keyboard,T-RB22 Mouse,DVD-RW-DL+CD-RW,Iomega MiniMax,Belkin 6 port 3 x Firewire/3 x, USB2, MorphOS 3.12, Mac OSX 10.4/10.5, A1138+A1139 PwrBk MOS v3.12,Model 5,8/5,9, & PowerMac G5 2.3GHz(DP)
  • »23.11.20 - 15:57
    Profile