IDE-CF adapters - PMac 3.1
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Cool_amigaN
    Posts: 527 from 2011/11/30
    TL;DR has any succeeded in setting up an IDE-CF adapter?

    Long story: I have tried to install this and this device (ide 40 pin to cf in bracket) to my heavily upgraded PowerMac 3.1. The Sawtooth has only 1 uata port in its mobo and the end of the cable has a Digitus IDE-SATA adapter connected to an ADATA SSD which works perfectly. Middle cable slot is empty (that's the one I used to experiment). I connected a Delock m-m 40pin adapter (thanks koszer for the idea ;)) and then a sleeved Sharkoon uata cable leading to the ide-cf adapters (tested one each time of course). Adapters' jumpers were set on Slave and Digistus/SSD on master. I had tried to use both a SDCF WiFi adapter (with a SunDisk 32GB extreme SD) and a normal SunDisk 8GB CF which is working properly on an Amiga 1200. Also, I have tried to connect the IDE-CF adapters directly on middle empty slot bypassing the extra uata sleeved cable and m-m ide adapter.

    In ALL combinations, I was getting the following behavior on a MorphOS 3.11:

    - If CF cards were present on the IDE-CF adapters during boot: usb powered mouse/keyboard -> grey screen -> usb rebooted -> grey screen remained indefinitely (SSD has only MorphOS installed / no dual boot)

    - If CF cards were inserted after MorphOS has entered Ambient: No popup that a device has been connected and clicking to any partition would hang the system (including the sbar). If CF cards were removed then partition window which was clicked would be opened and sbar would resume operation normally.

    - IDE - CF adapters didn't seem to be recognized anywhere on MorphOS me thinks... such as on the HD Toolbox. All I was getting was the idemacio2.device (which is the SSD connected, listing its partitions) and idemacio.device which is my CD-DVD device I suppose. Should I look elsewhere as well? Shouldn't the adapters be recognized, even if no CF card was present?

    - Without the CF cards inserted I can see that the adapters try to load/access files (activity leds), but once inserted blinks stop.

    - If the IDE-CF adapters were set on Master then PowerMac would complain that no bootable device can be found during boot (usual Mac logo with a question mark), so it seems that generally speaking the hardware setup looks correct.

    You can take a panoramic look at the h/w internal setup, here.

    [ Edited by Cool_amigaN 28.11.2019 - 13:07 ]
    Amiga gaming Tribute: Watch, rate, comment :)
  • »28.11.19 - 10:55
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    Doffo
    Posts: 441 from 2010/10/14
    From: Nevada
    To make a long story short, use CF cards that have a true IDE Mode on them. Look up Industrial CF cards on eBay to get an idea. I bought smaller sizes of 4GB each of the Western Digital SiliconDrive . :)

    Try stacking two Sandisk CD cards on the Amiga, and bet you its gonna give you grief to no end. :) One by itself and only by itself it seems to work on my Amiga 1200, but adding a slave CF card? Nope. That is when I figured out about the CF cards needing to be fully compatible with IDE. Thats when both CF cards worked on my A1200 once I replaced both with the Western Digital SiliconDrive cards.

    I meant to try some Transcend Industrial cards to see how they are. But from what I gathered on your post, the Sandisk will never like working with another device present in the IDE.
    -=-=-=-
    YUUUP!
  • »28.11.19 - 15:57
    Profile Visit Website
  • MorphOS Developer
    geit
    Posts: 928 from 2004/9/23
    Yeah, I used CF cards for a very long time in Pegasos and PowerMac G4 and they work perfect.

    Just make sure the card is a real DMA supporting card using the latest CF Standard. Bigger cards are likely supporting this mode. The issue is that all cards only support a very limited amount of write commands. When the limit is reached they block the IDE bus until the operation is finished.

    These days CF cards are expensive and for the known reasons should no longer be used anymore as system drive. Real SSDs became much cheaper.

    However in systems with space I would use an ide2sata dual adapter and use anstandest SSD. Even the cheapest 64GB SSD is faster than any CF card and faster than the die bus itself. For Systems without space like a mini or a powerbook use an ide2mSata Adapter with a matching card.

    I suggest the SanDisk extreme series, which is very cheap. Just get the smallest size available, which is always a good deal.
  • »29.11.19 - 06:28
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Cool_amigaN
    Posts: 527 from 2011/11/30
    You both confided that it's the type of the cf card? I do have also a working 32gb extreme udma sandisk cf on another a1200. Will remove it and give it a go.
    Amiga gaming Tribute: Watch, rate, comment :)
  • »30.11.19 - 19:59
    Profile Visit Website