PowerBook5,6 1.67 phantom keys in input
  • Just looking around
    Posts: 13 from 2017/8/9
    Hi all,

    Just picked up a PowerBook5,6 hoping to have a portable MorphOS system.

    The machine seems to be working OK, except I can't seem to type reliably without getting some phantom characters inserted into my input. Note that I am a pretty fast typist.

    Two specific examples:

    if I type .org very fast, I reliably get .o6rg
    if I type slice very fast, I reliably get slicce

    Note that this doesn't happen if I type slowly, nor can I narrow it down to a specific set of keys.

    This happens in the Ambient Shell and in Flow Studio as well as probably other places.

    My Locale is United_states/English and my keyboard has been set to "USA keyboard with 101/104 keys" as well as "American".

    I haven't tried it with an external keyboard.

    This is a fresh install of MorphOS 3.10.

    I'd think it was the hardware, but it doesn't happen in the 10.5.8 install on this machine.

    Any ideas?

    Thanks
  • »22.06.18 - 01:27
    Profile Visit Website
  • Just looking around
    Posts: 13 from 2017/8/9
    I just tried something similar to .org to see what would happen.

    /pef typed fast results in /p*ef

    It's almost like there's some phantom num-lock happening.

    I noticed that if I turn on num-lock, and rapidly hit the uio/jkl/m,. keys, numbers are intermixed with letters. I would think with num-lock on, I would only get numbers. But nope.


    [ Edited by uchar 22.06.2018 - 02:32 ]
  • »22.06.18 - 01:32
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    polluks
    Posts: 398 from 2007/10/23
    From: Gelsenkirchen,...
    I reported this keylargo bug in 2016, no solution so far.
    An external keyboard is a workaround.
    Pegasos II G4: MorphOS 3.9, Zalman M220W · iMac G5 12,1
    Power Mac G3: OSX 10.3 · PowerBook 5,8: OSX 10.5, MorphOS 3.11
  • »22.06.18 - 05:50
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 10018 from 2003/5/22
    From: Germany
    > I can't seem to type reliably without getting some phantom characters
    > inserted into my input. Note that I am a pretty fast typist.

    JFYI, also discussed there.
  • »22.06.18 - 09:04
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 1681 from 2003/3/5
    From: Poland
    Quote:

    polluks wrote:
    I reported this keylargo bug in 2016, no solution so far.
    An external keyboard is a workaround.


    Powerbook 5,6 does not use keylargo for keyboard though - it is USB.
  • »22.06.18 - 11:44
    Profile Visit Website
  • Just looking around
    Posts: 13 from 2017/8/9
    Quote:

    polluks wrote:
    I reported this keylargo bug in 2016, no solution so far.
    An external keyboard is a workaround.


    Thanks.

    Sounds like this is a confirmed issue.

    I will hold off on registering MorphOS on this PowerBook until this is resolved.

    This issue smashes my dreams of using CygnusEd while sitting out on the porch. ;)

    As an aside -- this is not the first time I've had issues using Apple keyboards on alternative operating systems. Using the "flat" aluminum Apple USB keyboard on my Raspberry Pi (running Raspbian) has also resulted in extra keys entering the input stream, though perhaps not exactly in the same style. It has made me wonder if Apple's keyboards actually have firmware bugs which are addressed by Apple in Apple's own drivers.
  • »22.06.18 - 14:42
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Posts: 1681 from 2003/3/5
    From: Poland
    Since the issue also appears in the OpenFirmware prompts, it is indeed likely that this is a hw issue. As such it is not likely that this will get any workarounds on MorphOS.
  • »22.06.18 - 22:43
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    polluks
    Posts: 398 from 2007/10/23
    From: Gelsenkirchen,...
    Quote:

    jacadcaps schrieb:
    Powerbook 5,6 does not use keylargo for keyboard though - it is USB.

    Aha, at least reslist shows the keylargo.resource

    USBKeyLargo.cpp

    Quote:

    jacadcaps schrieb:
    Since the issue also appears in the OpenFirmware prompts, it is indeed likely that this is a hw issue. As such it is not likely that this will get any workarounds on MorphOS.

    Which OpenFirmware release? 5,8 BootROM 4.9.6f0 works fine.
    I never had this issue with macOS.

    [ Editiert durch polluks 27.06.2018 - 21:37 ]
    Pegasos II G4: MorphOS 3.9, Zalman M220W · iMac G5 12,1
    Power Mac G3: OSX 10.3 · PowerBook 5,8: OSX 10.5, MorphOS 3.11
  • »27.06.18 - 18:37
    Profile