git clone from Github fails
  • Order of the Butterfly
    Order of the Butterfly
    asrael22
    Posts: 367 from 2014/6/11
    From: Germany
    Hi.

    I wanted to clone a repo from Github.

    When calling "git clone https://github..."
    I'm just seeing:
    Cloning into 'Foo'...
    die() should not be called in child

    And that's it.
    Some git metadata seems to be getting downloaded but no sources at all.

    Something I'm missing?


    Manfred
  • »20.05.18 - 10:08
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 1648 from 2003/3/5
    From: Canada
    It is a know issue. Will be addressed in the new SDK.
  • »20.05.18 - 11:42
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    polluks
    Posts: 380 from 2007/10/23
    From: Gelsenkirchen,...
    Me too, do you have a hot fix please?
    Pegasos II G4: MorphOS 3.9, Zalman M220W
    Power Mac G3: OSX 10.3 · PowerBook 5,8: OSX 10.5, MorphOS 3.11
  • »30.07.18 - 13:02
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 1648 from 2003/3/5
    From: Canada
    Unfortunately there'll be no SDK updates before November/December this year. You can use the original build from widelec though.

    [ Edited by jacadcaps 30.07.2018 - 08:09 ]
  • »30.07.18 - 13:09
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    polluks
    Posts: 380 from 2007/10/23
    From: Gelsenkirchen,...
    Thank you, it works.

    Because of
    Code:
    Cloning into 'cc65'...
    fatal: unable to access 'https://github.com/cc65/cc65.git/': SSL certificate problem: unable to get local issuer certificate

    you also need
    Code:
    setenv HOME .
    git config --global http.sslVerify false
    Pegasos II G4: MorphOS 3.9, Zalman M220W
    Power Mac G3: OSX 10.3 · PowerBook 5,8: OSX 10.5, MorphOS 3.11
  • »30.07.18 - 13:24
    Profile