Memory leak on Powerbook 5.2 and 5.4
  • Just looking around
    Posts: 17 from 2018/4/20
    If I run Morphos 3.8 or 3.9 or 3.10 .
    on Powerbook 5.2 and 5.4 the memory is gone afther 7 days.

    I must reset every week , a mounth ago the leak was stopped maby a task are crach .
    how can I find the program makes the memoryleak . with the Powerbooks 5.6 works all fine .

    - Ather 1 day running , the mouse move not nice , i kan solve that with
    the taskpri temperatur.sensor battery.sensor and Powerbook_service set to 0 .
    normal with 3.9 are that 20 and 25 by Morphos 3.10 .

    - and the keybordblacklicht are dedect wrong .
    as no keyborblachlicht the OSD work with press F8 F9 F10
    there are keybordblackl.. the OSD work not with press F8 F9 F10


    [ Bewerkt door Olystany 28.04.2018 - 22:11 ]
  • »25.04.18 - 16:30
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Posts: 1637 from 2003/3/5
    From: Canada
    Thank you for the report. We will be looking into this...
  • »25.04.18 - 16:43
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    asrael22
    Posts: 353 from 2014/6/11
    From: Germany
    Could be the same (or same cause) I had reported for the iBook.
  • »25.04.18 - 17:41
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 1637 from 2003/3/5
    From: Canada
    Yes, that is likely the same issue.
  • »25.04.18 - 17:48
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Posts: 1637 from 2003/3/5
    From: Canada
    Found and fixed one possible issue. If you can, please run Scout -> Tasks, find battery.sensor task and freeze it. Let me know if the issue disappeared completely or if the leak velocity simply changed.
  • »26.04.18 - 12:55
    Profile Visit Website
  • Just looking around
    Posts: 17 from 2018/4/20
    Quote:

    jacadcaps wrote:
    Found and fixed one possible issue. If you can, please run Scout -> Tasks, find battery.sensor task and freeze it. Let me know if the issue disappeared completely or if the leak velocity simply changed.


    I can,t let work Scout to freeze a task.
    I use freeze for mos 3.9 .

    hardware for test Powerbook A1095 5.4 .

    new installation Morphos 3.10 .
    memory leak 145 MB / 24 hour .
    with freeze battery.sensor after 5 hour i see no difference .. tommorow test complete

    I test on A1046 Powerbook 5.2 .
    Morphos 3.9
    freeze battery.sensor
    freeze temperatur.sensor
    freeze sensor.library
    freeze Powerbook_service
    the memory leak are < 2 MB / 24 hour .

    I will test more and find the Leak .
  • »28.04.18 - 22:06
    Profile Visit Website
  • Just looking around
    Posts: 17 from 2018/4/20
    Quote:

    jacadcaps wrote:
    Found and fixed one possible issue. If you can, please run Scout -> Tasks, find battery.sensor task and freeze it. Let me know if the issue disappeared completely or if the leak velocity simply changed.


    test with Morphos 3.10 on A1095

    I freeze battery.sensor

    the leak go a little faster and is stop afther 16 hours .
    then the leak <2 mb / 24 hours .
    maby sometings are crash ?

    OK i do more tests ......
  • »29.04.18 - 15:20
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Posts: 1637 from 2003/3/5
    From: Canada
    Does the same happen when you boot from CD?
  • »29.04.18 - 15:31
    Profile Visit Website
  • Just looking around
    Posts: 17 from 2018/4/20
    Quote:

    jacadcaps wrote:
    Does the same happen when you boot from CD?


    Do you mean boot and not freeze a task ?

    Yes the memory leak are also by boot from CD .

    I have 3 A1046 and 4 A1095 and 5 A1106 .
    I have a key van A1046 and one for A1095 and two for A1106
    the A1106 is the best , I run now 77 days with memory usage 7.6 % used.

    I have test all boot from CD , and let run a day with memory gauge .
    I did that 4 mound ago , and the memory leak on 3.8 3.9 and on A1046 , A1095 the same .
  • »29.04.18 - 21:20
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Posts: 1637 from 2003/3/5
    From: Canada
    Thanks for continuing to bug me about this problem. The issue has been found and fixed for 3.11. I've never seen this myself since this was exclusive to older PowerBooks - two bugs in the PowerBook service task resulted in it scanning the teperature sensor list every second and allocating a sensor notification per each sensor found on every scan. This also made the OS slow down with time like Olystany observed.
  • »30.04.18 - 03:09
    Profile Visit Website
  • Just looking around
    Posts: 17 from 2018/4/20
    Quote:

    jacadcaps wrote:
    Thanks for continuing to bug me about this problem. The issue has been found and fixed for 3.11.


    OK thanks , the problem with keyboard-black light , are that found .
    ma by are the detection off exist keyboard-black light wrong by powerbooks 5.2 and 5.4.
  • »30.04.18 - 09:59
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Posts: 1637 from 2003/3/5
    From: Canada
    Unfortunately I only have PowerBook5,8 and 5,9 so I cannot check anything related to the kb backlight on ADB machines.
  • »30.04.18 - 12:24
    Profile Visit Website