MiniSlug - Beworld port issues
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    koszer
    Posts: 812 from 2004/2/8
    From: Poland
    I'm having some issues running the latest MiniSlug ported by Beworld. Can anyone confirm the same behaviour of the game?

    1. The main menu backgroung gfx seem to be broken - covered by gray field from the right, only part of background is visible.
    2. Configuration of keyboard is OK, but then the cfg program recognizes joystick (that I don't have connected) and tries to configure it afterwards. As I have none - it's just endlessly waiting for my joystick input, and the configuration process cannot be finished.
    3. The game when launched in fullscreen mode (F10 if I'm not mistaken) runs with broken colours.
    4. After finishing the first stage nothing happens (I cannot skip to the second one).

    Running on Dual G5 2,7 GHz, Radeon X850XT.
  • »13.02.18 - 09:24
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 9830 from 2003/5/22
    From: Germany
    I'm not at my MorphOS machine currently so can't verify but this is what I (don't) remember from when I tried it last weekend:

    Issue #1: Either not happening here or didn't notice.
    Issue #2: I used default keyboard config, so didn't notice.
    Issue #3: Fullscreen colours are fine here.
    Issue #4: I can definitely confirm this.

    Running on dual-G5 2.3 GHz, Radeon 9600.
  • »13.02.18 - 09:52
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    beworld
    Posts: 233 from 2010/2/10
    From: FRANCE
    #1 --> yes animation (GIF file) doesnt working.... i disabled it in next version.

    #4 --> i confim, i fix that


    I re-upload archive

    thanks

    BeWorld
    PowerMac 2.7ghz MOS 3.10
    PowerBook 1.5Ghz MOS 3.10
    My MOS ports
  • »13.02.18 - 12:12
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    koszer
    Posts: 812 from 2004/2/8
    From: Poland
    Quote:

    beworld wrote:


    #1 --> yes animation (GIF file) doesnt working.... i disabled it in next version.

    #4 --> i confim, i fix that


    I re-upload archive

    thanks

    BeWorld


    Thanks for a quick reply. Issue #1 fixed, issue #2 and #3 - no (I guess that you don't have such problem on your config? I can take a screenshot/photo/video if it's needed)
    Now for the Issue #4 - the game lets you play level 2, but something strange happens when entering second part of mission 1 (entering the jungle) a window appears saying: "Fin de mission Transit2D_InitClosing" and you have to quickly click the main game window, because it's not active anymore - first soldier will surely kill you before you take game control back.
  • »13.02.18 - 16:36
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Cool_amigaN
    Posts: 470 from 2011/11/30
    Guys, does the port has sound/music enabled? The 68k port that I am using does but beworld's port does not. Can anyone confirm this?
    Amiga gaming Tribute: Watch, rate, comment :)
  • »13.02.18 - 17:32
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    koszer
    Posts: 812 from 2004/2/8
    From: Poland
    Quote:

    Cool_amigaN wrote:
    Guys, does the port has sound/music enabled? The 68k port that I am using does but beworld's port does not. Can anyone confirm this?


    There's no music, but sound works well here.
  • »13.02.18 - 17:39
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    beworld
    Posts: 233 from 2010/2/10
    From: FRANCE
    yes i know that, i disabled sounds....

    i check if i can enable it
    PowerMac 2.7ghz MOS 3.10
    PowerBook 1.5Ghz MOS 3.10
    My MOS ports
  • »13.02.18 - 18:54
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    koszer
    Posts: 812 from 2004/2/8
    From: Poland
    Quote:

    beworld wrote:
    yes i know that, i disabled sounds....

    i check if i can enable it


    But I do have sounds here - maybe it's because I've switched the config file with the one from 68k version?
  • »13.02.18 - 19:01
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    beworld
    Posts: 233 from 2010/2/10
    From: FRANCE
    no, i disable music only (YM atari files),... sorry

    [ Edité par beworld 13.02.2018 - 19:02 ]
    PowerMac 2.7ghz MOS 3.10
    PowerBook 1.5Ghz MOS 3.10
    My MOS ports
  • »13.02.18 - 19:01
    Profile Visit Website
  • Just looking around
    Oli716
    Posts: 16 from 2011/9/18
    Dear Beworld.

    great job on the port, I like the game very much.
    Any chance to get the config program and the animated gif title fixed?

    Thanks for your efforts.
    Best regards,
    Oli
  • »13.02.18 - 19:22
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    beworld
    Posts: 233 from 2010/2/10
    From: FRANCE
    gif no chance (glich total).... config program, it's present in lha archive.

    Music crash game :(.... working a little... but music it's very very ATARI lol (bad)
    PowerMac 2.7ghz MOS 3.10
    PowerBook 1.5Ghz MOS 3.10
    My MOS ports
  • »13.02.18 - 19:41
    Profile Visit Website
  • Just looking around
    Oli716
    Posts: 16 from 2011/9/18
    config program is broken, it displays joystick although I don't have connected a joystick.
    Therefore I can't save the configuration.

    Sorry to bother you ;)
  • »13.02.18 - 19:45
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    beworld
    Posts: 233 from 2010/2/10
    From: FRANCE
    it's just a port :( sorry but i can't modify config.
    Yan can't put anything in joystick ?
    PowerMac 2.7ghz MOS 3.10
    PowerBook 1.5Ghz MOS 3.10
    My MOS ports
  • »13.02.18 - 20:07
    Profile Visit Website
  • Just looking around
    Oli716
    Posts: 16 from 2011/9/18
    yes, I have no joystick connected so no chance to make an input.
    Game still runs with standard configuration though.

    Thanks for your quick response :)

    No issue if you are not able to fix the problems, maybe someone else can do, keep the ports coming, they are very welcome!
  • »13.02.18 - 20:29
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    koszer
    Posts: 812 from 2004/2/8
    From: Poland
    Quote:

    Oli716 wrote:
    config program is broken, it displays joystick although I don't have connected a joystick.
    Therefore I can't save the configuration.


    Get the 68k version, run config there and save it. Then just transfer the .cfg file to your MorphOS port directory. Voila, you have working, personalized settings!
  • »13.02.18 - 21:13
    Profile
  • Just looking around
    Oli716
    Posts: 16 from 2011/9/18
    Quote:

    koszer schrieb:
    Get the 68k version, run config there and save it. Then just transfer the .cfg file to your MorphOS port directory. Voila, you have working, personalized settings!


    great idea, I will copy the config from my OS4 version over to MorphOS.
    Thanks :)
  • »13.02.18 - 21:30
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Cool_amigaN
    Posts: 470 from 2011/11/30
    Quote:

    koszer wrote:
    Quote:

    Oli716 wrote:
    config program is broken, it displays joystick although I don't have connected a joystick.
    Therefore I can't save the configuration.


    Get the 68k version, run config there and save it. Then just transfer the .cfg file to your MorphOS port directory. Voila, you have working, personalized settings!


    Yeap, that's what I did as well. Anyhow, music should be enabled because we are losing a lot of fun without the game's soundtrack.
    Amiga gaming Tribute: Watch, rate, comment :)
  • »13.02.18 - 21:36
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    beworld
    Posts: 233 from 2010/2/10
    From: FRANCE
    in my test, music work fine in game but doesnt in menu... :(
    I try to deactive in menu, but i dont found....


    For GIF animation, i chack that this week-end.
    PowerMac 2.7ghz MOS 3.10
    PowerBook 1.5Ghz MOS 3.10
    My MOS ports
  • »14.02.18 - 07:00
    Profile Visit Website
  • Just looking around
    Oli716
    Posts: 16 from 2011/9/18
    Thank you very much beworld :)
  • »14.02.18 - 08:16
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    beworld
    Posts: 233 from 2010/2/10
    From: FRANCE
    ok i update with last Ymlib and music working !!

    I upload an update : http://www.morphos-storage.net/?page=Games%2FPlatform&file=MiniSlug.lha

    I check for the last bug : GIF (endian reverse...) this week-end with help (thk HunoPPC) (normally)
    PowerMac 2.7ghz MOS 3.10
    PowerBook 1.5Ghz MOS 3.10
    My MOS ports
  • »14.02.18 - 17:42
    Profile Visit Website