Iris - An upcoming E-Mail client blog
  • Yokemate of Keyboards
    Yokemate of Keyboards
    takemehomegrandma
    Posts: 2485 from 2003/2/24
    Quote:

    jacadcaps wrote:
    Now that 3.10 is out I'll be working towards the 1st public release. ETA: couple of days.


    Wow! :-)

    Looking forward to this!

    :-D
    MorphOS is Amiga done right! :-)
    MorphOS NG will be AROS done right! :-)
  • »26.03.18 - 14:17
    Profile
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    Debaser
    Posts: 146 from 2005/7/12
    From: Syracuse, NY, USA
    This is great news. I am looking forward to trying Iris out!
  • »27.03.18 - 02:35
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Doffo
    Posts: 379 from 2010/10/14
    From: Nevada
    Looking forward to trying it out. :)
    -=-=-=-
    YUUUP!
  • »27.03.18 - 16:06
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Posts: 1575 from 2003/3/5
    From: Canada
    Iris beta 22 is now available at tunkki

    Now this is all in the README, but let me re-iterate: this is a BETA release. I take no responsibility for whatever happens to your mailbox. If you're uncertain / don't want to take the risk: do NOT download this.

    I will be releasing those betas once in a while. Probably every 2nd or 3rd closed beta release will be made public.

    What works:

    IMAP, SSL, email autoconfiguration, OAuth2 (for gmail and outlook.com)
    POP3 to some extent (slow)
    Browsing email folders, reading emails in a HTML view
    Saving attachments, viewing image attachments
    Sending HTML emails, with attachments
    Multiple accounts
    Encryption of passwords & keys via cryptostorage.library

    Does not work:

    There's no settings. No really, they're there, there's just no UI for them. Settings
    will happen at the very end, sorry :)
    There's no local storage (other than headers)
    There's no outgoing folder - if there's an error when you're writing an email,
    the email is lost.
    Iris on MorphOS 3.9

    Feature requests and stuff:
    Feel free to ask in this thread, but don't expect things to happen quickly. I have an internal
    roadmap and many systems depend on each other - I cannot just hop over some things :)
    For instance some stuff can now be painfully slow because the systems that are not yet
    online will take care of this later (like the local storage will make loading emails
    pretty fast).

    Installation and usage:
    Extract files. Make sure OpenURL is set up for OWB 1.24. Make sure OWB defaults to JS enabled if you're using gmail or outlook.com. Make sure OpenURL is set up for Iris (notes on that are in the README file).
  • »29.03.18 - 20:41
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Cego
    Posts: 572 from 2006/5/28
    From: Germany
    hey jacadcaps,

    first of all thanks for the release. i had a quick look at it and i had my mail account running 20 seconds after i copied it over to my harddisk. fantastic work!

    i have a question though. How can i activate the icon toolbar? there are icons stored in the icon drawer. i assume they are supposed to act as toolbar buttons, right?

    [ Edited by Cego 29.03.2018 - 22:21 ]
    Powerbook G4@1,67GHz, 2GB DDR2 Ram, Radeon 9700, 60GB SSD, MorphOS 3.7
    PowerMac Dual G5 @2.3GHz, 4GB DDR Ram, Radeon 9600XT, 2x250GB HD, MorphOS 3.7, MacOS X Leopard 10.5.8
  • »29.03.18 - 22:21
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 1575 from 2003/3/5
    From: Canada
    There is no toolbar in the main window. The images you’ve seen are used by the New Email window.
  • »29.03.18 - 23:10
    Profile Visit Website
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    Debaser
    Posts: 146 from 2005/7/12
    From: Syracuse, NY, USA
    So far working well with my gmail account. Enjoying the ability to work with emails well with Morphos. Well done jacadcaps! Thank you Thank you :)

    Looking forward to seeing this application progress.
  • »30.03.18 - 03:21
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    pegasos-sigi2
    Posts: 251 from 2006/8/31
    @jacadcaps:



    I find a problem with iris. Iris can't get the settings from the mailserver. It was hostet on "Deutsche Glasfaser AG".
    This problem exists on any other clients, whitch try to get the settings automaticly.

    The problem: The server needs this hostname: mail.dg-email.de not imap.dg-email.de
    I can't set this my selfe.

    2. The login: Iris presume as login "carstensiegner", but i use a different login. The same in the login from smtp.dg-email.de


    After some trys, iris can't conect to the mailserver : (

    [ Edited by pegasos-sigi2 30.03.2018 - 11:46 ]
    Spreedy - The spreedsheet editor of MorphOS
    Calimero - Do you know about the new DTP Program for MorphOS ?
  • »30.03.18 - 10:38
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 1575 from 2003/3/5
    From: Canada
    Quote:

    pegasos-sigi2 wrote:
    I find a problem with iris. Iris can't get the settings from the mailserver. It was hostet on "Deutsche Glasfaser AG".
    This problem exists on any other clients, whitch try to get the settings automaticly.


    Well, that’s the fault of the admins of the said server. Once autoconfiguration fails you can adjust all the settings by hand and try again. Let me know if anything is unclear in the settings - there is a switch to show more options there that you probably need to use.

    Worst case scenario - make an email accout for me on that server and I’ll have a look. This is generally advised for everybody having problems at this point.

    [ Edited by jacadcaps 30.03.2018 - 09:11 ]
  • »30.03.18 - 14:10
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    defender
    Posts: 227 from 2011/4/24
    Thank you for the Beta of IRIS.

    Freenet: imap receiving Works fine :-)
    Freenet: imap Sending - doesn't work

    Googlemail: imap receiving - Works fine :-)
    Googlemail: sending ... doesn't work

    deleting mails works fine :-)


    [ Editiert durch defender 31.03.2018 - 00:47 ]
    PowerMac 3.6 - Radeon 9000_64Mb - 1,5Gb Ram - SB Live - MorphOS 3.9
    CD32 - PowerBook 1,67GHz 1GB/100GB - MorphOS 3 reg. 1455
  • »30.03.18 - 23:43
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Posts: 1575 from 2003/3/5
    From: Canada
    Quote:

    defender wrote:
    Freenet: imap Sending - doesn't work
    Googlemail: sending ... doesn't work



    For freenet: I guess you just need to tweak the settings.
    Google sounds interesting... what email address did you use?

    Btw. you can run Iris with a TRACE arguent when starting from shell. This effectively dumps most of the network traffic to the system log.
  • »31.03.18 - 00:17
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    defender
    Posts: 227 from 2011/4/24
    My fault in both mail accounts:

    for gmail sending: Authentication should be default not OAuth2 (I missunderstood the readme in that case)
    and I had to enable Iris as a 3rd party app in google mail

    for freenet sending: the account name must be the same as the email adress?! (however, it works now!)

    again, thanks for Iris
    PowerMac 3.6 - Radeon 9000_64Mb - 1,5Gb Ram - SB Live - MorphOS 3.9
    CD32 - PowerBook 1,67GHz 1GB/100GB - MorphOS 3 reg. 1455
  • »31.03.18 - 21:23
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Posts: 1575 from 2003/3/5
    From: Canada
    It should be OAuth, actually. You still didn’t tell me what email address you’ve used - was it from some domain different than gmail.com?
  • »31.03.18 - 21:37
    Profile Visit Website
  • ASiegel
    Posts: 933 from 2003/2/15
    From: Central Europe
    @ jacaDcaps

    In Germany, Google gave out googlemail.com addresses for many years due to a trademark dispute regarding "Gmail".
  • »31.03.18 - 21:49
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    defender
    Posts: 227 from 2011/4/24
    I tried my freenet account for sending a mail to gmail
    and the gmail account for sending a mail to freenet.

    @ASiegel

    I didn't know that this was a german exclusive change, thank you for clearing.




    [ Editiert durch defender 31.03.2018 - 23:04 ]
    PowerMac 3.6 - Radeon 9000_64Mb - 1,5Gb Ram - SB Live - MorphOS 3.9
    CD32 - PowerBook 1,67GHz 1GB/100GB - MorphOS 3 reg. 1455
  • »31.03.18 - 21:52
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Intuition
    Posts: 940 from 2013/5/24
    From: Englistan
    Quote:

    ASiegel wrote:
    @ jacaDcaps

    In Germany, Google gave out googlemail.com addresses for many years due to a trademark dispute regarding "Gmail".


    Was same in UK too. Was it an EU-wide thing?
    1.67GHz 15" PowerBook G4, 1GB RAM, 128MB Radeon 9700M Pro, 64GB SSD, MorphOS 3.9

    2.7GHz DP G5, 4GB RAM, 512MB Radeon X1950 Pro, OSX 10.5.8, 500GB SSHD, MorphOS 3.9
  • »01.04.18 - 01:32
    Profile
  • ASiegel
    Posts: 933 from 2003/2/15
    From: Central Europe
    Quote:

    Intuition wrote:
    Quote:

    ASiegel wrote:
    @ jacaDcaps

    In Germany, Google gave out googlemail.com addresses for many years due to a trademark dispute regarding "Gmail".


    Was same in UK too. Was it an EU-wide thing?

    "GoogleMail" has been used due to trademark issues in Germany, Poland, Russia, and the UK.
  • »01.04.18 - 07:39
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    NewSense
    Posts: 596 from 2012/11/10
    From: Manchester, Gr...
    I've tried it on MorphOS v3.9, where it is supposed to work, but it won't start/display any window/GUI - anyone else have similar observations with MorphOS v3.9? :-(

    [ Edited by NewSense 03.04.2018 - 06:31 ]
    Mac Mini 1.5GHz, Model 10.2, 64MB VRam, 250GB HDD, 1GB RAM, Airport, Bluetooth, Wireless Keyboard & Mouse, DVD-RW-DL+CD-RW, Iomega MiniMax, Belkin 6 port 3 x Firewire/3 x USB2, MorphOS 3.9, Mac OS X 10.4 & 10.5 & A1138 Powerbook MOS v3.9, Model 5,8 (Also
  • »03.04.18 - 06:30
    Profile
  • ASiegel
    Posts: 933 from 2003/2/15
    From: Central Europe
    Quote:

    NewSense wrote:
    I've tried it on MorphOS v3.9, where it is supposed to work

    It is absolutely not supposed to work on v3.9. Iris requires several key new features of v3.10 to run.

    The developer has clearly mentioned in this very discussion thread that he had to wait for 3.10 to be released before he could finally publish a beta version.
  • »03.04.18 - 07:53
    Profile
  • Just looking around
    Boingmax
    Posts: 12 from 2014/10/3
    Works great so far ... thanks !


    Missing:
    Toolbar
    Pinting / Save as PDF
    Copy & Paste - in Yam and Simple Mail Copy & Paste is SHIT!!!
    http://boingsworld.de Podcast "roundabout" Amiga
  • »03.04.18 - 13:40
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Posts: 1575 from 2003/3/5
    From: Canada
    Quote:

    NewSense wrote:
    I've tried it on MorphOS v3.9, where it is supposed to work


    The README.txt clearly states that 3.9 is unsupported.
  • »03.04.18 - 15:04
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Posts: 1575 from 2003/3/5
    From: Canada
    Quote:

    Boingmax wrote:
    Works great so far ...



    Thanks!

    Quote:


    Missing:
    Toolbar
    Pinting / Save as PDF
    Copy & Paste - in Yam and Simple Mail Copy & Paste is SHIT!!!



    Toolbar - maybe if Jobbo delivers an icon set like the one in Flow Studio :) I actually like the minimalist interface with no buttons.
    Printing - to be done.
    Copy & Paste - it's supported. rcommand + c/v should work just fine in email reader/writer.
  • »03.04.18 - 15:06
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    beworld
    Posts: 224 from 2010/2/10
    From: FRANCE
    My little test :

    - Missing Context menu (to Reply, transfert, delete ?!) or indeed toolbar
    - When Iris is checking IMAP server, it's impossible to read a email (multi task)
    PowerMac 2.7ghz MOS 3.10
    PowerBook 1.5Ghz MOS 3.10
    My MOS ports
  • »03.04.18 - 16:24
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Posts: 1575 from 2003/3/5
    From: Canada
    Quote:

    beworld wrote:
    - Missing Context menu (to Reply, transfert, delete ?!) or indeed toolbar



    All the options are available in the main menu, w/ hotkeys.

    Quote:


    - When Iris is checking IMAP server, it's impossible to read a email (multi task)



    Yeah, that will be mitigated in the next beta. Local storage will also solve that problem.
  • »03.04.18 - 17:26
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    beworld
    Posts: 224 from 2010/2/10
    From: FRANCE
    cool :-) thanks
    PowerMac 2.7ghz MOS 3.10
    PowerBook 1.5Ghz MOS 3.10
    My MOS ports
  • »03.04.18 - 17:39
    Profile Visit Website