Iris - An upcoming E-Mail client blog
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Amigaharry2
    Posts: 793 from 2010/1/6
    From: EU-Austria (Wien)
    Ahhh - Ok. I missunderstood! Now it works - Thank you!
    Peg2, 3xPowerMac G5, 2xPowerbookG4, 2x MacMiniG4, Efika (again), A3000T and life is never boring.....
  • »07.01.21 - 15:16
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Cool_amigaN
    Posts: 612 from 2011/11/30
    @Jaca,

    About the Wayfarer string, I mean, open Iris, select Check for Updates -> tada, surprise! :P
    Amiga gaming Tribute: Watch, rate, comment :)
  • »07.01.21 - 21:19
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Posts: 2269 from 2003/3/5
    From: Canada
    It's called re-using code. But yeah, fixed in the upcoming 0.104 (or so, 103 is currently in beta tests). I've added a way to map your old email backup folders from other applications right into Iris.
  • »23.01.21 - 21:40
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Posts: 2269 from 2003/3/5
    From: Canada
    Iris 0.104 is now available for download from iris-morphos.com. The new version makes it possible to map your email archives and folders of other email applications right into Iris. This release also fixes several crashes reported via the built-in bug reporting system.

    Do note that the Arexx port has changed from IRIS.1 to IRIS and needs to be adjusted in OpenURL settings!

    [ Edited by jacadcaps 24.01.2021 - 18:58 ]
  • »24.01.21 - 17:58
    Profile Visit Website
  • Paladin of the Pegasos
    Paladin of the Pegasos
    NewSense
    Posts: 1013 from 2012/11/10
    From: Manchester, UK/GB
    @ jacadcaps - you're THE . . . MAIL-man now, thanks for all your almost exhausting to watch workload and output, stand-by for a donation for all your efforts, BIG thanks ! 8-D
    MacMini 1.5GHz,10,2,64MB VRAM,1GB,Airport, Bluetooth,A1016 Keyboard,T-RB22 Mouse,DVD-RW-DL+CD-RW,Iomega MiniMax,Belkin 6 port 3 x Firewire/3 x, USB2, MorphOS 3.12, Mac OSX 10.4/10.5, A1138+A1139 PwrBk MOS v3.12,Model 5,8/5,9, & PowerMac G5 2.3GHz(DP)
  • »24.01.21 - 22:04
    Profile
  • MDW
  • Order of the Butterfly
    Order of the Butterfly
    MDW
    Posts: 312 from 2003/7/25
    From: Wroclaw/Poland
    Updated to 0.104. No problems.

    Iris 0.100+ rulez! :)
  • »25.01.21 - 08:22
    Profile Visit Website
  • MorphOS Developer
    jacadcaps
    Posts: 2269 from 2003/3/5
    From: Canada
    Thank you, NewSense and MDW.
  • »25.01.21 - 13:07
    Profile Visit Website
  • K-L
  • Just looking around
    K-L
    Posts: 14 from 2020/11/17
    From: Lyon, France
    Hello,

    Thanks for this update !

    Unfortunately, I still get crashes at closing of Iris (as you can see when I can send you the bugreport, since sometimes the whole system freezes when I click on "send bugreport").

    I don't know what is the cause of these regulars crashes.
    PowerMac G5 2,7 Ghz / Radeon 9650 / MorphOS 3.14
    AmigaOne X1000 (unused ATM)
  • »27.01.21 - 17:56
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Amigaharry2
    Posts: 793 from 2010/1/6
    From: EU-Austria (Wien)
    Got same problems closing IRIS after updating over old installation - busy-bar runs forever. Installed completly new from scratch and now it works.But takes a relative long time to close (busy-bar!).

    Btw:
    I also did a new installation and copied "Settings"-directory fom old installation there: works exactly one time! Next time same behavieour.
    Peg2, 3xPowerMac G5, 2xPowerbookG4, 2x MacMiniG4, Efika (again), A3000T and life is never boring.....
  • »27.01.21 - 18:46
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2269 from 2003/3/5
    From: Canada
    Quote:

    K-L wrote:
    Unfortunately, I still get crashes at closing of Iris (as you can see when I can send you the bugreport, since sometimes the whole system freezes when I click on "send bugreport").

    I don't know what is the cause of these regulars crashes.


    Yeah, I know you do. I've had a look at the crashes and so far all I can say is that something (not necessarily Iris) is trashing memory. It would help if you could try to start it a couple of times with nothing running except Ambient - I see you have OWB, Hollywood stuff, MagicBeacon and many many other things running at the time of the crash. That doesn't make it easier in pin-pointing the issue.

    Also, run memtest extensive to check your memory.

    [ Edited by jacadcaps 28.01.2021 - 00:12 ]
  • »27.01.21 - 21:52
    Profile Visit Website
  • K-L
  • Just looking around
    K-L
    Posts: 14 from 2020/11/17
    From: Lyon, France
    Quote:

    jacadcaps a écrit :
    It would help if you could try to start it a couple of times with nothing running except Ambient - I see you have OWB, Hollywood stuff, MagicBeacon and many many other things running at the time of the crash. That doesn't make it easier in pin-pointing the issue.

    Also, run memtest extensive to check your memory.

    [ Edited by jacadcaps 28.01.2021 - 00:12 ]


    No problem, I'll make extensive tests without third party softwares.
    PowerMac G5 2,7 Ghz / Radeon 9650 / MorphOS 3.14
    AmigaOne X1000 (unused ATM)
  • »28.01.21 - 06:34
    Profile